BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-06-2009, 10:23 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2009
Model: 9700
OS: 6.0.0.461
PIN: N/A
Carrier: Rogers
Posts: 41
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES 5.0 and Exchange 2010

Please Login to Remove!

Recently I have deployed some servers with the Exchange 2010 beta running on Server 2008 for testing the beta before it goes public. Currently RIM does not officially support Exchange 2010 with the BES but I was wondering if anyone had gotten or seen a working instance of BES and Exchange 2010.

Currently BES 5.0 will connect to Exchange 2010 with no problem in cdomapi32.dll however when I try to EA a user the user doesn't recieve the full activation email and the BlackBerry device shows: Activating [email address]...
Retrying...
Retrying...

Then it gives a generic error. I have looked into this issue and BlackBerry has suggested it is because the EAP.dat file does not get to the users inbox. It does, however the nicely formatted activation email doesn't seem to.

Do any BES experts either know what I might be doing wrong or can blatantly tell me a reason why Exchange 2010 wouldn't work on BES. E14 just seems so similar to 2007 in terms of UI and Infrastructure.

I appreciate any help I can get.
Offline  
Old 08-06-2009, 11:59 PM   #2 (permalink)
Knows Where the Search Button Is
 
Neo3000's Avatar
 
Join Date: Jul 2008
Model: 9000
PIN: N/A
Carrier: TMO
Posts: 32
Post Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs down Currently no chance

Hi,

I am interested in using BES5 with E14, too. The problems are known to MS and RIM.
Be patient afaik a working version of both E14 and BES will be available soon

Greetings,
Neo3000
__________________
BES 4.1.7 (20 servers), Domino 7.0.3 with 19000+ users
BES 5.0.2 (8 server), Exchange 2010 SP1 with 1000+ users
Offline  
Old 08-07-2009, 12:01 AM   #3 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you properly setup permissions per the 5.0 install guide? ...

E14 just seems so similar to 2007 in terms of UI and Infrastructure.

Umm ... yeah maybe UI; that's like saying Windows ME is like XP.
Offline  
Old 08-07-2009, 12:08 AM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2009
Model: 9700
OS: 6.0.0.461
PIN: N/A
Carrier: Rogers
Posts: 41
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well I think the biggest difference between the two is the Exchange 2010 (from a management perspective) is alway remote. When you load up the Exchange Management Console even on the same server as the Roles it accesses Exchange 2010 as if it was on another server. I know this because I had a huge Exchange 2010 beta issue where changing the certificate wouldn't let me access EMC.

And in terms of permissions. Yes I did do them properly. It is not my first BES Install either (and I have redone this BES and E14 twice) so I thought it might be something more then coincidence.
Offline  
Old 08-07-2009, 07:15 AM   #5 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

does anything show up in the BES logs with regards to the activation? if the message is just sitting there its either an E2010 thing that hasn't been implemented in BES yet, or permissions aren't properly set.
Offline  
Old 08-07-2009, 08:57 PM   #6 (permalink)
BlackBerry God
 
jibi's Avatar
 
Join Date: Oct 2004
Location: Jibi's Secret Place
Model: 8900
OS: 4.6.1.174
Carrier: AT&T
Posts: 11,310
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

From what I've heard through the grapevine, E14 will be officially supported with SP2, which is due out early next year (likely around WES time frame). Exchange Calendar Web Services, Exchange Web Services, no direct access to the mailboxes, etc. If you can get it working with BES 5.0 or BES 5.0 SP1, please let us know
__________________
In the beginning the Universe was created. This has made a lot of people very angry and is widely regarded as a bad move.
Offline  
Old 08-09-2009, 06:25 PM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2009
Model: 9700
OS: 6.0.0.461
PIN: N/A
Carrier: Rogers
Posts: 41
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well I am rebuilding my BES 5.0 tomorrow for the last time and this time going to make sure every single permission is perfect. There may have been an error before.

In terms of SP1/SP2. I didn't even know there was an SP1 released for BES 5.0 yet.
Offline  
Old 08-10-2009, 06:41 PM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2009
Model: 9700
OS: 6.0.0.461
PIN: N/A
Carrier: Rogers
Posts: 41
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

After installing BES 5.0 and verifying permissions today I can report that I cannot get it working with Exchange. When the BESAdmin tries to send an activation email it just never ends up in the users mailbox.
Offline  
Old 08-13-2009, 06:15 AM   #9 (permalink)
New Member
 
Join Date: Jan 2007
Model: 8100
Carrier: Orange
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Send As Right for BESAdmin

Have you made sure you have send as rights on the BESAdmin user?
You can check this by typing
get-mailboxserver <Exchange2007> | get-ADpermission -user <BESAdmin> | Format-List

I can't set 'send as' rights for my BESAdmin user for some reason, how did you go about doing that?

I am currently working on the same thing, I don't see any reason why this should not work.

Regards
Offline  
Old 08-13-2009, 09:04 PM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2009
Model: 9700
OS: 6.0.0.461
PIN: N/A
Carrier: Rogers
Posts: 41
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default SendAs permission

Thats a good point. When I run the command I do not see "SendAs" listed.
PS] C:\Windows\System32>get-mailboxserver MAIL | get-ADpermission -user BESAdmi
n | Format-List


User : LIFETECH\BESAdmin
Identity : MAIL
Deny : False
AccessRights : {Self, WriteProperty, GenericRead}
ExtendedRights :
IsInherited : False
Properties :
ChildObjectTypes :
InheritedObjectType :
InheritanceType : All

User : LIFETECH\BESAdmin
Identity : MAIL
Deny : False
AccessRights : {ExtendedRight}
ExtendedRights :
IsInherited : False
Properties :
ChildObjectTypes :
InheritedObjectType :
InheritanceType : All

User : LIFETECH\BESAdmin
Identity : MAIL
Deny : False
AccessRights : {ExtendedRight}
ExtendedRights :
IsInherited : False
Properties :
ChildObjectTypes :
InheritedObjectType :
InheritanceType : All

User : LIFETECH\BESAdmin
Identity : MAIL
Deny : False
AccessRights : {ExtendedRight}
ExtendedRights :
IsInherited : False
Properties :
ChildObjectTypes :
InheritedObjectType :
InheritanceType : All

Were you having an issue with the SendAs on the Exchange server or on AD?
Offline  
Old 08-20-2009, 02:12 PM   #11 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2009
Model: 9700
OS: 6.0.0.461
PIN: N/A
Carrier: Rogers
Posts: 41
Post Thanks: 0
Thanked 0 Times in 0 Posts
Smile UPDATE: It will work

On Tuesday Microsoft announced the Release Candidate for Exchange Server 2010 which is feature complete. Previous to this, the public beta would not work with any other versions of Exchange. The RC will work with 2003 OTB and will work with Exchange 2007 SP2 (unreleased) when the Service Pack comes out. The good news is that the service pack is coming out early next week. This means you will be able to deploy Exchange 2010 RC (and direct upgrade to RTM is supported) and also deploy 2007 for the BES to interact with.

My only question to senior BESAdmins is what roles will be required for the BES to communicate with 2007. Just the mailbox role?
Offline  
Old 08-20-2009, 05:05 PM   #12 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

You'll need the CAS role too as there is no direct client <> mailbox server communication ... it all goes through a CAS
Offline  
Old 08-21-2009, 01:45 AM   #13 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2009
Model: 9700
OS: 6.0.0.461
PIN: N/A
Carrier: Rogers
Posts: 41
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks.

So CAS 2007 SP2 and Mailbox SP2.

I will let you guys all know how it goes and details of my install.
Offline  
Old 08-21-2009, 06:39 PM   #14 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2009
Model: 9700
OS: 6.0.0.461
PIN: N/A
Carrier: Rogers
Posts: 41
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Or would you be able to get away just with a CAS role in 2007 and get away with using the 2010 mailbox? (To reduce server load)
Offline  
Old 08-22-2009, 11:19 AM   #15 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Oy, sorry ... I read your question incorrectly.

For Exchange 2007 you only need the mailbox role. BES doesn't need a CAS role to communicate with an Exchange 2007 mailbox server, as you can talk direct MAPI/RPC to that server.

For Exchange 2010 you'll need a CAS to communicate with a mailbox server as there is no direct MAPI/RPC communication with a mailbox server ... all goes through a CAS.

Sorry for the confusion.
Offline  
Old 08-22-2009, 02:57 PM   #16 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2009
Model: 9700
OS: 6.0.0.461
PIN: N/A
Carrier: Rogers
Posts: 41
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK. Thanks. So for my current environment I will be using a 2007 MB server for communication to BES. But when BES has a SP upgrade and it natively supports 2010 and I remove the 2007 servers I do need a MB and CAS minimum for communication to the BES.
Offline  
Old 08-22-2009, 03:04 PM   #17 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

correct.
Offline  
Old 08-23-2009, 05:08 PM   #18 (permalink)
BlackBerry God
 
jibi's Avatar
 
Join Date: Oct 2004
Location: Jibi's Secret Place
Model: 8900
OS: 4.6.1.174
Carrier: AT&T
Posts: 11,310
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

So you're going to respond back on Tuesday to let us know if it worked or didn't work?
__________________
In the beginning the Universe was created. This has made a lot of people very angry and is widely regarded as a bad move.
Offline  
Old 08-25-2009, 01:35 PM   #19 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2009
Model: 9700
OS: 6.0.0.461
PIN: N/A
Carrier: Rogers
Posts: 41
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have to wait until Microsoft releases Exchange Server 2007 SP2. They said "early this week". So I hope they will release it today or tomorrow. If they do I will probably have it up by Thurs/Fri. So if they are on time I will respond by the weekend.
Offline  
Old 08-25-2009, 01:40 PM   #20 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,631
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

it is out now http://www.microsoft.com/downloads/d...b-2cc9afe3216a
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.