BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   Blackberry Manager falsely reporting application status up to date (http://www.blackberryforums.com/bes-admin-corner/201197-blackberry-manager-falsely-reporting-application-status-up-date.html)

niceonedave 08-17-2009 10:46 AM

Blackberry Manager falsely reporting application status up to date
 
I am trying to push an app out to a 8900 device OTA. I have set everything up (added software configuration, set it to wireless, set disposition to mandatory added it to user etc). Now when I select Update Configuration Check Status it tells me the Application Status is Up To Date. I don't see how this can possibly be since the application has never been installed on the device. I even tried creating a new version of the app and giving it a higher version number but it still reports that the Application is Up To Date.

Anyone got any ideas why this might be? I have pushed the same app out to other devices (8800) before and it worked fine.

penguin3107 08-17-2009 11:02 AM

Make sure your device.xml file on the BES is current.
KB13589 - How to update the device.xml and vendor.xml files - Port3101.org : Your BES Connection

niceonedave 08-17-2009 11:16 AM

This was an issue. When I first tried to push the app the blackberry manager complained that the device wasn't specified in the device.xml file. So I updated the file and after that it didn't complain, and I started getting the problem I have now.

niceonedave 08-17-2009 11:55 AM

I don't know exactly what the device.xml and vendor.xml files are used for, but I have had a look at the files I have and this is what I have noticed.

In device.xml there is an entry for my device, the 8900:

<os model="8900" radio="GPRS-WLAN" series="Javelin" Colour="True" Theme="Normal" JVMLevel="1.0" Camera="True" VideoRecorder="True" VoiceNotes="True" pttApp="True" Memory="Large" KeyboardType="Qwerty" Sound="Tunes8700g" SystemSize="normal" Bluetooth="True" MMS="True" GPS="True" ThemeSupport="Enhanced" VAD="True" JPN_Input="True">0x84001503</os>

The hardware ID 0x84001503 matches up with what the blackberry manager says for this device.

The blackberry manager also reports platform version 4.2.0.94 and blackberry version 4.6.1.168. In the vendor.xml file I can find an entry under Vodafone (which is the Network I am on)

<bundle id="System" version="4.6.1.176">
<devicehwid>0x84001503</devicehwid>
</bundle>

But as you can see the version number here is different from the blackberry version reported in the Blackberry Manager. Is this something that I should be concerned about? Should there be an entry that matches my blackberry version and hardware ID?

niceonedave 08-18-2009 03:32 AM

Does anyone else know of any problems pushing an app OTA to a 8900 device? My BES version is 4.1.5.24

Thanks

penguin3107 08-18-2009 05:59 AM

Are you sure the app you're trying to push is compatible with the OS on the device?

Have you checked the handheld to see if multiple modules (different versions) exist for the same application?

Have you looked in your POLC logs to see if there's any indication of what the problem might be?

Have you tried wiping the handheld and reactivating?

niceonedave 08-18-2009 06:49 AM

Thanks for the response:

The app is compatible with the device as we have succesfully installed it over USB using javaloader.

We have been testing with multiple devices many fresh out of the box, so no previous version of the app has ever been installed on it.

We have also been wiping and reactivating devices a lot and still no luck. Only this model (8900) gives us problems, when we try a different model it works fine.

What sort of things should we be looking out for in the log? I have checked them and I see no obvious errors.

Here is a snippet of the log that should include the time when I tried doing Deploy Applications:

[40000] (08/17 16:15:46.235):{0xD94} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::DoWork - Completed Processing NEW_MESSAGE request
[40000] (08/17 16:16:46.220):{0xD7C} [BIPP] Ping 16079 sent
[40000] (08/17 16:16:46.220):{0xD78} [BIPP] PingResponse 16079 received
[40000] (08/17 16:17:46.236):{0xD7C} [BIPP] Ping 16080 sent
[40000] (08/17 16:17:46.236):{0xD78} [BIPP] PingResponse 16080 received
[40000] (08/17 16:18:46.252):{0xD7C} [BIPP] Ping 16081 sent
[40000] (08/17 16:18:46.252):{0xD78} [BIPP] PingResponse 16081 received
[45050] (08/17 16:19:18.752):{0xD9C} DBNS: DbObject=500
[40000] (08/17 16:19:19.752):{0xFDC} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}SCS::PollDBQueueNewRequests - Queuing POLL_FOR_MISSING_APPS request
[45050] (08/17 16:19:19.846):{0xD9C} DBNS: DbObject=500
[40000] (08/17 16:19:29.643):{0xD88} RequestHandler::PollForMissingApps: Starting Poll For Missing Apps.
[40304] (08/17 16:19:29.643):{0xD84} WorkerThreadPool:: ThreadProc(): Thread released with empty queue
[40000] (08/17 16:19:29.643):{0xD88} SCS::RemoveAppDeliveryRequests - No App Delivery Requests purged for User id 2
[40000] (08/17 16:19:32.174):{0xD88} RequestHandler::PollForMissingApps: Completed Poll For Missing Apps, elapsed time 2.516 seconds.
[45050] (08/17 16:19:32.190):{0xD9C} DBNS: DbObject=500
[40000] (08/17 16:19:46.268):{0xD7C} [BIPP] Ping 16082 sent
[40000] (08/17 16:19:46.268):{0xD78} [BIPP] PingResponse 16082 received
[40000] (08/17 16:20:46.268):{0xD7C} [BIPP] Ping 16083 sent
[40000] (08/17 16:20:46.268):{0xD78} [BIPP] PingResponse 16083 received
[40000] (08/17 16:21:46.269):{0xD7C} [BIPP] Ping 16084 sent
[40000] (08/17 16:21:46.269):{0xD78} [BIPP] PingResponse 16084 received
[45050] (08/17 16:21:53.378):{0xD9C} DBNS: DbObject=800
[40000] (08/17 16:22:35.769):{0xD98} RequestHandler::DoWork - Processing CHECK_FOR_USERCONFIG_CHANGES request
[40000] (08/17 16:22:35.785):{0xD98} RequestHandler::DoWork - Completed Processing CHECK_FOR_USERCONFIG_CHANGES request
[40304] (08/17 16:22:35.785):{0xD98} WorkerThreadPool:: ThreadProc(): Thread released with empty queue
[40000] (08/17 16:22:46.269):{0xD7C} [BIPP] Ping 16085 sent
[40000] (08/17 16:22:46.269):{0xD78} [BIPP] PingResponse 16085 received
[45050] (08/17 16:22:49.238):{0xD9C} DBNS: DbObject=800
[45050] (08/17 16:23:11.644):{0xD9C} DBNS: DbObject=800
[40000] (08/17 16:23:28.769):{0xD98} RequestHandler::DoWork - Processing CHECK_FOR_USERCONFIG_CHANGES request
[40000] (08/17 16:23:28.801):{0xD98} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}SCS::CheckDBforITPolicyChanges - Queuing SET_ITPOLICY_REQUEST request, ITPolicyId 1
[40000] (08/17 16:23:28.832):{0xD98} RequestHandler::DoWork - Completed Processing CHECK_FOR_USERCONFIG_CHANGES request
[40304] (08/17 16:23:28.832):{0xD98} WorkerThreadPool:: ThreadProc(): Thread released with empty queue
[45050] (08/17 16:23:28.910):{0xD9C} DBNS: DbObject=500
[45050] (08/17 16:23:29.910):{0xD9C} DBNS: DbObject=500
[40000] (08/17 16:23:29.926):{0xFDC} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}SCS::PollDBQueueNewRequests - Queuing SET_ITPOLICY_REQUEST request
[45050] (08/17 16:23:33.660):{0xD9C} DBNS: DbObject=800
[40000] (08/17 16:23:34.660):{0xD8C} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::DoWork - Processing SET_ITPOLICY_REQUEST request
[40304] (08/17 16:23:34.660):{0xD90} WorkerThreadPool:: ThreadProc(): Thread released with empty queue
[45050] (08/17 16:23:34.660):{0xD9C} DBNS: DbObject=500
[40000] (08/17 16:23:34.676):{0xD8C} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::SendToRelay - SubmitToRelaySendQ, Tag=1452
[40000] (08/17 16:23:34.676):{0xD7C} [BIPP] Send cancel, Tag=1452
[30000] (08/17 16:23:34.691):{0xD8C} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::SendQueuedITAdminCommandT oDevice Sending data to device, contentType=ITADMIN, size=788, RefId=0, TransactionId=-897930499, Tag=1453
[40000] (08/17 16:23:34.691):{0xD8C} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::SendToRelay - SubmitToRelaySendQ, Tag=1453
[40000] (08/17 16:23:34.691):{0xD7C} [BIPP] Send data, Tag=1453
[40000] (08/17 16:23:34.691):{0xD8C} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::DoWork - Completed Processing SET_ITPOLICY_REQUEST request
[45050] (08/17 16:23:34.816):{0xD9C} DBNS: DbObject=500
[40000] (08/17 16:23:36.582):{0xD78} [BIPP] Received status DELIVERED, Tag=1453
[40000] (08/17 16:23:36.582):{0xD94} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::DoWork - Processing DEVICE_SEND_STATUS_EVENT request
[30000] (08/17 16:23:36.582):{0xD94} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::DoDeviceSentProcessing - Message has been delivered to device, Tag=1453
[40000] (08/17 16:23:36.582):{0xD94} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::DoITPolicyDeviceSentProce ssing - ITPolicy GME Receive Ack for the command SET_IT_POLICY_COMMAND - Processing packet, Tag=1453
[45050] (08/17 16:23:36.597):{0xD9C} DBNS: DbObject=500
[40000] (08/17 16:23:36.613):{0xD94} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::DoWork - Completed Processing DEVICE_SEND_STATUS_EVENT request
[40000] (08/17 16:23:41.113):{0xD78} [BIPP] Received datagram, Tag=20182703
[40000] (08/17 16:23:41.113):{0xD84} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::DoWork - Processing NEW_MESSAGE request
[40000] (08/17 16:23:41.113):{0xD84} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::DoGMEReceiveProcessing - Receiving packet from device, size=46, TransactionId=12632148, Tag=20182703, content type=ITADMIN, cmd=0x3
[40000] (08/17 16:23:41.113):{0xD84} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::HandleITADMINDataCommand - ITPolicy Success Ack for the command SET_IT_POLICY_COMMAND - Processing packet, Tag=20182703
[40000] (08/17 16:23:41.129):{0xD84} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::SendToRelay - SubmitToRelaySendQ, Tag=20182703
[40000] (08/17 16:23:41.129):{0xD7C} [BIPP] Send status DATA_ACCEPTED, Tag=20182703
[40000] (08/17 16:23:41.129):{0xD84} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::DoWork - Completed Processing NEW_MESSAGE request
[45050] (08/17 16:23:41.176):{0xD9C} DBNS: DbObject=500
[40000] (08/17 16:23:44.285):{0xD78} [BIPP] Received datagram, Tag=20182704
[40000] (08/17 16:23:44.285):{0xD88} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::DoWork - Processing NEW_MESSAGE request
[40000] (08/17 16:23:44.285):{0xD88} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::DoGMEReceiveProcessing - Receiving packet from device, size=388, TransactionId=12632150, Tag=20182704, content type=OTASL, cmd=0x3
[40000] (08/17 16:23:44.301):{0xD88} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::SendToRelay - SubmitToRelaySendQ, Tag=20182704
[40000] (08/17 16:23:44.301):{0xD7C} [BIPP] Send status DATA_ACCEPTED, Tag=20182704
[40000] (08/17 16:23:44.301):{0xD88} {chriso@test.beatsystems.com, PIN=20F27472, UserId=2}RequestHandler::DoWork - Completed Processing NEW_MESSAGE request
[40000] (08/17 16:24:21.770):{0xD98} RequestHandler::DoWork - Processing CHECK_FOR_USERCONFIG_CHANGES request
[40000] (08/17 16:24:21.801):{0xD98} RequestHandler::DoWork - Completed Processing CHECK_FOR_USERCONFIG_CHANGES request
[40304] (08/17 16:24:21.801):{0xD98} WorkerThreadPool:: ThreadProc(): Thread released with empty queue
[45051] (08/17 16:24:34.098):{0xD9C} DBNS: renewed subscription, heartbeat 45957
[30181] (08/17 16:24:38.192):{0xD80} Performing system health check (BlackBerry Enterprise Server [BlackBerryPolicyServer Version 4.1.5.29] - BES [POLC] - Exchange)
[40000] (08/17 16:24:44.301):{0xD7C} [BIPP] Ping 16086 sent
[40000] (08/17 16:24:44.301):{0xD78} [BIPP] PingResponse 16086 received
[40000] (08/17 16:24:44.520):{0xD84} RequestHandler::DoWork - Processing CHECK_FLOW_CONTROL_QUEUE request
[40304] (08/17 16:24:44.520):{0xD88} WorkerThreadPool:: ThreadProc(): Thread released with empty queue
[40000] (08/17 16:25:44.317):{0xD7C} [BIPP] Ping 16087 sent

freakinvibe 08-18-2009 07:17 AM

The "Update configuration check status" compares the assigned application configuration for a specified user to the contents of the SyncDeviceManagement table in the database. So it does not actually look on the device itself.

You also have to check the other statuses, they should look like:

Configuration Status: OK
System Status: Up to date
Application Status: Up to date

Also, how did you make sure that the application is not installed? Have you looked in the Options > Application

You should also check the User Properties > Blackberry device > Applications on the BES. Is the app listed there?

hdawg 08-18-2009 07:23 AM

What ^ said. Check the module list too. Perhaps it is getting partially installed ...

niceonedave 08-20-2009 05:16 AM

I have checked the application list for the device on the BES and it is not there. I have checked the module list too and none of the modules that are part of the software configuration are in there either.

I have checked the database and none of the modules are listed in there at all.

The other statuses are:

Configuration Status: OK
System Status: Up to date
Application Status: Up to date

Any other ideas??

freakinvibe 08-20-2009 08:04 AM

Have you really checked the SyncDeviceManagement table and filtered for your UserConfigId (which is 2, according to your logs). You can do an SQL statement like

SELECT Id, UserConfigId, TableId, Data, Status, ModuleName, ModuleVersion, ModuleSize
FROM SyncDeviceMgmt
WHERE UserConfigId = 2

You should now see all the modules that the BES thinks are on your device.

niceonedave 08-20-2009 09:01 AM

There is only one user on our BES, so I didn't need to filter by the UserConfigId, but there are over 800 pages of results when I do it, so I used the following SQL instead:

SELECT Id, UserConfigId, TableId, Guid, RecordTimeStamp, Data, Status, ServerTime, State, Lurnum, ModuleName, ModuleVersion, ModuleSize
FROM SyncDeviceMgmt
WHERE (ModuleName LIKE '%com%')

This returned 3 modules, none of which are included in our application.

To make sure my SQL was working fine I activated a different device for the user, pushed the app out to that device and ran the SQL again, this time all of the modules from our app appeared in the result.

So I am absolutely 100% sure that I checked the database for the relevant modules and they aren't there.

niceonedave 08-21-2009 05:07 AM

Still struggling with this if anyone has any more suggestions??

niceonedave 08-21-2009 06:05 AM

I found the answer myself :D I thought I would share it here in case anyone else was experiencing similar problems.

Basically the ALX file specified radio="GPRS" but the device.xml for the 8900 specified radio="GPRS-WLAN", so I guess the BES didn't like the inconsistency. Since I am using the same ALX file to push to lots of different devices, I decided not to change the radio to GPRS-WLAN, instead I just deleted it alltogether, and straight away the BES reported Install Required and I was able to push the app.

A side question then: is the line radio="..." actually required in the ALX file? I don't know why it was there, somebody else in the team set up the build script that creates these files when we do a release. Can I just remove it and therefore not care in the future what type of device I am trying to deploy to?

hdawg 08-22-2009 11:13 AM

It isn't required ... it is there to limit the devices that the app will be pushed to. If the app will work on any device radio then you can remove it.


All times are GMT -5. The time now is 11:54 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.