BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-01-2009, 05:15 PM   #1 (permalink)
New Member
 
Join Date: Jun 2009
Model: 900
PIN: N/A
Carrier: Cable & Wireless Panama
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Send As Problem BES 5 + Exch2K

Please Login to Remove!

Hi,
I'm having issues with the send as permissions. (Exch 2K + BES 5).
Here are the results of the IEMSTest.exe tool.
Any clue about that??
king regards!
C.

C:\Documents and Settings\besadmin>"C:\Download\BlackBerry Enterprise Server 50\
tools\IEMSTest.exe"
BlackBerry Enterprise Server Utility - IEMSTest.exe (IExchangeManageStore), Vers
ion 1.0
Copyright (c) Research In Motion, Ltd. 1999. All rights reserved.
Opening Default Message Store Mailbox - Blackberry Users

Vanessa C▀rdenas: Opening message store using
/o=Caja de Ahorros/ou=CAJADEAHORROS/cn=Recipients/cn=VanessaC
/O=Caja de Ahorros/OU=CAJADEAHORROS/cn=Configuration/cn=Servers/cn=TSIAP
P90/cn=Microsoft Private MDB
Vanessa C▀rdenas: Mailbox opened successfully
Vanessa C▀rdenas: Root Folder opened successfully
Vanessa C▀rdenas: Folder created successfully
Vanessa C▀rdenas: Test folder deleted successfully
Vanessa C▀rdenas: MAPI test completed successfully
Vanessa C▀rdenas: CDO Server Name: TSIAPP90
Vanessa C▀rdenas: CDO Mailbox DN: /o=Caja de Ahorros/ou=CAJADEAHORROS/cn=Recipie
nts/cn=VanessaC
Vanessa C▀rdenas: CDO logon successful
Vanessa C▀rdenas: Get default calendar folder successful
Vanessa C▀rdenas: Get calendar folder name successful: 'Calendar'
Vanessa C▀rdenas: CDO test completed successfully
Vanessa C▀rdenas: No Send As permission for the {CAJADEAHORROS\besadmin} account
operator.
Offline  
Old 09-01-2009, 07:20 PM   #2 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Passp
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,753
Post Thanks: 274
Thanked 296 Times in 280 Posts
Default

Did you do this step?

To assign Microsoft Exchange Server permissions at the Microsoft Exchange Server level, complete the following steps:

For Microsoft Exchange 2000 or 2003

Click Start > Programs > Microsoft Exchange > System Manager.
Select Administrative Groups > First Administrative Group > Servers.
Right-click the Microsoft Exchange Server name and then click Properties.
On the Security tab, select the BlackBerry Enterprise Server service account.
Select the following permissions from the Permissions list:

Administer Information Store
Send As
Receive As
Click the Advanced button.
Verify that the Select the Allow inheritable permissions from parent to propagate to this object and all child objects option is selected.
Click OK.
Repeat the preceding steps for each Microsoft Exchange Server that will host mailboxes within the routing group.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Passport, Z30, Z10 and Q10
Offline  
Old 09-01-2009, 07:46 PM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,362
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

Do you have actual problems, or, are you "only" nervous because of this message ?

When I first installed BES5 and my Exchange2K server, I also had this kind of error, however, everything is working perfect. I also checked the permissions twice, they are correct.
Even, when I upgraded to Exchange2k7, the utility still will give the error.
I checked again the permissions, they are correct.
And, whats more important, the Server works perfect.
So, I started to ignore the error.


Code:
C:\Programme\Research In Motion\BlackBerry Enterprise Server\Utility>iemstest
BlackBerry Enterprise Server Utility - IEMSTest.exe (IExchangeManageStore), Vers
ion 1.0
Copyright (c) Research In Motion, Ltd. 1999. All rights reserved.
Opening Default Message Store Mailbox - Admin Blackberry

TheUser User: Opening message store using
        /o=my-organisation/ou=First Administrative Group/cn=Recipients/cn=TheUser
        /o=my-organisation/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Confi
guration/cn=Servers/cn=VM/cn=Microsoft Private MDB
TheUser User: Mailbox opened successfully
TheUser User: Root Folder opened successfully
TheUser User: Folder created successfully
TheUser User: Test folder deleted successfully
TheUser User: MAPI test completed successfully
TheUser User: CDO Server Name: VM
TheUser User: CDO Mailbox DN: /o=my-organisation/ou=First Administrative Group/cn=
Recipients/cn=TheUser
TheUser User: CDO logon successful
TheUser User: Get default calendar folder successful
TheUser User: Get calendar folder name successful: 'Calendar'
TheUser User: CDO test completed successfully
TheUser User: No Send As permission for the {my-organisation\besadmin} account ope
rator.

C:\Programme\Research In Motion\BlackBerry Enterprise Server\Utility>

Last edited by nobody7290 : 09-01-2009 at 07:52 PM.
Offline  
Old 09-02-2009, 07:57 AM   #4 (permalink)
New Member
 
Join Date: Jun 2009
Model: 900
PIN: N/A
Carrier: Cable & Wireless Panama
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the replay!!
knottyrope, I did it!!, I even used the xxx8220;send asxxx8221; tool from RIM. I checked the permissions and everything seems OK. I did 5 successful installations of BES 5 before (but never with Ex2K btw)xxx8230; any other suggestions??
nobody7290, I have a problem!, I canxxx8217;t activate users wirelesslyxxx8230; the ETP mail remains in the user mailbox, BES didnxxx8217;t capture itxxx8230;.
I truly appreciate your replaysxxx8230; thanks!
King Regards
C.
Offline  
Old 09-02-2009, 04:53 PM   #5 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,362
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

Do all your users inherit the permissions from the parent Objects ?
In active Directory and users, under View, check Advanced functions,
now, open the properties of a user, under Security, advanced, you can see all permissions to the user account.
There is also a button like "reset to default settings"

From here you also can check the effective permissions to a users mailbox. Choose the besadmin account to verify and check if the "receive as" and "send as" permissions are checked for a user account.


Did you also check that besadmin is a normal domain user, and not member of any special security group ? And, your users also ?

If this is all ok, I think the problem with the etp.dat sitting in the users mailbox has a different reason.

Last edited by nobody7290 : 09-02-2009 at 04:56 PM.
Offline  
Old 09-02-2009, 05:36 PM   #6 (permalink)
New Member
 
Join Date: Jun 2009
Model: 900
PIN: N/A
Carrier: Cable & Wireless Panama
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

nobody7290, Thanks for the replay!!
The problem was solved!! I had different versions of the cdo.dll in my BES and in my Exchange Server. Now everything goes OK, and, as you told me before, still appears the message xxx8220;No Send As permission for thexxx8230;xxx8221; in the IEMSTest.exe tool.
Thanks a lot for your hints and your time!
KRegards
C.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright ę 2004-2014 BlackBerryForums.com.
The names RIM ę and BlackBerry ę are registered Trademarks of BlackBerry Inc.