BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   SSL Ceritificate Issue on connecting to MDS services through https (http://www.blackberryforums.com/bes-admin-corner/203300-ssl-ceritificate-issue-connecting-mds-services-through-https.html)

pgoeol 09-05-2009 07:15 AM

SSL Ceritificate Issue on connecting to MDS services through https
 
Hi,

I'm unable to connect to MDS services through https, Blackberry Manager asks to install SSL certificate. Then it asks me to submit the login id and password but it does not accept the provided authentication data.

Following error logs get generated on Tomcat server:

[ERROR][2009-09-05 17:29:48,187][[Catalina]]Exception performing authentication
org.apache.tomcat.dbcp.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (The connection to the named instance has failed. Error: java.net.SocketTimeoutException: Receive timed out.)
at org.apache.tomcat.dbcp.dbcp.BasicDataSource.create DataSource(BasicDataSource.java:855)
at org.apache.tomcat.dbcp.dbcp.BasicDataSource.getCon nection(BasicDataSource.java:540)
at org.apache.catalina.realm.DataSourceRealm.open(Dat aSourceRealm.java:402)
at org.apache.catalina.realm.DataSourceRealm.authenti cate(DataSourceRealm.java:282)
at org.apache.catalina.authenticator.BasicAuthenticat or.authenticate(BasicAuthenticator.java:181)
at org.apache.catalina.authenticator.AuthenticatorBas e.invoke(AuthenticatorBase.java:446)
at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:126)
at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.j
ava:105)
at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:107)
at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:148)
at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:856)
at org.apache.coyote.http11.Http11Protocol$Http11Conn ectionHandler.processConnection(Http11Protocol.jav a:744)
at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java:527)
at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:80)
at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:684)
at java.lang.Thread.run(Thread.java:595)
Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: The connection to the named instance has failed. Error: java.net.SocketTimeoutException: Receive timed out.
at com.microsoft.sqlserver.jdbc.SQLServerException.ma keFromDriverError(U
nknown Source)
at com.microsoft.sqlserver.jdbc.SQLServerConnection.g etInstancePort(Unknown Source)
at com.microsoft.sqlserver.jdbc.SQLServerConnection.c onnect(Unknown Source)
at com.microsoft.sqlserver.jdbc.SQLServerDriver.conne ct(Unknown Source)
at org.apache.tomcat.dbcp.dbcp.DriverConnectionFactor y.createConnection(
DriverConnectionFactory.java:37)
at org.apache.tomcat.dbcp.dbcp.PoolableConnectionFact ory.makeObject(Pool
ableConnectionFactory.java:290)
at org.apache.tomcat.dbcp.dbcp.BasicDataSource.valida teConnectionFactory
(BasicDataSource.java:877)
at org.apache.tomcat.dbcp.dbcp.BasicDataSource.create DataSource(BasicDataSource.java:851)
... 15 more


I've searched for this issue on various forums but nothing helped me out.

I've already tried updating keystore (server.key) with FQDN
Also checked for the WSAdminPassword value stored in MDSAGConfig table and it is also seems to be correct.

Please help me out of this issue, I've already a lot of time fixing it.

Thanks...

pgoeol 09-07-2009 02:33 AM

hi...

finally solved the issue... after spending so much of time I've figured out that it was a configuration issue... the default configuration was not working so i changed the server.xml to use odbc dirver for making connections and it worked...


All times are GMT -5. The time now is 08:44 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.