BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-22-2009, 11:57 AM   #1 (permalink)
New Member
 
Join Date: Sep 2009
Model: 9630
PIN: N/A
Carrier: Verizon
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Please Help - New Guy, New BPS system....stuck

Please Login to Remove!

Hello All.

I am building a Blackberry Professional Server for our office. I am stuck and need some help badly.

Here is the breakdown.

Our office environment is Exchange 2000 SP3. Yes, I know its old, thats not my battle. I am the phone guy.

My Blackberry Professional Server a separate system running Windows Server 2003 Enterprise. I have installed the Exchange 2000 System Manager tools from our Exchange 2000 disk. I got the message about Exchange 2000 not being supported on Server 2003 that many others have mentioned is not an issue. I have all the ports opened. Installation is in progress. SRP has been validated. Now getting " Unable to find Exchange Server MAPI component".

I read a lot about the Service pack versions needing to be the same between the blackberry server and the exchange server. I downloaded and intstalled Exchange 2000 Service pack 3 on the Blackberry server. Still getting the same error.

From my reading, I know this has something to do with the MAPI dll file and CDO dll files between the Blackberry server and the Exchange server, but I have not found a clear solution that I understand.

This is all new to me and I really need some help. Any direction is appreciated.

Thanks
Micah Bennett
Nashville TN
Offline  
Old 09-22-2009, 12:19 PM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

remove the Exchange 2000 management tools ( i dont think, they are installed anyway).
download
http://www.microsoft.com/downloads/d...displaylang=en

install these and try again.
Offline  
Old 09-22-2009, 12:54 PM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Jul 2007
Location: Petoskey, MI
Model: 8530
OS: Win 7
PIN: N/A
Carrier: Verizon Droid
Posts: 95
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

i think the .dll files you mention must all be the same version on the exchange servers and the BPS. back them up on your BPS and copy the ones from exchange.
Offline  
Old 09-22-2009, 12:55 PM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

never versions should work also.
Offline  
Old 09-22-2009, 01:04 PM   #5 (permalink)
New Member
 
Join Date: Sep 2009
Model: 9630
PIN: N/A
Carrier: Verizon
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

7290

I removed the Ex 2000 tools and installed the stuff from the link you sent.

No change. Still getting the MAPI error like before.

I see others have mentioned copy the DLLs from the exchange 2000 server and put them on on the Blackberry server. Is this just a simple copy paste. Some things have mentioned "registering them". Im still lost.
Offline  
Old 09-22-2009, 01:08 PM   #6 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

you can try that also. (but, make restart after installing new versions).
If you copy the cdo.dll and the mapi32.dll in a directory where a path points to (windows system32 directory for example), it should be enough to open a cmd prompt and register the dlls with:
regsvr32 xyz.dll

also, search the complete disk for possible duplicates of other versions of these dlls and delete them.
Offline  
Old 09-22-2009, 01:32 PM   #7 (permalink)
New Member
 
Join Date: Sep 2009
Model: 9630
PIN: N/A
Carrier: Verizon
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does Outlook need to be installed on the Blackberry Professional Server?
Offline  
Old 09-22-2009, 02:55 PM   #8 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

You should try to omit that - and, if its installed, remove it clean all traces of outlook mapi dlls. Everybody says its not allowed (I had running outlook 2000 running without problems, but never tried a different version).
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.