BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-17-2009, 07:58 PM   #1 (permalink)
New Member
 
Join Date: Oct 2008
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Multiple Exchange 2007 servers with BES

Please Login to Remove!

Good Afternoon,

I have been searching all over for information on this and have come up with nothing...

I have just built out a new Exchange 2007 Mailbox/CAS role server and I need to connect the users on it to my BES.

Currently I have my MAPI Profile pointed to my "old" Exchange 2007 Server, which contains some of my BES users.

The problem comes in when I try to add a user from the "new" Exchange 2007 Server to the BES. It pulls the user from the GAL, but then when I try to configure folders for redirection I get error:
"Failed to retrieve folder redirection settings for the selected user. Please ensure that the MAPI Profile you used to login to Exchange has sufficient provledges..."

I have ensured that my BES Service account is granted Send As permissions to this user already.

My only thought is that since the MAPI Profile for BES is pointing at the "old" server, it can not properly connect to the "new" server.

I am running BlackBerry Manager 4.1.4.17

Any help would be greatly appreciated. Thank you!
Offline  
Old 11-17-2009, 08:03 PM   #2 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,036
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

Moved to a more appropriate section.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 11-18-2009, 07:04 PM   #3 (permalink)
New Member
 
Join Date: Oct 2008
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Turns out after doing some further research that multiple Exchange Servers running in the same domain do not need any new configuration.

The only thing I had to do was add the correct BES privileges to the new Exchange 2007 Server:

You need to run the following shell command on all of your Exchange 2007 servers:

get-mailboxserver <mail_server_name> | add-adpermission -user <service account> -accessrights GenericRead, GenericWrite -extendedrights Send-As, Receive-As, ms-Exch-Store-Admin

e.g. Server 1

get-mailboxserver bbforumsex01| add-adpermission -user BESadmin -accessrights GenericRead, GenericWrite -extendedrights Send-As, Receive-As, ms-Exch-Store-Admin

e.g. Server 2

get-mailboxserver bbforumsex02 | add-adpermission -user BESadmin -accessrights GenericRead, GenericWrite -extendedrights Send-As, Receive-As, ms-Exch-Store-Admin
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.