BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-30-2009, 06:32 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2005
Location: Cambridge, UK
Model: 8100
Carrier: Vodafone
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Migrating 4.1x BES to another server - Long

Please Login to Remove!

We're having some problems migrating from one server to another.
Our main BES server is in a state - one of the RAID 1 drives failed and the remaining drive is corrupted.
We want to migrate onto another server, replace the HDs in this server and then migrate back.
Here is what we've done so far:

Brand new Server 2003 R2 32bit machine.
Installed BES server onto this machine - using MSDE, not SQL Server.
Used the same license & SRP information on the new installation.
After installation (under the BES Admin account) both machines appeared in the "Blackberry Domain".

We then used "Move Users" to move all of our users from the old server to the new server - everything continued to work as expected.
At this point we removed the old server from the "Blackberry Domain" and shut it down - everything stopped working.
If we bring up the original server then everything works OK.
Howerver when the new server is running on it's own nothing works - no email is forwarded etc.

Has anybody got any idea what we may have done wrong?
Also, does anyone know how we can get the original server back into the "Blackberry Domain" so that we can move all of the users back?

At the moment we have two Blackberry servers sharing licenses & SRP.
Old server on it's own with no users.
New server with all the users - will not work if original server is switched off.
Old server not listed in "Blackberry Domain" so we can't copy users back and start again on the new server.

Any help appreciated
Offline  
Old 11-30-2009, 06:37 AM   #2 (permalink)
BlackBerry God
 
penguin3107's Avatar
 
Join Date: Jan 2005
Model: iOS 5
Carrier: VZW
Posts: 11,701
Post Thanks: 1
Thanked 237 Times in 219 Posts
Default

OK... you made two considerably large errors in your migration process.

1. You installed the second BES into the existing BlackBerry Domain, which means it's using the same configuration database as the first BES.

2. You used the same SRP on the second BES, which is a huge no-no because you had both BES running at the same time. RIM will lock the SRP if you do this because it's not possible to have two live BES using the same SRP simultaneously.

Your database, which I believe is still running on your first BES, is probably screwed up right now. I would immediately put a call into RIM T-Support and have them address this issue for you. And further tinkering could cause some serious damage at this point.
__________________
BCSA
BES 5.0.3 MR4 :-: Exchange 2007 SP3 RU3
http://port3101.org
Offline  
Old 11-30-2009, 06:49 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2005
Location: Cambridge, UK
Model: 8100
Carrier: Vodafone
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

We were following the instructions for a "Knife Edge" migration.

This explained about backing up the database from the old server (which we did).
It also indicated that the same SRP could be used as the two servers would in effect act as a "cluster" - sharing licenses etc.

Is there a manual way to get the old server listed in the "Blackberry Domain" once more so we can move the users back to the original server and at least get ourselves back to square 1?
Offline  
Old 11-30-2009, 06:53 AM   #4 (permalink)
BlackBerry God
 
penguin3107's Avatar
 
Join Date: Jan 2005
Model: iOS 5
Carrier: VZW
Posts: 11,701
Post Thanks: 1
Thanked 237 Times in 219 Posts
Default

Quote:
Originally Posted by Aminocom View Post
We were following the instructions for a "Knife Edge" migration.

This explained about backing up the database from the old server (which we did).
It also indicated that the same SRP could be used as the two servers would in effect act as a "cluster" - sharing licenses etc.

Is there a manual way to get the old server listed in the "Blackberry Domain" once more so we can move the users back to the original server and at least get ourselves back to square 1?
I don't know where you read those instructions, because that most certainly is NOT a knife-edge cutover.

There's no "clustering" and there's no "Move User" in a knife-edge cut.

I honestly don't know what you did or how to fix it.

I'd call RIM.
__________________
BCSA
BES 5.0.3 MR4 :-: Exchange 2007 SP3 RU3
http://port3101.org

Last edited by penguin3107 : 11-30-2009 at 06:54 AM.
Offline  
Old 12-01-2009, 09:36 AM   #5 (permalink)
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Post Thanks: 6
Thanked 9 Times in 9 Posts
Default

Your SRP ID may be disabled. The old server is a stale record in the ServerConfig table. You need to call up RIM for their BES Exchanges experts to help clean up the mess you've created.
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.