BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-04-2010, 12:19 PM   #1 (permalink)
New Member
 
Join Date: Jan 2010
Model: 8800
PIN: N/A
Carrier: Verizon
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 1 BES - Multiple Exchange Servers / Versions

Please Login to Remove!

I recently setup a BES 5.0 server and everything is working great with the Exchange 2007 server in our primary domain. Unfortunately, I'm unable to activate a user in our child domain. The mail server in the child domain is running Exchange 2003. I've double checked the service accounts' permissions and have narrowed it down to an Exchange not an AD problem.

When I first setup BES I installed the ExchangeMapiCdo.EXE only. I did not install the Exchange System Manager. I believe ESM is needed on the BES to connect to Exchange 2003. Can I install the Exchange tools without affecting the working connection I have with our Exchange 2007 server?

Thanks!
Offline  
Old 01-04-2010, 12:26 PM   #2 (permalink)
BlackBerry Extraordinaire
 
CanuckBB's Avatar
 
Join Date: Feb 2006
Location: YYZ
Model: 9900
Carrier: Rogers
Posts: 1,183
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default

The ExchangeMapiCdo.exe is all you need.

does mail flow from those servers?

Does BESAdmin have permissions on the 2003 server?
Offline  
Old 01-04-2010, 12:35 PM   #3 (permalink)
New Member
 
Join Date: Jan 2010
Model: 8800
PIN: N/A
Carrier: Verizon
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, mail flows from each server. I've triple-checked the permissions for the BESADMIN account on each server. Everything appears to be correct. I've been doing some testing using the IEMSTEST.exe. All users hosted on the Exchange 2003 server fail. The one user located in the child domain but hosted on the Exchange 2007 server passes the test. I believe that rules out the AD permissions.

Another post mentioned checking the MAPI32.DLL versions among the servers. Not sure how it works but here they are...
BES = 1.0.2536.0
Ex2007 (working) = 1.0.2536.0
Ex2003 (not working) = 6.5.7654.12

Thanks again for the help!
Offline  
Old 01-04-2010, 03:19 PM   #4 (permalink)
BlackBerry Extraordinaire
 
CanuckBB's Avatar
 
Join Date: Feb 2006
Location: YYZ
Model: 9900
Carrier: Rogers
Posts: 1,183
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default

Your MAPI is fine.

Your symptoms point to a BESAdmin permission issue on the E2K3 server.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.