BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-04-2010, 07:06 PM   #1 (permalink)
New Member
 
Join Date: Jan 2010
Model: 9000
PIN: N/A
Carrier: Optus
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems with upgrading from BES 4.1 to BES 5.0

Please Login to Remove!

Hi,

I'm trying to in-place upgrade from Blackberry Enterprise Server 5.0, Blackberry Enterprise Server 4.1, Blackberry for Domino on a Windows 2003 server. There's only one BES server in our organisation.

Original BES version was 4.1.2.
Have upgraded to numerous Maintenance Releases and Service Packs
Current BES (according to BlackBerry Manager & the SQL database) is 4.1.7.17

Other Version info from BB Manager includes:
USB Channel Controller; 4.1.0.11
Device manager 4.3.1.12
Application Loader: 4.7.0.57
RIM Intel Programmer: 1.0.0.35

The problem:
When running the BES 5.0 installation, I receive the following error:

"The setup application found one or more instances of BlackBerry® Enterprise Server version 4.1.2 or earlier, which is not compatible with BlackBerry Enterprise Server version 5.0 or later. You must upgrade or remove the incompatible BlackBerry Enterprise Server instances, or create a new BlackBerry Domain for the BlackBerry Enterprise Server that you are installing."

Looking at the install log (attached), I found the following entry towards the bottom of the file:

[30000] (01/04 21:22:20.179):{0x1D30} <5>Jan 04 21:22:20 BLACKBERRYSERVER {0x1CC4} 0168: (#35019) [ENV] [DB] Database Schema Version: 4.1.7 <4.1.2.2009.07.16>

This line shows the database schema as being version 4.1.7 but also has 4.1.2.. listed, which is what I'm assuming causing the error

There are additional errors in the log after this but I'm not focusing on them until I resolve the version issue.

I've updated to the latest Service Pack and the error still occurs.

The only reference to "4.1.2 or earlier" I can find is in the Help/About within BES Manager where it lists the USB Channel Controller; 4.1.0.11.

Any suggestions welcomed.

Thanks
Attached Files
File Type: txt Setup20100104102152.txt (55.4 KB, 3 views)
Offline  
Old 01-05-2010, 06:22 AM   #2 (permalink)
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Post Thanks: 6
Thanked 9 Times in 9 Posts
Thumbs down

You can't deny you have not read the install/upgrade guides and admin manuals. Bad.

DB2 is not supported for BES Configuration database.

<snip>
[30000] (01/04 21:24:51.929):{0x1D30} <4>Jan 04 21:24:51 BLACKBERRYSERVER {0x1CC4} 0198: (#25000) ConnectionItem::ConnectToDB: COM Error 0x80040E4D - IDispatch error #3149 - Source: "IBM OLE DB Provider for DB2" - Description " SQL1013N The database alias name or database name "BESMGMT" could not be found. SQLSTATE=42705 " - Command "Provider=IBMDADB2;DSN=BESMgmt;"
[30000] (01/04 21:24:51.929):{0x1D30} <5>Jan 04 21:24:51 BLACKBERRYSERVER {0x1CC4} 0199: (#35028) {ConnectionPool::InitializePool()} Pool Initialization failed for attempt 1 of 5
[30000] (01/04 21:25:01.929):{0x1D30} <5>Jan 04 21:25:01 BLACKBERRYSERVER {0x1CC4} 0200: (#35028) {ConnectionPool::InitializePool()} Pool Initialization failed for attempt 2 of 5
[30000] (01/04 21:25:11.945):{0x1D30} <5>Jan 04 21:25:11 BLACKBERRYSERVER {0x1CC4} 0201: (#35028) {ConnectionPool::InitializePool()} Pool Initialization failed for attempt 3 of 5
[30000] (01/04 21:25:21.961):{0x1D30} <5>Jan 04 21:25:21 BLACKBERRYSERVER {0x1CC4} 0202: (#35028) {ConnectionPool::InitializePool()} Pool Initialization failed for attempt 4 of 5
[30000] (01/04 21:25:31.961):{0x1D30} <5>Jan 04 21:25:31 BLACKBERRYSERVER {0x1CC4} 0203: (#35028) {ConnectionPool::InitializePool()} Pool Initialization failed for attempt 5 of 5
[30000] (01/04 21:25:31.961):{0x1D30} <3>Jan 04 21:25:31 BLACKBERRYSERVER {0x1CC4} 0204: (#10000) VerifyVersions: Failed to connect to database.
[30000] (01/04 21:25:31.961):{0x1D30} <3>Jan 04 21:25:31 BLACKBERRYSERVER {0x1CC4} 0205: (#10000) The setup application found one or more instances of BlackBerry® Enterprise Server version 4.1.2 or earlier, which is not compatible with BlackBerry Enterprise Server version 5.0 or later. You must upgrade or remove the incompatible BlackBerry Enterprise Server instances, or create a new BlackBerry Domain for the BlackBerry Enterprise Server that you are installing.
[30000] (01/04 21:25:48.195):{0x1D30} <5>Jan 04 21:25:48 BLACKBERRYSERVER {0x1CC4} 0206: (#30000) [PIPTOOL]: Cancelling PIPTool from CDBInfoDlg.
[30000] (01/04 21:25:48.195):{0x1D30} <3>Jan 04 21:25:48 BLACKBERRYSERVER {0x1CC4} 0207: (#10000) [PIPTOOL]: Executing stop from CDBInfoDlg.

</snip>

BES 5.0 SP1 not supported already, don't need to consider version 5.0.

<quote>
The BlackBerry Enterprise Server version 5.0 SP1 and BlackBerry Enterprise Server components do not support IBM DB2 UDB.
</quote>

Source: Unsupported environments
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.