BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-08-2010, 09:09 AM   #1 (permalink)
New Member
 
Join Date: Dec 2009
Location: UK
Model: 9700
OS: V5.1.0.90
PIN: N/A
Carrier: Vodafone UK
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Angry Cant get BBs to access internet through corporate proxy.

Please Login to Remove!

I'm trying to get my clients to come throught the corporate ISA proxy for filtered internet access, but cant get it to work.

I've created a specifix BESBrowser account
Enable WAP Config to False.
Allow IBS Browsers to False.
Service Exclusivity Policy Group set Allow Other Browser Services to False.
This should force use of Blackberry browser only.

Then I created
PROXY PROXY server.domain:8080 in Proxy Mappings of MDS components

All the PCS in the company work fine going throught the Proxy. But the end users can still get the internet without going through the proxy. ISA monitor shows no sessions while they are on, and the can browse to unstuiable websites (we use Websense to filter)

Any ideas what to do to fix?


Thanks
Offline  
Old 01-08-2010, 09:12 AM   #2 (permalink)
BlackBerry Master
 
dankarlinski's Avatar
 
Join Date: May 2007
Model: 1
Carrier: 1
Posts: 3,391
Post Thanks: 1
Thanked 2 Times in 2 Posts
Default

Wirelessly posted (White and Nerdy)

Did you remember to push the policy to the end users?
Offline  
Old 01-08-2010, 09:18 AM   #3 (permalink)
New Member
 
Join Date: Dec 2009
Location: UK
Model: 9700
OS: V5.1.0.90
PIN: N/A
Carrier: Vodafone UK
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I didnt know this was part of a policy?
Is it not set in Blackberry solution topology\components\MDS Connection service?
Do I have to do it somewhere else?
Part of the IT policy?
Offline  
Old 01-11-2010, 07:16 AM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

What is your URL? http:// and https://.* ? Can you browse internet from BES server using IE?

Last edited by fadmin : 01-11-2010 at 07:18 AM.
Offline  
Old 01-11-2010, 07:46 AM   #5 (permalink)
New Member
 
Join Date: Dec 2009
Location: UK
Model: 9700
OS: V5.1.0.90
PIN: N/A
Carrier: Vodafone UK
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I can browse from the BES service fine.
IS has proxy settings in it for the besbrowser account.

.*://.*(:\d*)?(/.*)*(\?.*)?

Which is the default, and I thought should just work

Maybe I need to do more?
Offline  
Old 01-11-2010, 07:58 AM   #6 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

Provide some more details such as BES versions, is it running on SBS maybe, what authantication is being used, error you get on BB etc.
Offline  
Old 01-11-2010, 08:14 AM   #7 (permalink)
New Member
 
Join Date: Dec 2009
Location: UK
Model: 9700
OS: V5.1.0.90
PIN: N/A
Carrier: Vodafone UK
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It's a BES 5 server - Version: 5.0.0.137
There are no errors. Basically the handhelds should go out through the
ISA proxy server. However they are not.They can get porn and other stuff
that they should not.

I havent set authentication or snything like that
I've basically only done the steps listed i nthe OP.

I can "Authentication Support enabled" set to no - that must be a default.
Do I need to do more seting changes - either here or i nthe IT policy?

Thanks
Offline  
Old 01-11-2010, 08:33 AM   #8 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

Is ISA on the same server?
Offline  
Old 01-11-2010, 08:37 AM   #9 (permalink)
New Member
 
Join Date: Dec 2009
Location: UK
Model: 9700
OS: V5.1.0.90
PIN: N/A
Carrier: Vodafone UK
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

No Isa is elsewhere
I thought what happens is you set up a username and password
Then when a device request a web page it contacts the BES
BEs then tries to get the page using hte credentials I supplies
Then if it works then ISA processes the request

Am I missing somethnig else - I could eaily be as I'm a total Newbie on this.
Offline  
Old 01-11-2010, 08:41 AM   #10 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

On device you have just Blackberry Browser? When you open BB browser and then press menu>Options>General Properties and make sure BB browser is default one and not Internet browser.
Offline  
Old 01-11-2010, 09:11 AM   #11 (permalink)
New Member
 
Join Date: Dec 2009
Location: UK
Model: 9700
OS: V5.1.0.90
PIN: N/A
Carrier: Vodafone UK
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yep Blackberry Browser is the listed one.
Offline  
Old 01-11-2010, 09:27 AM   #12 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

What proxy type do you have selected in MDS? Proxy or direct or ..?? We don't use ISA proxy and we don't need user name and password to enter to browse Internet. All we need is to allow access to the internet from BES IP address, enter proxy address:port in mds and then proxy filters whatever is allowed or disallowed.
Offline  
Old 01-11-2010, 10:49 AM   #13 (permalink)
New Member
 
Join Date: Dec 2009
Location: UK
Model: 9700
OS: V5.1.0.90
PIN: N/A
Carrier: Vodafone UK
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Proxy type is set to PROXY.
I want them to go through ISA for URL filtering done by Websense.
One day we may well replace websense with a hardware proxy, but not now.
Offline  
Old 01-11-2010, 11:41 AM   #14 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default

This sounds to me that your BES setup is ok but it seems that websense does not reckognize traffic from BB browser and just lets it go through. I found this as well that may also confirm this:
Blackberrys bypass our Websense Filters ?

Sorry I could not help more.
Offline  
Old 01-11-2010, 12:28 PM   #15 (permalink)
BlackBerry Extraordinaire
 
CanuckBB's Avatar
 
Join Date: Feb 2006
Location: YYZ
Model: 9900
Carrier: Rogers
Posts: 1,183
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default

Can you navigate to blocked sites from the BES?

It sounds like BESAdmin account is not being filtered. Also, is the gateway on BES the ISA server?
Offline  
Old 01-11-2010, 12:43 PM   #16 (permalink)
CrackBerry Addict
 
Join Date: Jan 2008
Model: 9700
PIN: N/A
Carrier: Rogers
Posts: 709
Post Thanks: 0
Thanked 8 Times in 8 Posts
Default

We don't use ISA, but I do know users get the same firewall restrictions as the BES box - it's coming from the same IP. Again, not sure if that helps in ISA world or not.
Offline  
Old 01-13-2010, 09:36 AM   #17 (permalink)
New Member
 
Join Date: Dec 2009
Location: UK
Model: 9700
OS: V5.1.0.90
PIN: N/A
Carrier: Vodafone UK
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Alas the problem has deteriorated
There is now no internet at all.
I'm just getting ab unch of 400 bad request errors.
The server could not understand the page request or was unable to process it.
connection refused Google or bbc:80

I read a post (Web Content Filter) about editing the wsMSP.ini file on the ISA server in the system32 folder.

[configSection]
IgnoreForwardedRequest=0

But then I got no internet
I then changed it back and still no internet
I can get to the web and am filtered properly from the BES box.

Is there a delay in making changes in the mds components on the server before it takes effect?
I stop start services but no joy.

Also BB must be using MDS as if I stop the service I get an error about not being able to communicate with the MDS.

Last edited by deesloop : 01-13-2010 at 10:31 AM. Reason: Extra
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.