BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-09-2010, 07:23 PM   #1 (permalink)
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Post Thanks: 6
Thanked 9 Times in 9 Posts
Arrow Knowledge Sharing - Perform basic troubleshooting steps for Novell GroupWise

Please Login to Remove!

Don't know why RIM removed this good KB reference article... Anyway found on another good BB Forum website. Archiving here for future lookup.

Source: http://www.blackberryforums.com.au/f...groupwise.html

Perform basic troubleshooting steps for Novell GroupWise

Doc ID : KB12662
Last Modified : 2007-05-03
Document Type : What Is


Environment
  • BlackBerry® Enterprise Server
  • Novell® GroupWise®
Details

Confirm Software Configuration

To run BlackBerry Enterprise Server software for Novell GroupWise, you must meet specific software requirements. However, if you update any third-party or BlackBerry Enterprise Server software in the environment, you might also have to update the software prerequisites for the BlackBerry Enterprise Server. This document is designed to help you keep the BlackBerry Enterprise Server in a supported configuration.

Software Prerequisites

Below is a list of the software the BlackBerry Enterprise Server requires for its functions. Each performs a certain role in relation to the BlackBerry Enterprise Server.

Operating System Requirements

The BlackBerry Enterprise Server requires a server level operating system in order to function as expected. Server operating systems provide better resource management for the BlackBerry Enterprise Server. Supported operating systems include the following:
  1. Windows Server® 2000 and Advanced Server Service Pack 4
  2. Windows Server 2003 and Standard Service Pack 1 or higher
GroupWise Application Programming Interface (API)

The GroupWise Client recommended to be installed on the BlackBerry Enterprise Server is version 6.5.6 Update 1 Rev 4 (or later). Please note that this version is required for BlackBerry Enterprise Server software version 4.0 Service Pack 6 and later, and BlackBerry Enterprise Server software version 4.1 Service Pack 2 Hot Fix 1 and later. To validate the GroupWise Client after installation, launch the GroupWise Client on the BlackBerry Enterprise Server and log in. Open to Help About and record the version and the release date. The version should be 6.5.7 and the release date should be November 6, 2006 (11/06/2006). If this is not the correct version you will need to upgrade. If you are running GroupWise client 7.0 or later, you will need to install the required version of GroupWise Client.

Trusted Application Key

The BlackBerry Enterprise Server accesses GroupWise through a Trusted Application Key. This key will need to be generated prior to installing BlackBerry Enterprise Server. To Generate a key follow these steps:
  1. Log into Netware using a Novell Administrator account with supervisor rights to the GroupWise system.
  2. Copy the Key Generator Application folder from the installation files.
  3. In ConsoleOne, locate the Universal Naming Convention (UNC) path that points to the wpdomain.db file for the domain that you are creating the trusted application key for.
  4. Launch Generate_GW_Trusted_App.exe.
  5. In the name field type a name for the trusted application key. The default is "RIM BES".
  6. Click Browse and navigate to the folder containing the wpdomain.db file for the Primary Domain of the GroupWise system.
  7. When prompted, save the configuration file on the local machine.
  8. Copy the configuration file to the BlackBerry Enterprise Server. You will need to open this file with Notepad to copy over the key and the name.
Administration account

During installation you will be prompted for an administration account. This account will be the one that is used by the BlackBerry Enterprise Server using the trusted application key to log into the GroupWise system. The only requirement for this account is to have a valid, initialized GroupWise mailbox. To verify this, launch the GroupWise client, log in as the administrative user and verify that the account has a Frequent Contacts address book and can access the GroupWise System Address book.

GroupWise Post Office

The GroupWise Post Office minimum version is 6.5.1. This is because this version and later support the Trusted Application Key. If you are running BlackBerry Enterprise Server version 4.1 Service Pack 2 or higher and would like to use the Simple Object Access Protocol (SOAP) mode, you will need to be running Post Office version 7.0.1 Interim Release 1 or higher.
Microsoft SQL Desktop Engine (MSDE) or Microsoft SQL Server™

Note: MSDE 2000 can be installed with the BlackBerry Enterprise Server.
The BlackBerry Enterprise Server requires that SQL be at a minimum version in order for it to function properly. Those versions are:
  1. MSDE 2000 Release A
  2. SQL Server 2000 Service Pack 3a
Note: SQL Server 2005 is only supported by BlackBerry Enterprise Server 4.1 or later. However, BlackBerry MDS Services does not support Microsoft SQL 2005 Express.

Both of these applications will return a SQL version of 8.00.760. If the version is higher then this, it is acceptable for the BlackBerry Enterprise Server. Along with versions, the BlackBerry Enterprise Server also requires the ability to access the SQL Database using one of two protocols. In order to ensure this is the case, follow the steps below:
  1. Login to the server hosting your MSDE or SQL instance.
  2. Go to Start > Run and type the command svrnetcn and click OK.
  3. In the SQL Server Network Configuration Utility, confirm that TCP/IP and Named Pipes are both listed as enabled protocols.
Also ensure that the SQLSERVERAGENT service is running and set to automatic. To check this, follow the steps below:
  1. Login to the SQL server.
  2. Go to Windows Services.
  3. Find the SQLSERVERAGENT service.
  4. Set the service to "automatic" and then start the service.
If any of the Database requirements are not functioning correctly, it can causes problems with the BlackBerry Synchronization Service, BlackBerry Policy Service and BlackBerry Dispatcher. When the BlackBerry Synchronization Service is not functioning errors will occur with the BlackBerry Wireless Backup, synchronization of the address book, memo pad and tasks and Enterprise Activation. The BlackBerry Policy Service is responsible for managing both IT Policies and Service Books. When it is not working correctly, Enterprise Activations will fail and users will not be able to switch IT Policies. The BlackBerry Dispatcher is responsible for all traffic routing on between the BlackBerry services. If this service is not functioning, none of the BES functions will work.

Microsoft Data Access Components (MDAC) MDAC is the software that allows the BlackBerry Enterprise Server to connect to the SQL database and is used extensively by several of the services. When MDAC is not matching the BES requirements it will cause the same issues as the Database Server. The latest BlackBerry Enterprise Server version required an MDAC version of 2.8 Service Pack 1.

In order to confirm this is the version you are using, follow the steps below:
  1. Go to the Microsoft Download Center.
  2. Download and Install the Component Checker software.
  3. Run the Component Checker and select the first of the three options.
  4. This will return the version of MDAC if you have installed. If it is not 2.8 Service Pack 1, you will require an upgrade of this software.
Microsoft XML Parser and SDK

Note: the XML parser will be installed with the BlackBerry Enterprise Server by default.

The Microsoft XML Parser and SDK is used by several of the services to format Data correctly. The minimum version of this is 4.10.9404.0. In order to retrieve this version, please follow the steps below:
  1. Open Add or Remove Programs in the Windows Control Panel.
  2. Scroll through the list until you find an entry for Microsoft XML Parser and SDK.
  3. Click the Support Information link for this entry to display the version number.
  4. If the Parser is not present or the version number listed is lower than the required version, it install the correct version.
Incorrect XML Parser and SDK versions will cause problems with both the BlackBerry Synchronization Service and the BlackBerry Policy Service. If XML is not present is not functioning, it will cause issues with Wireless Backup, Wireless Synchronization, IT Policies and Service Books.

Java Runtime Environment

Note: The Java Runtime Environment (JRE) will be installed with the BlackBerry Enterprise Server by default.

The Java Runtime Environment is used by the Mobile Data Service or the MDS Connection Service, depending on you version of the BlackBerry Enterprise Server. This software is absolutely required for that service to function. Different versions of the BlackBerry Enterprise Server require different versions of the Java Runtime Environment. 4.0 can use 1.4.2_X as the latest version it supports. The BlackBerry Enterprise Server version 4.1 supports 1.5.0_04 and later for its Java Runtime Environment version. In order to check this, please follow the steps below:
  1. Open Add or Remove Programs in the Windows Control Panel.
  2. Find and record all the versions of the Java Runtime Environment that are installed, ensure that one of them is supported by your BlackBerry Enterprise Server.
  3. To ensure the correct Java version is in use, follow the steps from KB02283.
  4. The Java Runtime Environment is what allows the BlackBerry Browser to function from the handheld as well as the Wireless Application push.
.NET Framework

Note: The .NET Framework will be installed with the BlackBerry Enterprise Server by default. The .NET Framework is required for some of the features of BlackBerry Enterprise Server. Currently, the BlackBerry Enterprise Server utilizes .NET 1.1 Service Pack 1.

In order to check the versions installed, please follow the steps below:
  1. Open "Add or Remove Programs"
  2. Find the entries for the .NET Framework, it should show you versions.
  3. Ensure .NET Framework 1.1 is installed. More than one version is of .NET Framework may be present as Windows Server 2003 includes .NET Framework 1.1.
Upgrade Instructions

GroupWise API

If the GroupWise client is not installed, or requires an update please follow these steps. If there are any issues upgrading or installing GroupWise client, Research In Motion recommends contacting Novell for additional assistance:
  1. Visit the Novell Support Site and download the latest full version or Field Test File (FTF) for the GroupWise 6.5 client. It contains the current version of the GroupWise Object API needed for the BlackBerry Enterprise Server. Note: If needed, follow the instructions provided by Novell to install the latest GroupWise Client versions, including those associated with any FTF builds.
  2. Open the Microsoft Windows Services administrative tool and stop all listed BlackBerry Enterprise Server Services. In case the GroupWise Client update requires a restart of the server, set these services to Manual Start Up.
  3. Close the BlackBerry Manager and the GroupWise client on the BlackBerry Enterprise Server.
  4. Remove the GroupWise client version currently installed on the BlackBerry Enterprise Server via Add/Remove Programs. It may be necessary to reboot the server at this time, it is recommended to do so even if not prompted by the uninstall utility.
  5. Install the updated GroupWise 6.5 client obtained from the Novell web site. Note: You must select the US-English language when you install the GroupWise client.
  6. To ensure the GroupWise client is correct, launch GroupWise and log in. Open the Address Book and ensure no errors are reported.
  7. Set the BlackBerry Enterprise Server Services to Automatic Start Up and start the BlackBerry Enterprise Server Services stopped in an earlier step.
Microsoft SQL Desktop Engine (MSDE) or Microsoft SQL Server
If an upgrade to SQL Server is required, please follow the steps below:
  1. Follow the steps provided in KB03112 to backup the BlackBerry Configuration Database.
  2. Follow the approved Microsoft procedure to upgrade your version of the SQL server.
  3. If required, restore the backup of the database that you took.
Microsoft Data Access Components (MDAC)

If MDAC is below the required version, please follow the steps below to resolve this:

For Windows Server 2000 and Advanced Server:
  1. Open the MDAC Downloads Center on the Microsoft website.
  2. Search for and download MDAC 2.8 SP1.
  3. Run the setup program and install the software on the server.
  4. Restart the server.
For Windows Server 2003:
1. Upgrade to Windows Server 2003 Service Pack 1.

Microsoft XML Parser and SDK

If the Microsoft XML Parser requires an update, of if you suspect that it is not functioning correctly, follow these instructions:
  1. Remove any versions of the Microsoft XML Parser and SDK that are currently installed.
  2. Go to the Downloads section of the XML Developer Center on the Microsoft website.
  3. Search for and download the XML Core Services 4.0 Service Pack 2 file.
  4. Run the setup program and restart the BlackBerry Enterprise Server.
Java Runtime Environment

To upgrade the Java Runtime Environment, please follow these steps:
  1. Open Add or Remove Programs in the Windows Control Panel and remove any versions of the Java Runtime Environment that are present.
  2. Download and install the latest version of Java supported by your BlackBerry Enterprise Server from Suns website.
  3. Open the registry editor and navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\ <BlackBerry Mobile Data Service or BlackBerry MDS Connection Service name>.
  4. Find the ImagePath registry value and open it.
  5. Update the jvmpath to match the version of the Java Runtime Environment you installed, shown below: C:\Program Files\Research In Motion\BlackBerry Enterprise Server\MDS\bin\bmds.exe" -s jvmpath="C:\Program Files\Java\jre1.5.0_07\bin\client\jvm.dll" -XX:+DisableExplicitGC -Xss64K -Xmx768M -Xms128M classpathdir="C:\Program Files\Research In Motion\BlackBerry Enterprise Server\MDS\classpath\\" wrkdir="C:\Program Files\Research In Motion\BlackBerry Enterprise Server\MDS\Servers\BLACKBERRY\\" webserverdir="C:\Program Files\Research In Motion\BlackBerry Enterprise Server\MDS\webserver\\" -rbes "<BES Name>_MDS-CS_1
  6. Restart the BlackBerry Enterprise Server.
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Old 01-12-2010, 06:33 AM   #2 (permalink)
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Post Thanks: 6
Thanked 9 Times in 9 Posts
Default

This is even better. Great contribution from GartCutri.

Link: http://www.blackberryforums.com.au/f...html#post34820
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.