BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-01-2010, 07:46 AM   #1 (permalink)
Knows Where the Search Button Is
 
Laeeq's Avatar
 
Join Date: Nov 2008
Location: Islamabad
Model: 7100T
PIN: N/A
Carrier: Mobilink
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Unable to connect to the remote server: BESUserAdminTool 5.0.1.7

Please Login to Remove!

Hi,

I have just installed BRK 5.0.1 (BESUserAdminTool) and successfully set the client password using

BESUserAdminClient -set_client_auth

but after that when I run any command, i get the errors:

BlackBerry(R) Enterprise Server User Administration Tool Version 5.0.1.7
Copyright (c) Research In Motion, Ltd. 2009. All rights reserved.

(04/01 07:13:02) Error setting up authentication with 2 tries remaining: Unable to connect to the remote server
(04/01 07:13:04) Error setting up authentication with 1 tries remaining: Unable to connect to the remote server
(04/01 07:13:06) Error setting up authentication with no tries remaining:
(04/01 07:13:06) Unable to connect to the remote server
(04/01 07:13:06) Command Results:


I have tested basic server commands like:

BESUserAdminClient -p clientPwd -list -it_policies

and

BESUserAdminClient -p clientPwd -status

but every time i m getting the same error msg.

Note: My BES is on some other machine and BRK (AdminTool) is installed separately on a win 2008 server SP2 machine. BES Admin console on BES server is working fine, and i m able to add/delete users there.


Any help would be appreciated in this regard.
__________________
Regards,

Laeeq Qazi
Senior Software Engineer [Exchange2007,BES 5,WSS 3.0, DCRM 4.0]

www.HostingController.com

Last edited by Laeeq : 04-01-2010 at 07:51 AM. Reason: addition
Offline  
Old 04-01-2010, 12:31 PM   #2 (permalink)
Knows Where the Search Button Is
 
Laeeq's Avatar
 
Join Date: Nov 2008
Location: Islamabad
Model: 7100T
PIN: N/A
Carrier: Mobilink
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Now after doing uninstall and reinstall BRK 5.0.1 and setting besUserAdminClient password the error has changed to "Cannot find Dispatcher Instance: bes01"

This error is coming when i m trying to add a new user or deleting existing user, but server related commands are running fine like (-status).

I ran the command (which i have run numerous times on some other bes server)

besUserAdminClient -p clientPwd -add -u "user@domain.com" -b bes01 -wrandom -it_policy default

BlackBerry(R) Enterprise Server User Administration Tool Version 5.0.1.7
Copyright (c) Research In Motion, Ltd. 2009. All rights reserved.

(04/01 11:51:08) Running command...
(04/01 11:51:08) Cannot find Dispatcher Instance: bes01
(04/01 11:51:08) ...Done
(04/01 11:51:08) Command Results:
,Cannot find Dispatcher Instance: bes01


Now dont know what to do becoz BES is running fine, and i just cant add/remove user using BESUserAdminClient tool.

Regards,
__________________
Regards,

Laeeq Qazi
Senior Software Engineer [Exchange2007,BES 5,WSS 3.0, DCRM 4.0]

www.HostingController.com
Offline  
Old 04-02-2010, 10:17 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2010
Model: 9700
PIN: N/A
Carrier: AT&T
Posts: 30
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default check syntax

well I havn't used it with v5.0 yet, but in previous versions the syntax to hit a remote server required a -n server switch, without it, the command is expecting the local machine to be running the BESUserAdminService service:

[-n <network address>] : network address (or computer name) of where
BESUserAdminService is running

Something like:

BESUserAdminClient.exe -p adminpass -n server01.us.mydomain.net -add -u useremailatmydomain.com -b BESInstance01 -w eapass -wt 336 -it_policy SomeITPolicy -v



[well take two - I couldn't put 'useremailatmydomain.com' in email address form as my post count is below 10]
Offline  
Old 04-02-2010, 10:25 AM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2010
Model: 9700
PIN: N/A
Carrier: AT&T
Posts: 30
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Laeeq View Post
Now after doing uninstall and reinstall BRK 5.0.1 and setting besUserAdminClient password the error has changed to "Cannot find Dispatcher Instance: bes01"

This error is coming when i m trying to add a new user or deleting existing user, but server related commands are running fine like (-status).
Well if -status works then it would seem you are either running it local to where the BESUserAdminService is running (i.e. on the BES) or you are using the -n witch and just not showing it.

Make sure the BES instance name you are using with -b is correct. This is not always the same as the name of the server.
Offline  
Old 04-02-2010, 12:17 PM   #5 (permalink)
Knows Where the Search Button Is
 
Laeeq's Avatar
 
Join Date: Nov 2008
Location: Islamabad
Model: 7100T
PIN: N/A
Carrier: Mobilink
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

Thanx for your reply Sp1d3rM@n.

I didnt provide -n parameter to the command previously. Yes it was issue of server name though. I had to put different bes server name for -b parameter bcoz its different than the bes server name. Now its running fine.
__________________
Regards,

Laeeq Qazi
Senior Software Engineer [Exchange2007,BES 5,WSS 3.0, DCRM 4.0]

www.HostingController.com
Offline  
Old 04-02-2010, 02:36 PM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2010
Model: 9700
PIN: N/A
Carrier: AT&T
Posts: 30
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ah cool... so I nailed it then. That means at least something went right so far today.
Offline  
Old 04-02-2010, 06:20 PM   #7 (permalink)
Knows Where the Search Button Is
 
Laeeq's Avatar
 
Join Date: Nov 2008
Location: Islamabad
Model: 7100T
PIN: N/A
Carrier: Mobilink
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

Yes you directed me in the right direction. Previously I noticed that different BES Server name in the Registry settings on bes server as "ConfigServer" key, but ignored it. Actually I didnt install the BES server, was just configuring BES to run with HostingController.

Thanx.
__________________
Regards,

Laeeq Qazi
Senior Software Engineer [Exchange2007,BES 5,WSS 3.0, DCRM 4.0]

www.HostingController.com
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.