BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-06-2010, 04:06 PM   #1 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default issues after migration to exchange 2010

Please Login to Remove!

Hey folks,

Been a looooong time since I've posted here, mainly because our BES has been running pretty well, but I'm having some issues now.

At the beginning of the year we migrated from 4.1.x to 5.0. That was a bit of a painful upgrade, but I got it sorted out well enough. Now we have just upgraded our Exchange server to Exchange 2010, and I'm having a whole bunch of issues. This isn't happening to every account, but for the users who are affected, I am having connectivity issues. Setting up a new user, and the BlackBerry will not activate, the email get stuck in their inbox. I have a few users who's devices have stopped syncing. Sometimes rebooting the BES server fixes the problem for a few hours, sometimes it doesn't.

I looked through the log files, and I am seeing MAPI errors on the affected users, but I have confirmed that the MAPI file is identical on both the Exchange server and the BES server. I even grabbed the most recent version from Microsoft and put it on just to be sure.

Here is the specific error for one user:

Code:
[20400] (04/06 13:26:56.056):{0x3F8} {JenniferRavenshorst@di-corp.com} MAPIMailbox::MAPIMailbox - OpenMsgStore (0x8004011d) failed, MailboxDN=/o=Diversity Technologies Corporation/ou=First Administrative Group/cn=Recipients/cn=jravens, ServerDN=/o=Diversity Technologies Corporation/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=SECAS/cn=Microsoft Private MDB
[40720] (04/06 13:26:56.056):{0x3F8} MAPI call failed. Error 'The information store could not be opened.', LowLevelError 0, Component 'MAPI 1.0', Context 649
[20154] (04/06 13:26:56.056):{0x3F8} User Jennifer Ravenshorst not started

At this point I'm almost at a total loss as to what the issue could be.

I'm running BESX 5.0.1 MR1 on Server 2003 R2, and the Exchange server is Exchange 2010 on Server 2008 R2. I'm going to be upgrading to MR2 after hours tonight, but I don't think any of the bugfixes listed in the release notes will help me out much.
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Old 04-06-2010, 06:48 PM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Nov 2005
Location: Oklahoma City, OK
Model: 9800
Carrier: AT&T
Posts: 239
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Have you ran the commands to remove the limit of active connections???

Increase the maximum number of connections to the Address Book service in Microsoft Exchange 2010
Offline  
Old 04-07-2010, 09:25 AM   #3 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I hadn't done this. I changed it and will see what happens.
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Old 04-07-2010, 10:38 AM   #4 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, I made that change, waited an hour, even restarted the BES, and I still have 5 users who will not sync at all. Everyone else is working fine.
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Old 04-08-2010, 10:32 AM   #5 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Nov 2005
Location: Oklahoma City, OK
Model: 9800
Carrier: AT&T
Posts: 239
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK try this...

If you followed the official BES 5.0.1 install guide you would have issued the following two commands:

New-ThrottlingPolicy BESPolicy

Set-Mailbox "BESAdmin" -ThrottlingPolicy BESPolicy

These two commands would have created a new policy and added BESadmin with all the default settings (RCAMaxConcurrency = 20) which will cause the "OpenMsgStore failed (8004011d)" error to occur once multiple users are added to the BES.

To correct this error please enter the commands below into the Exchange Management Shell:

1. Change the RCAMaxConcurrency setting to unlimited (default is 20) using the following command:

Get-ThrottlingPolicy | where {$_.IsDefault -eq $true} | Set-ThrottlingPolicy -RCAMaxConcurrency $null

2. Display a list of your Throttling Policies using the following command:

Get-ThrottlingPolicy

3. From the "Get-ThrottlingPolicy" output locate and copy the "DefaultThrottlingPolicy" name.

Example: "DefaultThrottlingPolicy_a1f84187-7a42-4ece-9276-06c704be21e7"

4. Now enter the command below but paste in your DefaultThrottlingPolicy name.

Set-Mailbox "BESAdmin" -ThrottlingPolicy <Default Policy Name>

Example: Set-Mailbox "BESAdmin" DefaultThrottlingPolicy_a1f84187-7a42-4ece-9276-06c704

5. Now we need to remove the BESPolicy that isn't required by issuing the command below:

Remove-ThrottlingPolicy BESPolicy
Offline  
Old 04-08-2010, 11:23 AM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I will give this a try and report back. I had found a guide, and tried changing the RCAMaxConcurrency setting to unlimited, but not where I had to change the throttling policy BESAdmin was on.

They decided to upgrade exhchange servers while i was on holidays, and they did follow the guide for exchange 2010, but because I wasn't the one who did it it's hard to know exactly what they did, which makes this all that much harder to nail down =/
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Old 04-08-2010, 01:01 PM   #7 (permalink)
New Member
 
Join Date: Jan 2008
Model: 8830
PIN: N/A
Carrier: Sprint
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

wunderbar,

I had this EXACT issue. I set all of the throttling policies to no avail. However, after installing Exchange 2010 Rollup 2 my issue was finally resolved.

I hope this helps. If you are like me, you were ready to kick kittens over this.

Chad


Note: I tried to include the link but my post count is too low.
Offline  
Old 04-08-2010, 01:29 PM   #8 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Passp
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,817
Post Thanks: 287
Thanked 305 Times in 287 Posts
Default

Exchange 2010 RU2 can be downloaded from the following link

Download details: Update Rollup 2 for Exchange Server 2010 (KB979611)

The link below is a list of fixes included in Ru2

Description of Update Rollup 2 for Exchange Server 2010: February 18, 2010
__________________
unlock you phone here http://cellunlocker.net/blackberry-unlock.php
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Passport, Z30, Z10 and Q10
Offline  
Old 04-08-2010, 01:53 PM   #9 (permalink)
New Member
 
Join Date: Jan 2008
Model: 8830
PIN: N/A
Carrier: Sprint
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks, Knotty!
Offline  
Old 04-08-2010, 02:11 PM   #10 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Passp
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,817
Post Thanks: 287
Thanked 305 Times in 287 Posts
Default

Welcome
__________________
unlock you phone here http://cellunlocker.net/blackberry-unlock.php
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Passport, Z30, Z10 and Q10
Offline  
Old 04-08-2010, 03:20 PM   #11 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, bigwilloc's suggestion did not work, even after a reboot of the BES server. we are already on update rollup 2 for exchange, so that's a no go either.

I'm almost at the point where I just need to go through the entire checklist again on the exchange server. I'm completely dumbfounded as to why this is affecting 5 out of 40 users, and was working just fine 2 days before.
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Old 04-09-2010, 09:54 AM   #12 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, I went through most of the checklist, and still nothing. I opened a ticket with RIM (we only have email support) 2 days ago, and still haven't even received a reply.

This is getting really frustrating.
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Old 04-09-2010, 03:53 PM   #13 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Passp
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,817
Post Thanks: 287
Thanked 305 Times in 287 Posts
Default

You can get a free support call, look at my signature
__________________
unlock you phone here http://cellunlocker.net/blackberry-unlock.php
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Passport, Z30, Z10 and Q10
Offline  
Old 04-12-2010, 07:58 PM   #14 (permalink)
New Member
 
Join Date: Apr 2010
Model: 8230
PIN: N/A
Carrier: Verizon
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Any Luck?

I'm having the same problem.

Have you come up with a resolution?
Offline  
Old 04-13-2010, 12:29 PM   #15 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

No resolution so far, I'm still working with RIM T-support. I actually have a new issue as well, some users, unrelated to the issue with no users working at all, are having calendar sync issues, as in, it's not working.

Gotta say not impressed with RIM right now. This is not a smooth transition.
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Old 04-14-2010, 04:25 AM   #16 (permalink)
New Member
 
Join Date: Jan 2010
Model: 9000
PIN: N/A
Carrier: T-Mobile-UK
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Wunderbar,

Just to add to your proof to Rim, I too have the exact same problem, i have about 24 people in and the remainder including myself, stuck not being able do anything, if you find anything out please let me out of the hell i am in

Last edited by Al0w3 : 04-14-2010 at 04:32 AM.
Offline  
Old 04-14-2010, 11:16 AM   #17 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Al0w3 View Post
Hi Wunderbar,

Just to add to your proof to Rim, I too have the exact same problem, i have about 24 people in and the remainder including myself, stuck not being able do anything, if you find anything out please let me out of the hell i am in
Yea, I will be calling RIM today. The end of the line for email support was basically a "yea, we're not sure, you should probably call us." So as soon as I'm at my actual office instead of one of the satellites today, I'll be calling later on and will keep everyone updated as to what RIM says.
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Old 04-14-2010, 01:26 PM   #18 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok folks, another symptom, not sure if it's related to the same issue or not. This appears to be affecting all BlackBerry users. When a meeting request is sent, what the user gets on their blackberry appears to be just an email, not a meeting request, with no way to accept/deny it. If i accept a request in outlook, it goes into my outlook calendar, but does not get pushed to the BlackBerry. Calendar entries created on BlackBerry do not go to outlook.

I know that the CDO is good, as I have re-installed the latest version within the last week as part of trying to fix the other issues we are having
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Old 04-14-2010, 02:05 PM   #19 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, I just went through the log files and it's saying my CDO isn't registered, for some reason, so I think that's an easy fix.

I've also found something interesting in the log files, maybe someone can help me with. I found a line that points to our old exchange server, the one that was on 2007. When we moved to 2010 we also moved to new hardware, so that was part of our transition. The specific line in the log is:

[30000] (04/13 07:42:17.131):{0x36C} [ENV] Server DN: /o=Diversity Technologies Corporation/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=SEEXCHANGE

That's the only mention of the old server in the file, everything else refrences our new exchange server.

Could that have anything to do with the issues we are having, can anyone else having this same issue look in their logs and see if there are any references to old exchange servers?
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Old 04-14-2010, 03:00 PM   #20 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Passp
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,817
Post Thanks: 287
Thanked 305 Times in 287 Posts
Default

If CDO is not registered it can do some weird things with calendar.
__________________
unlock you phone here http://cellunlocker.net/blackberry-unlock.php
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Passport, Z30, Z10 and Q10
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.