BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   BlackBerry Dispatcher (http://www.blackberryforums.com/bes-admin-corner/229842-blackberry-dispatcher.html)

Berrial 06-29-2010 03:49 PM

BlackBerry Dispatcher
 
Hello,

The Blackberry server is not functioning at all at this point and I am receiving BlackBerry Controller errors like this:

Unable to connect to Dispatcher 'BLACKBERRY'

and

Could not connect to Service Control Manager at \\127.0.0.1: 1722

within seconds of each other back to back.

I have tried resetting all the services, rebooting, checked cables, connections. I can ping my internal network and can surf the internet but these two errors keep popping up, preventing the server from functioning at all.

This morning I noticed that the connection was flaking in and out, dropping connection and coming back up. I switched it to a different drop and then a solid orange light came on the NIC. This is running at a 1gb connection, and I drop it down to 100 Full duplex and I get a solid green light. I dont know if the NIC is going bad or not just some added information.

Any help would be appreciated.

freakinvibe 06-30-2010 05:11 AM

The problem is that for what ever reason, some of the Blackberry Services don't start. Check the Windows Services (services.msc). Go through the steps of this KB article:

BlackBerry Controller cannot start BlackBerry Messaging Agent processes

Berrial 06-30-2010 08:03 AM

Dispatcher
 
Freakinvibe,
Thanks for your response, I have tried all the suggestions in the KB article you sent but I am still having the same two errors pop up:

[20000] (10/05 10:56:57.254):{0x2BC} Could not connect to Service Control Manager at \\127.0.0.1: 1722

[20000] (10/05 10:56:57.254):{0x2BC} Unable to connect to Dispatcher '<BlackBerry_Enterprise_Server_name>'

I dont have IPv6 installed, i have stopped and restarted each of the services it said to and I am unsure about this master browser section it is telling me about.. I made sure that the services are running against an account with full administrative rights. I am still getting these two errors.

Any other ideas?

Thanks again!

Berrial 07-01-2010 12:46 PM

man... hour 14 with RIM and to no avail... still down :( :( any help is still appreciated...

knottyrope 07-01-2010 01:31 PM

is windows firewall on?

was the computer updated?

Update to latest NIC drivers?

If a dual NIC, can you disable one?

Berrial 07-01-2010 02:04 PM

Windows Firewall is turned off

I have not updated the server in about two weeks

I have checked for updates on the NIC, uninstalled and reinstalled

I only have one enabled but I have swapped between to the two for testing but same results come back.

I have also made sure that HBSS isnt blocking, firewall ports are open for the Blackberry ports 3200, 3101. Made the reserveports registry key change to 1432-9001 per RIM.

Updated GroupWise client on server to HP5.

freakinvibe 07-02-2010 01:24 AM

In services.msc, are all the BB services started?

Also, what error messages do you see in the DISP and in the CTRL log?

Berrial 07-02-2010 09:42 AM

Freakinvibe,
All the services report automatic and started except the MDS Integration service, which I researched doesnt start until it needs to. Most are using the built in administrator account to run the services. Made sure the password was correct.

in the CTRL log I get this error over and over:

[30000] (06/30 00:03:30.265):{0xB78} Starting MDS Services 'local'
[30000] (06/30 00:03:30.296):{0xB78} MDS Services 'local' started
[30000] (06/30 00:03:30.296):{0xB78} MDS Services state: Starting, PID=3504
[30000] (06/30 00:03:32.296):{0xB78} MDS Services state: Stopped, PID=0
[30000] (06/30 00:03:32.296):{0xB78} Found unexpectedly terminated MDS Services 'local'
[20000] (06/30 00:03:34.312):{0xB78} Could not connect to Service Control Manager at \\127.0.0.1: 1722
[20000] (06/30 00:03:34.312):{0xB78} Unable to connect to Dispatcher 'USUBLACKBERRY'
[30000] (06/30 00:03:40.312):{0xB78} MDS Services 'local' will start in 50 seconds
[20000] (06/30 00:03:44.328):{0xB78} Could not connect to Service Control Manager at \\127.0.0.1: 1722
[20000] (06/30 00:03:44.328):{0xB78} Unable to connect to Dispatcher 'USUBLACKBERRY'
[30000] (06/30 00:03:50.328):{0xB78} MDS Services 'local' will start in 40 seconds
[20000] (06/30 00:03:54.343):{0xB78} Could not connect to Service Control Manager at \\127.0.0.1: 1722
[20000] (06/30 00:03:54.343):{0xB78} Unable to connect to Dispatcher 'USUBLACKBERRY'
[30000] (06/30 00:04:00.343):{0xB78} MDS Services 'local' will start in 30 seconds
[20000] (06/30 00:04:04.343):{0xB78} Could not connect to Service Control Manager at \\127.0.0.1: 1722
[20000] (06/30 00:04:04.343):{0xB78} Unable to connect to Dispatcher 'USUBLACKBERRY'
[30000] (06/30 00:04:10.343):{0xB78} MDS Services 'local' will start in 20 seconds
[20000] (06/30 00:04:14.343):{0xB78} Could not connect to Service Control Manager at \\127.0.0.1: 1722
[20000] (06/30 00:04:14.343):{0xB78} Unable to connect to Dispatcher 'USUBLACKBERRY'
[30000] (06/30 00:04:20.343):{0xB78} MDS Services 'local' will start in 10 seconds
[20000] (06/30 00:04:24.343):{0xB78} Could not connect to Service Control Manager at \\127.0.0.1: 1722
[20000] (06/30 00:04:24.343):{0xB78} Unable to connect to Dispatcher 'USUBLACKBERRY'
[30000] (06/30 00:04:30.343):{0xB78} Starting MDS Services 'local'
[30000] (06/30 00:04:30.375):{0xB78} MDS Services 'local' started

and in the DISP log:

[30000] (06/30 00:03:30.265):{0xB78} Starting MDS Services 'local'
[30000] (06/30 00:03:30.296):{0xB78} MDS Services 'local' started
[30000] (06/30 00:03:30.296):{0xB78} MDS Services state: Starting, PID=3504
[30000] (06/30 00:03:32.296):{0xB78} MDS Services state: Stopped, PID=0
[30000] (06/30 00:03:32.296):{0xB78} Found unexpectedly terminated MDS Services 'local'
[20000] (06/30 00:03:34.312):{0xB78} Could not connect to Service Control Manager at \\127.0.0.1: 1722
[20000] (06/30 00:03:34.312):{0xB78} Unable to connect to Dispatcher 'BLACKBERRY'
[30000] (06/30 00:03:40.312):{0xB78} MDS Services 'local' will start in 50 seconds
[20000] (06/30 00:03:44.328):{0xB78} Could not connect to Service Control Manager at \\127.0.0.1: 1722
[20000] (06/30 00:03:44.328):{0xB78} Unable to connect to Dispatcher 'BLACKBERRY'
[30000] (06/30 00:03:50.328):{0xB78} MDS Services 'local' will start in 40 seconds
[20000] (06/30 00:03:54.343):{0xB78} Could not connect to Service Control Manager at \\127.0.0.1: 1722
[20000] (06/30 00:03:54.343):{0xB78} Unable to connect to Dispatcher 'BLACKBERRY'
[30000] (06/30 00:04:00.343):{0xB78} MDS Services 'local' will start in 30 seconds
[20000] (06/30 00:04:04.343):{0xB78} Could not connect to Service Control Manager at \\127.0.0.1: 1722
[20000] (06/30 00:04:04.343):{0xB78} Unable to connect to Dispatcher 'BLACKBERRY'
[30000] (06/30 00:04:10.343):{0xB78} MDS Services 'local' will start in 20 seconds
[20000] (06/30 00:04:14.343):{0xB78} Could not connect to Service Control Manager at \\127.0.0.1: 1722
[20000] (06/30 00:04:14.343):{0xB78} Unable to connect to Dispatcher 'BLACKBERRY'
[30000] (06/30 00:04:20.343):{0xB78} MDS Services 'local' will start in 10 seconds
[20000] (06/30 00:04:24.343):{0xB78} Could not connect to Service Control Manager at \\127.0.0.1: 1722
[20000] (06/30 00:04:24.343):{0xB78} Unable to connect to Dispatcher 'BLACKBERRY'
[30000] (06/30 00:04:30.343):{0xB78} Starting MDS Services 'local'
[30000] (06/30 00:04:30.375):{0xB78} MDS Services 'local' started

and

[20000] (06/30 07:31:05.125):{0x18A8} SRPClient::Connect: Error calling host "localhost" [127.0.0.1] (10061)
[20000] (06/30 07:31:05.125):{0x18A8} [SRP] Connection failed
[20460] (06/30 07:31:05.125):{0x18A8} [SRP] Connection failed
[30000] (06/30 07:31:05.125):{0x18A8} [SRP] Connection lost
[30127] (06/30 07:31:08.312):{0x1958} [BIPPe] Connection established with 131.158.7.112 0x003efbf8
[30514] (06/30 07:31:08.312):{0x19DC} [BIPPe] (S55719130:C3,agent_sync) Connecting secure client
[30513] (06/30 07:31:08.328):{0x19DC} [BIPPe] (S55719130:C3,agent_sync) Authenticated 0x003efbf8
[30127] (06/30 07:31:08.343):{0x1958} [BIPPe] Connection established with 131.158.7.112 0x00f752b8
[30514] (06/30 07:31:08.359):{0x19DC} [BIPPe] (S55719130:C3,SYNC) Connecting secure client
[30513] (06/30 07:31:08.375):{0x19DC} [BIPPe] (S55719130:C3,SYNC) Authenticated 0x00f752b8
[30000] (06/30 07:31:08.375):{0x18A8} SRPClient::ReceivePacket: No received bytes (0)
[20000] (06/30 07:31:08.375):{0x18A8} SRPClient::Connect: Error calling host "localhost" [127.0.0.1] (0)
[20000] (06/30 07:31:08.375):{0x18A8} [SRP] Connection failed
[20460] (06/30 07:31:08.375):{0x18A8} [SRP] Connection failed
[30127] (06/30 07:31:55.046):{0x1958} [BIPPe] Connection established with 131.158.7.112 0x00fb1770
[30127] (06/30 07:31:55.046):{0x1958} [BIPPe] Connection established with 131.158.7.112 0x00fc7670
[30514] (06/30 07:31:55.046):{0x19DC} [BIPPe] (S55719130:C3,IPPP) Connecting secure client
[30514] (06/30 07:31:55.046):{0x19DC} [BIPPe] (S55719130:C3,BBIM) Connecting secure client
[30513] (06/30 07:31:55.078):{0x19DC} [BIPPe] (S55719130:C3,IPPP) Authenticated 0x00fb1770
[30513] (06/30 07:31:55.078):{0x19DC} [BIPPe] (S55719130:C3,BBIM) Authenticated 0x00fc7670
[30000] (06/30 07:32:12.593):{0x18A8} [SRP] Connection established
[30000] (06/30 07:32:12.593):{0x1C9C} [DIAG] EVENT=Register_thread, THREADID=0x1C9C, THREADNAME="SRPClientReceiver"
[50096] (06/30 07:32:12.593):{0x18A8} [SRP] Dispatcher\SRP Connection established

and numerous lines of users trying to connect and failing.

knottyrope 07-02-2010 11:00 AM

look at blue in my signature and sign up, there is a test to see if your SRP is being blocked.

Berrial 07-02-2010 11:35 AM

im trying to fill in my SRP ID and it wont let me input the ID it just shows a drop down box of some other SRP and I cant clear it out... auth box works fine...

nm i found out how to work around it.

Berrial 07-02-2010 11:39 AM

The test said it was connected and enabled with the infrastructure... i had an account on there already, just tried the test..

nrgadmin 08-03-2010 05:27 AM

The Fix!
 
Same issue, heres the fix!

BES support told me to reinstall all my windows updates (i just installed over 90 windows updates!!!!!).

I narrowed them down to one suspect update - KB980232 (SMB updates)

its part of a bigger rollup pack (MS10-20).

Uninstall this update, reboot. BES wont work... Windows update again (SQL SP3 et all), reboot. BES will work. I cant say EXACTLY what the re-update does, but it sure as heck fixes it. It makes me so happy i didnt install 90 updates manually.

Hope this helps someone!!!

BTW heres how you know you have the problem.

go to start->run cmd.exe
c:\> new view
SYSTEM ERROR 87 HAS OCCURRED

if you receive the above error, you need to follow my fix above.

jbown 10-01-2010 05:48 PM

I'm very happy to say that after spending almost 5 hours trying to fix this exact same issue for one of my clients I came across this post. The information provided by nrgadmin has helped me resolve the issue and I have a working BES server again.

I had just about given up on it, and I read the advice regarding Microsoft Patch KB980232. The strange thing is that this server had that patch installed several months prior to this issue arising which is bizarre.

I followed the steps by removing the patch, rebooting, then installing all outstanding patches from Microsoft Update, including KB980232. Everything just started working again.

One difference to nrgadmin in my case was the the "net view" command was working fine. However the command "sc \\127.0.0.1 query" would return an error saying that the "RPC Server was unavailable". Checking on several other servers that didn't have issues, that "sc" command worked fine. As soon as KB980232 was removed, then re-installed with the other patches the "sc" command worked as expected and produced a large amount of output about the services on the box.

KB980232 is a patch for the SMB Client as nrgadmin stated. There is obviously something going on deep inside the networking stack that breaks something to do with NetBIOS listening on the localhost IP. But I'm not prepared to spend another day researching it at this stage.

Also worth noting is we came across another issue at a completely different site a few days later. A Multi-Function printer/scanner had all of a sudden lost the ability to save files to a server that had been working for over 12 months prior. I suspected a similar problem, and sure enough when I tested with the "sc \\127.0.0.1 query" command I received the same RPC error. I applied the same method as recommended by nrgadmin (remove KB980232, reboot, re-install all patches) and the problem was solved!

So I'd just like to say a big thanks to nrgadmin :)

Regards,

Jeff

SoUnCool 12-16-2010 09:44 AM

Re: BlackBerry Dispatcher
 
i had same issue, and this fix worked for me , thank you nrgadmin


All times are GMT -5. The time now is 11:36 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.