BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-13-2010, 05:06 AM   #1 (permalink)
Kul
Talking BlackBerry Encyclopedia
 
Kul's Avatar
 
Join Date: May 2005
Location: London, England.
Model: 9300
Carrier: Vodafone (UK)
Posts: 442
Post Thanks: 19
Thanked 2 Times in 2 Posts
Default Error Pushing 3rd Party App to device

Please Login to Remove!

I am having issues pushing a 3rd party app (Xing.de) to the 8900 HH (4.6.1.310) from BES 4.1.6

I have updated the device.xml and vendor.xml files and seen that the 8900 Device is listed, repackeaged the app (basically recreating the specification and pkgDBCache files

I have also installed the same version of the device software on the BES Server (4.6.1.310) which is same on the device, also restarted Policy Service just incase. I also looked at this thread Hhcm_device_not_supported

But still getting HHCM_DEVICE_NOT_SUPPORTED Error

Policy Error Log shows detailed errors below:

[40000] (07/13 10:45:26.439):{0xD58} {First.Name@mydomain.com, PIN=MydevicePin, UserId=804}SCS::PollDBQueueNewRequests - Queuing POLL_FOR_MISSING_APPS request
[40000] (07/13 10:45:26.439):{0xBE0} RequestHandler::PollForMissingApps: Starting Poll For Missing Apps.
[40000] (07/13 10:45:26.439):{0xBE0} SCS::RemoveAppDeliveryRequests - No App Delivery Requests purged for User id 804
[40000] (07/13 10:45:26.455):{0xD58} SCS::PollDBQueueNewRequests - Change Detection Poll: ProcessingRequests 1, LowerThreshhold 30, ProcessingBESes 1, MaxDomainJobs 300, MaxJobsToSchedule 300, MaxBESJobs 100, MaxRequestsToQueue 100, Requests 0, QueueInterval (ms) 0.
[20000] (07/13 10:45:26.923):{0xBE0} Error validating package cache: C:\Program Files\Research In Motion\BlackBerry Enterprise Server\PackageCache\FILESHARE_BESSVR\bes apps\Xing.de Error: The operation completed successfully.
[20000] (07/13 10:45:26.923):{0xBE0} Failed to InitializeSharedPackageSources for hardwareId 0 and flashSize 0.
[20000] (07/13 10:45:27.673):{0xBE0} Error validating package cache: C:\Program Files\Research In Motion\BlackBerry Enterprise Server\PackageCache\FILESHARE_BESSRV\bes apps\Xing.de Error: The operation completed successfully.
[20000] (07/13 10:45:27.673):{0xBE0} Failed to InitializeSharedPackageSources for hardwareId 84001503 and flashSize 262144.
[20000] (07/13 10:45:27.673):{0xBE0} {First.Name@mydomain.com, PIN=MydevicePin, UserId=804}RequestHandler::PollForMissingApps: GetHHCodePackages failed with the error: HHCM_DEVICE_NOT_SUPPORTED.
[40000] (07/13 10:45:27.673):{0xBE0} RequestHandler::PollForMissingApps: Completed Poll For Missing Apps, elapsed time 1.234 seconds.
[40000] (07/13 10:45:27.673):{0xBE0} RequestHandler::DoWork - PollForMissingApps failed.

any other ideas how I could possibly resolve this or what I am doing wrong ?

Last edited by Kul : 07-13-2010 at 05:12 AM. Reason: forgot to put the linked thread
Offline  
Old 07-13-2010, 07:36 AM   #2 (permalink)
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Post Thanks: 6
Thanked 9 Times in 9 Posts
Default

Access this link for device.xml:

https://www.blackberry.com/Desktop/D...XML/Device.xml

Search for hardware ID "84001503", which reports "HHCM_DEVICE_NOT_SUPPORTED".

You are missing these in your device.xml:-

- <!-- javelin
-->
<os model="8900" radio="GPRS-WLAN" series="Javelin" Colour="True" Theme="Normal" JVMLevel="1.0" Camera="True" VideoRecorder="True" VoiceNotes="True" pttApp="True" Memory="Large" KeyboardType="Qwerty" Sound="Tunes8700g" SystemSize="normal" Bluetooth="True" MMS="True" GPS="True" ThemeSupport="Enhanced" VAD="True" JPN_Input="True">0x84001503</os>


Sources:
KB16162
KB13589
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.

Last edited by noname : 07-13-2010 at 07:39 AM. Reason: Added KB Sources.
Offline  
Old 07-13-2010, 08:21 AM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default

It is essential that your device.xml is in the right directory within the share that you have setup for the application, so if you use

C:\Program Files\Common Files\Research In Motion

as your share then the Device.xml is in

C:\Program Files\Common Files\Research In Motion\AppLoader
Offline  
Old 07-13-2010, 08:41 AM   #4 (permalink)
Kul
Talking BlackBerry Encyclopedia
 
Kul's Avatar
 
Join Date: May 2005
Location: London, England.
Model: 9300
Carrier: Vodafone (UK)
Posts: 442
Post Thanks: 19
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by noname View Post
Access this link for device.xml:

https://www.blackberry.com/Desktop/D...XML/Device.xml

Search for hardware ID "84001503", which reports "HHCM_DEVICE_NOT_SUPPORTED".

You are missing these in your device.xml:-

- <!-- javelin
-->
<os model="8900" radio="GPRS-WLAN" series="Javelin" Colour="True" Theme="Normal" JVMLevel="1.0" Camera="True" VideoRecorder="True" VoiceNotes="True" pttApp="True" Memory="Large" KeyboardType="Qwerty" Sound="Tunes8700g" SystemSize="normal" Bluetooth="True" MMS="True" GPS="True" ThemeSupport="Enhanced" VAD="True" JPN_Input="True">0x84001503</os>


Sources:
KB16162
KB13589
I have had a look at the latest device.xml file and the section you mention above IS THERE. I did download the lastest device and vendor.xml files from the link that you gave.

Also eventhough I get the error "HHCM_DEVICE_NOT_SUPPORTED" I dont exactly get "HHCM_DEVICE_NOT_SUPPORTED. Upgrade your copy of device.xml"
Offline  
Old 07-13-2010, 08:47 AM   #5 (permalink)
Kul
Talking BlackBerry Encyclopedia
 
Kul's Avatar
 
Join Date: May 2005
Location: London, England.
Model: 9300
Carrier: Vodafone (UK)
Posts: 442
Post Thanks: 19
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by freakinvibe View Post
It is essential that your device.xml is in the right directory within the share that you have setup for the application, so if you use

C:\Program Files\Common Files\Research In Motion as your share then the Device.xml is in C:\Program Files\Common Files\Research In Motion\AppLoader
Mine looks ok and in the location:
I have shared "c:\program files\common Files\research in motion" with sharename "Research in motion" and the device.xml is in "c:\program files\common Files\research in motion\apploader"
Offline  
Old 07-14-2010, 07:08 AM   #6 (permalink)
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Post Thanks: 6
Thanked 9 Times in 9 Posts
Default

Using "Failed to InitializeSharedPackageSources for hardwareId" from yor listed error, I can find KB15365. Give it a try and let's us know...

KB15365 - View Document
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Old 07-14-2010, 11:05 AM   #7 (permalink)
Kul
Talking BlackBerry Encyclopedia
 
Kul's Avatar
 
Join Date: May 2005
Location: London, England.
Model: 9300
Carrier: Vodafone (UK)
Posts: 442
Post Thanks: 19
Thanked 2 Times in 2 Posts
Default

I am using the BESADMIn account, same as what the Policy Service is configired with and also, using the same account. I have tested now pushing other Apps i.e. Bloomberg and they work fine to the same device.

Could it be that the alx file provided by the vendor to me isnt correct one ???
Offline  
Old 07-15-2010, 01:22 AM   #8 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default

Could be! .alx files are plain text, so you can look at them with Notepad, check if all the modules in the file are really there and if there are no restrictions to certain Blackberry models.
Offline  
Old 07-16-2010, 07:47 AM   #9 (permalink)
Kul
Talking BlackBerry Encyclopedia
 
Kul's Avatar
 
Join Date: May 2005
Location: London, England.
Model: 9300
Carrier: Vodafone (UK)
Posts: 442
Post Thanks: 19
Thanked 2 Times in 2 Posts
Default

when i tried to open the alx file in notepad it seemed wonglyed formatted, i created it properly and still doesnt work. I have asked the vendor to send me the files again, but could it be that since I have corrected the alx file, the cod file needs to be created as well ?
Offline  
Old 07-16-2010, 07:53 AM   #10 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default

How did you create the .alx file?

An .alx file could look like

Code:
<loader version="1.0">
  <!-- Bloomberg for BlackBerry -->
  <application id="com.bloomberg.ax.mobile">
    <name>Bloomberg</name>
    <description>Bloomberg Apps for BlackBerry</description>
    <version>1.8.10.9</version>
    <vendor>BloombergLP</vendor>
    <copyright>Copyright (c) 2008 Bloomberg</copyright>
    <fileset Java="1.0">
      <directory/>
      <files>
        com_bloomberg_bblib.cod
        com_bloomberg_transport.cod
        com_bloomberg_launcher.cod
        com_bloomberg_msg.cod
        com_bloomberg_top.cod
        com_bloomberg_mkt.cod
        com_bloomberg_wei.cod
        com_bloomberg_quote.cod
        com_bloomberg_chart.cod
        com_bloomberg_ib.cod
        com_bloomberg_alrt.cod
        com_bloomberg_blawlib.cod
        com_bloomberg_people.cod
        com_bloomberg_transportlib.cod
        com_bloomberg_fly.cod
        com_bloomberg_dine.cod
        com_bloomberg_bbuilib.cod
        com_bloomberg_monitor.cod
        com_bloomberg_blaw.cod
        com_bloomberg_tk.cod
        com_bloomberg_eco.cod
        com_bloomberg_appframe.cod
        com_bloomberg_evts.cod
        com_bloomberg_tklib.cod
        com_bloomberg_citator.cod
        com_bloomberg_viewlib.cod
        com_bloomberg_osapi.cod
        com_bloomberg_personalmonitors.cod
        com_bloomberg_tw.cod
        com_bloomberg_ems.cod
        com_bloomberg_whatsnew.cod
      </files>
    </fileset>
  </application>
</loader>
But the vendor of the software should give you the proper file. Normally, there is no need to manually edit it.
Offline  
Old 07-16-2010, 10:55 AM   #11 (permalink)
Kul
Talking BlackBerry Encyclopedia
 
Kul's Avatar
 
Join Date: May 2005
Location: London, England.
Model: 9300
Carrier: Vodafone (UK)
Posts: 442
Post Thanks: 19
Thanked 2 Times in 2 Posts
Default

I have asked the vendor to send me the files again but waiting ......

Bloomberg and other apps are ok - its just this app called "Xing.De"

I was just trying to see if I can get it to work as I havent heard back from them.

Last edited by Kul : 07-16-2010 at 10:59 AM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.