BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-03-2010, 10:38 AM   #1 (permalink)
New Member
 
Join Date: Aug 2010
Model: 8520
PIN: N/A
Carrier: Vodafone
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES Express Send-As permission issues on Windows 2008 R2 \ Exchange 2010

Please Login to Remove!

I've finished a fresh BES Express installation on my organization.

All pre-requisites were met and the installation run smoothly.

When testing a user account I've found that Send-As permissions failed.

c:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\Utility> IEMSTest.exe

BlackBerry Enterprise Server Utility - IEMSTest.exe (IExchangeManageStore), Vers
ion 1.0
Copyright (c) Research In Motion, Ltd. 1999. All rights reserved.
Opening Default Message Store Mailbox - BeseAdmin

Test User: Opening message store using
/o=Domain/ou=OU/cn=Recipients/cn=Test User
/o=Domain/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=
Configuration/cn=Servers/cn=ExchangeSVR/cn=Microsoft Private MDB
Test User: Mailbox opened successfully
Test User: Root Folder opened successfully
Test User: Folder created successfully
Test User: Test folder deleted successfully
Test User: MAPI test completed successfully
Test User: CDO Server Name: ExcahngeSVR
Test User: CDO Mailbox DN: /o=my Domain/ou=IMA/cn=Recipients/cn=test User
Test User: CDO logon successful
Test User: Get default calendar folder successful
Test User: Get calendar folder name successful: 'Calendar'
Test User: CDO test completed successfully
Test User: No Send As permission for the {MOLDES\Besadmin} account oper
ator.

I've managed to set Send-As permissions in AD, but failed to do it running Exchangeshell cmdlet:

Add-ADPeermission -InheritedObjectType User -InheritanceType Descendents -ExtendedRights Send-As -User "BesAdmin" -Identity "CN=Users,DC=mydomain,DC=pt"

1. Exchange 2010 Update role up 3.

2. BES Express 5.0.1.13

3. Single BES Express Server (Hyper-V)
Offline  
Old 08-03-2010, 10:51 AM   #2 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,035
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

Moved to a more appropriate section.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 08-03-2010, 12:25 PM   #3 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Passp
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,760
Post Thanks: 274
Thanked 296 Times in 280 Posts
Default

Run it on a user and see what the results are.

FYI
Assign Send As permissions to all users via Active Directory

1. Open Active Directory.
2. Select the "View" menu and ensure "Advanced Features" is checked.
3. Right mouse click on your domain name and select Properties
4. Select the Security tab
5. Press the Advanced button at the bottom on the security tab
6. Select "Add" and enter your Blackberry Service Account name (e.g. BESadmin) and select OK
7. When the permissions screen appears change "Apply onto:" to "User Objects" (or xxx8220;Descendant User Objectsxxx8221; on Server 2008)
8. In the permissions box scroll down and check the Allow box beside "Send As" and press OK
9. Press Apply and OK to exit
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Passport, Z30, Z10 and Q10
Online  
Old 08-04-2010, 03:59 AM   #4 (permalink)
New Member
 
Join Date: Aug 2010
Model: 8520
PIN: N/A
Carrier: Vodafone
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

That was already done.
The Send As Permissions are replicated trough all AD DCs.
Offline  
Old 08-07-2010, 07:57 PM   #5 (permalink)
New Member
 
Join Date: Mar 2005
Model: 8300
Carrier: T-Mobile
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey thanks...

But guess what - Server updates and Update4 exchange 2010 breaks BES express (5.0.1.13). tearing my hair out

Everything was working fine unitl midnight on 2 Aug
- Applied new updates to exchange server
- built new BES sserver (no updates)
- all permissions are in place

error message now are:
(W) GetFreeBusyFodler - OpenEntry(2) (0x8000405)
(W) MailboxManager::SUbsystemINitiaalize - GetFreeBusy (0x80004005)
(E) Failed to retrive the Server DN, shutting down
(E) BlackBerry Messaging Agent ---- Agent 1 failed to start error code 5305

frustrated..

anyone have any idea (runnign update 4 exchange 2010)

Last edited by matt_the_katt : 08-07-2010 at 07:58 PM.
Offline  
Old 08-08-2010, 04:34 AM   #6 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

Dont know, why the Messaging agent terminates, but, have a closer look in the Logs folder which is in the Applications folder of the BES server, maybe you find more then just the "failed to retrieve the Server DN" - which means then BES is unable to locate the Exchange server.
Is the Windows Firewall on - turn it of to check if this makes a difference.
Is your DNS and WINS server working properly ?
Recreate the MAPI profile for the BES user:
KB10285 - View Document


regarding the Active directory permissions, try to use a program from rim:
http://www.blackberry.com/DST2007/pa...Permission.exe
Also, add the besadmin user manually in the exchange console the send as permissions to the user(s)
Offline  
Old 08-09-2010, 08:36 AM   #7 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Passp
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,760
Post Thanks: 274
Thanked 296 Times in 280 Posts
Default

is BES installed on a dedicated server?
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Passport, Z30, Z10 and Q10
Online  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.