BlackBerry Forums Support Community
              

Closed Thread
 
LinkBack Thread Tools
Old 01-18-2011, 10:38 PM   #21 (permalink)
Thumbs Must Hurt
 
Join Date: Aug 2006
Model: 9530
Carrier: Verizon
Posts: 193
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

Please Login to Remove!

Did you try re-creating the BES mapi profile? I had similar issues lately and a MAPI profile recreation fixed it. I can find the documentation if needed but it's a knowledge base article on RIM's site...
Offline  
Old 01-24-2011, 12:46 PM   #22 (permalink)
New Member
 
Join Date: Jan 2011
Model: 9330
PIN: N/A
Carrier: Verizon
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

KB article: 13374

"The BlackBerry® smartphone might receive email messages up to 15 minutes after the messages arrive on the source mailbox. This is by design. The BlackBerry® Infrastructure checks for new email messages every 15 minutes."
Offline  
Old 01-24-2011, 01:25 PM   #23 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: DT60
OS: 123456789
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 7,324
Post Thanks: 399
Thanked 406 Times in 372 Posts
Default Re: Message delays on BES 5.0.2

Quote:
Originally Posted by Mikey-AGBoston View Post
KB article: 13374

"The BlackBerry® smartphone might receive email messages up to 15 minutes after the messages arrive on the source mailbox. This is by design. The BlackBerry® Infrastructure checks for new email messages every 15 minutes."
That is for BIS.
__________________
I had to fall
To lose it all
But in the end
It doesn't even matter

Rocking the Motion with out lotion.
Offline  
Old 01-24-2011, 03:14 PM   #24 (permalink)
New Member
 
Join Date: Jan 2011
Model: 9330
PIN: N/A
Carrier: Verizon
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

Ah. So it is...
That revealed however, is there anyone out there, with BES 5.0.x, and Exchange 2010.. who has more than 100 users.. and never experiences these delays which so many of us are seeing?
Offline  
Old 01-24-2011, 04:21 PM   #25 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: DT60
OS: 123456789
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 7,324
Post Thanks: 399
Thanked 406 Times in 372 Posts
Default Re: Message delays on BES 5.0.2

What service pack on Exchange 2010?
__________________
I had to fall
To lose it all
But in the end
It doesn't even matter

Rocking the Motion with out lotion.
Offline  
Old 01-24-2011, 07:30 PM   #26 (permalink)
Thumbs Must Hurt
 
BB-Tech support's Avatar
 
Join Date: Apr 2010
Location: Ontario
Model: 9790
PIN: N/A
Carrier: Rogers
Posts: 162
Post Thanks: 0
Thanked 8 Times in 8 Posts
Default Re: Message delays on BES 5.0.2

Quote:
Originally Posted by Mikey-AGBoston View Post
Ah. So it is...
That revealed however, is there anyone out there, with BES 5.0.x, and Exchange 2010.. who has more than 100 users.. and never experiences these delays which so many of us are seeing?

Are there any errors in router log?
__________________
Someone who likes to help
Offline  
Old 01-25-2011, 09:39 AM   #27 (permalink)
New Member
 
Join Date: Jan 2011
Model: 9330
PIN: N/A
Carrier: Verizon
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

OK - So I called RIM.
I got to second level support.
Got myself a sharp cat on the line, who knew his such and such.
Told him the whole story... and I sent him the link to this thread, which he read.

So, then he said: ZIP UP your BES logs and your application log from your server, send them along, and we'll have a look.

Well, wouldn't you know.. after he, and a senior development analyst had a look at all of the logs, it was determind that there were no problems with my BES 5.0.2 / Exchange environment.


I do want to point out the following...
Have any of you had at the ActiveSync policies in Exchange 2010?
I have... It allows for the similar granularity of BES policies.
iPhones and Windows 7 phones are super fast with emails, GAL look ups, ect.
Microsoft has seemingly taken some time to develop this, nicely.

Can't help but wonder if MS is making it 'quirky' for BES on purpose ;)
( did anyone manage a Lotus shop, when Office 2000 came out?!?! )
Offline  
Old 01-25-2011, 09:49 AM   #28 (permalink)
New Member
 
Join Date: Jan 2011
Model: 9650
PIN: N/A
Carrier: Verizon
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

I'm not sure if this will help, but I have been fighting this issue for 3 weeks and believe that I have finally resolved it.

For the record, I tried all the work arounds. Static agents worked for about 15 minutes then started doing the same thing. Up to 30 minute delays in new emails to blackberry devices.

Little background about our environment. We run BES 5.0.2 on a windows 2003 server virtualized in VSphere. We are currently running a mixed mode Exchange environment with Exchange 2003 on Server 2003 physical boxes, and Exchange 2010 on a Server 2008 VSphere box. SQL is a 2005 Enterprise Virtual system. THe SQL server was P2V'ed, and the others were built from scratch. We have 80 users that have blackberry's. No other devices are allowed so we dont have any Iphones or Droid devices.

Troubleshooting and description. Our issue began 3 weeks ago when we moved a large chunk of our MAC users to the Exchange 2010 environment. Users started complaining of delayed new messages. I went through the typical steps of verifying cell service, sending test message from BES (Which were never delayed) and PIN to PIN messages.

Looking through the logs I got "Send Pipe Full" errors in the Router log. The Controller log showed a few errors that seemed to be related. I decided to open a ticket with RIM. I wont go into the saga of trying to get help with them, just believe that they are proud of their support staff and make you pay for it. 3 hours on the first call and I got nowhere. The Tech said he couldn't see anything wrong based on our log files. After arguing, we agreed that I would get a specific users incident, time and message number and call back. When I called back, it was about 30 minutes and the tech determined that UDP packets between the BES and the Exchange server were being dropped. He referenced this Blackberry KB article KB14139 and explained that I had network issues.

I wont bore you with the next steps, but just tell you that we discovered our VM's running an older version of the Virtual NIC (E1000). We updated our BES and our Exchange 2010 CAS server to use the VMware enhanced NIC and changed TX and RX size to 2048, disabled the Interrupt moderation.

THis seems to have resolved our problem. I dont know why the old NIC's were used to begin with, perhaps it was defaulted to when the system was created.

Hope this helps someone else. OR atleast points you int he right direction.
Offline  
Old 01-25-2011, 10:16 AM   #29 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: DT60
OS: 123456789
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 7,324
Post Thanks: 399
Thanked 406 Times in 372 Posts
Default Re: Message delays on BES 5.0.2

Quote:
Originally Posted by knottyrope View Post
What service pack on Exchange 2010?
???
__________________
I had to fall
To lose it all
But in the end
It doesn't even matter

Rocking the Motion with out lotion.
Offline  
Old 01-25-2011, 10:24 AM   #30 (permalink)
New Member
 
Join Date: Jan 2011
Model: 9330
PIN: N/A
Carrier: Verizon
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

Rtm, Ru4
Offline  
Old 01-25-2011, 12:58 PM   #31 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

We are seriously considering rolling back Exchange 2010 SP1 back to RTM. This is simply getting unacceptable. I've tried throwing more RAM at the server, using static agents, moving people around in those static agents, and nothing works for more than a couple days.
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Old 01-25-2011, 02:44 PM   #32 (permalink)
New Member
 
Join Date: Jan 2011
Model: 9330
PIN: N/A
Carrier: Verizon
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

I am on Exchange 2010, RTM RU4 and am too, suffering.
Offline  
Old 01-26-2011, 11:31 AM   #33 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

Can anyone else confirm that they are having this issue on Exchange 2010 RTM? I don't want to have us roll back to RTM only for the problem to continue. My manager would not be happy. =/
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Old 01-27-2011, 08:48 AM   #34 (permalink)
New Member
 
Join Date: Jan 2011
Model: 9330
PIN: N/A
Carrier: Verizon
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

Have you (anyone) tried assigning a static agents to any users?
Offline  
Old 01-27-2011, 12:15 PM   #35 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: DT60
OS: 123456789
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 7,324
Post Thanks: 399
Thanked 406 Times in 372 Posts
Default Re: Message delays on BES 5.0.2

Quote:
Originally Posted by Mikey-AGBoston View Post
Have you (anyone) tried assigning a static agents to any users?
Yes people have tried that.
__________________
I had to fall
To lose it all
But in the end
It doesn't even matter

Rocking the Motion with out lotion.
Offline  
Old 01-27-2011, 02:43 PM   #36 (permalink)
New Member
 
Join Date: Aug 2010
Model: 9700
PIN: N/A
Carrier: tmo
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

Hi
did anybody tried the solution that Rueburbon published
Blackberry support are leading me on a wild goose chase with perfmon etc for weeks now without admitting they have a problem in the software
so if anyone tried the solution please update.
Offline  
Old 01-27-2011, 03:39 PM   #37 (permalink)
New Member
 
Join Date: Jan 2011
Model: 9330
PIN: N/A
Carrier: Verizon
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

NIranec, is part/whole of your BES environment on VMWARE?
Offline  
Old 01-28-2011, 03:21 AM   #38 (permalink)
New Member
 
Join Date: Aug 2010
Model: 9700
PIN: N/A
Carrier: tmo
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

Yes Mikey-AGBoston, my whole environment is on a VMWARE
Offline  
Old 01-28-2011, 08:37 AM   #39 (permalink)
New Member
 
Join Date: Jan 2011
Model: 9330
PIN: N/A
Carrier: Verizon
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

Did you investigate your VNIC settings, as Rueburbon discovered and altered?
Our CAS is on VMware.. so I am begining to wonder.
The most perplexing issue is that during non-business, off peak hours, emails arrived within the minute of being sent...
Offline  
Old 01-28-2011, 10:15 AM   #40 (permalink)
Talking BlackBerry Encyclopedia
 
wunderbar's Avatar
 
Join Date: Jun 2007
Location: Edmonton AB, Canada
Model: 9630
Carrier: Telus
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Message delays on BES 5.0.2

Quote:
Originally Posted by Mikey-AGBoston View Post
Did you investigate your VNIC settings, as Rueburbon discovered and altered?
Our CAS is on VMware.. so I am begining to wonder.
The most perplexing issue is that during non-business, off peak hours, emails arrived within the minute of being sent...
The reason for that is with less emails being sent during off peak times, the queue has time to process. When the higher volume of emails come though the high latency means it can't keep up. I'm encountering the same issue with our environment.

our enviornment is virtualized, but running Hyper-V.
__________________
Blackberry Admin
BES 5.0.2 MR4
Exchange 2010 SP1 RU2
Blackberry 9630
WES 2008 Alumni
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

OEM BULB with Housing for DELL 725-10331 Projector with 180 Day Warranty
$309.0
OEM BULB with Housing for DELL 725-10331 Projector with 180 Day Warranty pictureOEM BULB with Housing for DELL 7700 FullHD Projector with 180 Day Warranty
$309.0
OEM BULB with Housing for DELL 7700 FullHD Projector with 180 Day Warranty pictureOEM BULB with Housing for DELL 725-10323 Projector with 180 Day Warranty
$309.0
OEM BULB with Housing for DELL 725-10323 Projector with 180 Day Warranty pictureOEM BULB with Housing for DELL S520N Projector with 180 Day Warranty
$109.0
OEM BULB with Housing for DELL S520N Projector with 180 Day Warranty pictureOEM AC Power Supply Adapter Lot EBice / Panasonic / LEI / Glob Tek / Dell / DVE
$89.95
OEM AC Power Supply Adapter Lot EBice / Panasonic / LEI / Glob Tek / Dell / DVE picture






Copyright © 2004-2016 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.