BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-03-2010, 07:40 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2005
Model: 8700R
Carrier: Rogers
Posts: 42
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Handheld calendar loses items with Exchange 2010 SP1?

Please Login to Remove!

Has anyone else seen any calendar issues with BES Express 5.0.x and Exchange 2010 SP1 where calendar entries on the Blackberry simply disappear after say 24 hours (I can't confirm the time interval yet)? Resyncing using RSET from Calendar --> Options returns the calendar entries for another period of time. 5.0.1 and 5.0.2 are both exhibiting this issue in conjunction with Exchange 2010 SP1.

On our first server, we upgraded from Exchange 2010 RTM + Hotfix 4 to Exchange 2010 SP1, and then a couple of days later from 5.0.1 to 5.0.2 (5.0.1 and 2010 RTM had been fine for over 5 months). On the second server we are seeing the issue with, we migrated from Exchange 2007 SP2 directly to Exchange 2010 SP1, and were seeing this issue on 5.0.1, after which we upgraded to 5.0.2. I'm 99.9% sure the BESAdmin permissions are correct. This is not affecting all users, but most users.

Anyone have any ideas?

dcc
Offline  
Old 09-04-2010, 04:52 AM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Location: Wellington, New Zealand
Model: 9700
Carrier: Telecom NZ
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey there, I see E2K10 SP1 is still being assessed for compatibility by RIM as per the latest available compatibility matrix.

BlackBerry - BlackBerry Enterprise Server Compatibility
__________________
Checkout Copy to Calendar @ http://www.thatboy.co.nz/copytocal
The quickest and easiest way to create calendar entries from your BlackBerry mailbox!
Offline  
Old 09-04-2010, 08:08 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2005
Model: 8700R
Carrier: Rogers
Posts: 42
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah - I know... Just a quick follow up. The removal of the calendar entries appears to occur every 6 hours.
Offline  
Old 09-12-2010, 11:00 AM   #4 (permalink)
New Member
 
Join Date: Sep 2010
Model: 9700
PIN: N/A
Carrier: T-mobile
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Same here

Same story for me. Exchange 2010 + SP1, BESX 5.0.2. My calendar keeps disappearing, and I have to do RSET on my handheld and wait for a reload. Quite annoying. Please keep me posted.
Offline  
Old 09-20-2010, 11:47 AM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2005
Model: 8700R
Carrier: Rogers
Posts: 42
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just an update. We are opening a support call with RIM this afternoon (finally broke down and got a TSupport contract). However, in trial and error, we found the calendar issue appears to be related with the number of entries you have in your calendar. The magic number is somewhere between 500 & 600 items. I had 1999 items this morning when we found this.

I exported my calendar to a PST, then deleted everything older than January 1, 2010, leaving me with 146 items. My calendar never cleared after a BES reboot as it was doing previously. I then re-imported my 2009 entries, which put me at a count of 606 items, and upon BES reboot it wiped. One of the guys on my support team discovered this, and I know the number was over 500, but less than 600, but I don't recall the exact number he found to be the make / break number.

dcc
Offline  
Old 09-20-2010, 12:24 PM   #6 (permalink)
New Member
 
Join Date: Sep 2010
Model: 9700
PIN: N/A
Carrier: T-mobile
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Update us

Please update us on your support case. I have over 600 calendar items, and it happens to me, but my brother has much much less and he is OK.

Mickey
Offline  
Old 09-20-2010, 05:23 PM   #7 (permalink)
New Member
 
Join Date: Sep 2010
Model: 8700
PIN: N/A
Carrier: na
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Public Folders

Do you have Public Folders turned on in your environment? Found some other posts online where this has worked for people.

I'm in the same boat btw. In the middle of an Exchange 2003-2010 SP1 migration and missed the fact BES doesn't support SP1 yet...
Offline  
Old 09-20-2010, 05:25 PM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2005
Model: 8700R
Carrier: Rogers
Posts: 42
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yup - Public Folders are on. RIM had us recreate the mapi configuration for BESAdmin this afternoon and it looked like that was gonna fix it, but after about 20 reboots of the BES, the handheld calendars wiped again.
Offline  
Old 09-20-2010, 05:38 PM   #9 (permalink)
New Member
 
Join Date: Sep 2010
Model: 8700
PIN: N/A
Carrier: na
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I know everyone has prob seen this too, maybe worth mentioning though

I can't post the link but if you google shudnow and exchange 2010 sp1 blackberry enterprise the link should be the first result. Discusses modifying the BESthrottling policy, however in the comments one guy had to apply the changes to his default throttling policy as well:

Get-ThrottlingPolicy | Set-ThrottlingPolicy -RCAPercentTimeInCAS:$null -RCAPercentTimeInMailboxRPC:$null -RCAMaxConcurrency:$null -RCAPercentTimeInAD:$null
Offline  
Old 09-20-2010, 05:45 PM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2005
Model: 8700R
Carrier: Rogers
Posts: 42
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

All RCA* settings are already null in both the default and the BES policies. You'll also note I've posted in the comments of that particular thread too...
Offline  
Old 09-20-2010, 05:47 PM   #11 (permalink)
New Member
 
Join Date: Sep 2010
Model: 8700
PIN: N/A
Carrier: na
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Oh that's funny, I did miss that. Let's hope RIM can figure out a workaround..
Offline  
Old 09-21-2010, 10:18 AM   #12 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2005
Model: Torch
Carrier: ATT
Posts: 179
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Full support for E2010 comes with BES5.0 SP3 - no release date yet.

Thanks for the info on throttling, do those disappearing Calendar items seem to be the only issues with BES5 and E2010?
Offline  
Old 09-21-2010, 10:50 AM   #13 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2005
Model: 8700R
Carrier: Rogers
Posts: 42
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thus far - that is our only know issue with BES 5.0.2 and Exchange 2010 SP1, out of 275 mailboxes...

Last edited by dcolpitts : 09-21-2010 at 10:51 AM. Reason: (typo)
Offline  
Old 09-22-2010, 11:06 AM   #14 (permalink)
New Member
 
Join Date: Sep 2010
Model: 9700
PIN: N/A
Carrier: T-mobile
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

do they have an ETA on when they will release the update? or did they provide a workaround?
Offline  
Old 09-22-2010, 11:46 AM   #15 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2005
Model: Torch
Carrier: ATT
Posts: 179
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks dcolpitts, we're just about to move into pilot with E2010 SP1 and according to test plan we won't hit 300 users (out of 80K) until mid Nov. Hopefully BES 5.0 SP3 will be released by then
Offline  
Old 09-22-2010, 11:56 AM   #16 (permalink)
New Member
 
Join Date: Sep 2010
Model: 9700
PIN: N/A
Carrier: T-mobile
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

FYI, I have 3 mailboxes and 1 is experiencing the calendar issue. It's not related to the quantity of mailboxes.
Offline  
Old 09-22-2010, 01:14 PM   #17 (permalink)
New Member
 
Join Date: Aug 2008
Model: 8320c
PIN: N/A
Carrier: Tmobile
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Supposedly Figured it out

So it would appear that in SP1, Microsoft introduced EWSFindCountLimit throttling. It will search for the first thousand entries, maybe on one user, or across all users, then respond to all subsequent find requests with an item not found message, which causes BES to think that the item has been deleted, and it tells the device to delete them. It will be fixed in SP3, but there is a workaround:
Set the EWSFindCountLimit to $null

1. On a computer that hosts the Microsoft Exchange Management Shell, open the Microsoft Exchange Management Shell.
2. Type New-ThrottlingPolicy BESPolicy.
3. Type Set-ThrottlingPolicy BESPolicy -RCAMaxConcurrency $null -EWSFindCountLimit $null -EWSMaxConcurrency $null
4. Type Set-Mailbox "BESAdmin" -ThrottlingPolicy BESPolicy.

Good luck!
Offline  
Old 09-22-2010, 01:15 PM   #18 (permalink)
Thumbs Must Hurt
 
Korbyn's Avatar
 
Join Date: May 2005
Location: Calgary, AB
Model: 9800
OS: 6.0.0.246
Carrier: Telus
Posts: 85
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Do you happen to notice a pattern at all with the device code? I remember with moving several systems from E2003 to E2007 that the calendars would duplicate with any device running 4.3 code. Two of the users I'm having troubles with are running 5.0 code and I've stopped moving anyone else, peoples calendars are to important to them.

Shudnow found some pretty handy changes, but it would seem MS has buried something else somewhere to screw RIM over again. Mind you they screwed most of the backup vendors too, SP1 might as well been E2011, everything has to be updated yet again.
Offline  
Old 09-22-2010, 01:23 PM   #19 (permalink)
Thumbs Must Hurt
 
Korbyn's Avatar
 
Join Date: May 2005
Location: Calgary, AB
Model: 9800
OS: 6.0.0.246
Carrier: Telus
Posts: 85
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

giving yours a try Opie. Thanks.
Offline  
Old 09-22-2010, 05:03 PM   #20 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2005
Model: Torch
Carrier: ATT
Posts: 179
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here's my issue. Our BESADMIN mailbox is on an E2K3 server so I can't apply the throttling policy to it as outlined in step 4:

4. Type Set-Mailbox "BESAdmin" -ThrottlingPolicy BESPolicy.

Seems very risky to migrate that mailbox to E2010 and have a chance at affecting the other 10K BB users with mailboxes still on E2K3.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.