BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-04-2010, 07:31 AM   #1 (permalink)
Thumbs Must Hurt
 
elbutre's Avatar
 
Join Date: Oct 2006
Location: London
Model: 9700
Carrier: vodafone
Posts: 75
Post Thanks: 2
Thanked 2 Times in 2 Posts
Default BEs monitoring page cannot login (5.0.2)

Please Login to Remove!

hi

on my new bes 5.0 HA setup i cannot login to the bms page

when i browse to it

https://bes01:8843/webconsole/app the page loads, get the ssl certificate error, then i get the login page.

enter my login details and after about 1 minute i get the message.

The application has encountered a system error. Please report this error to the System Administrator.
Please return to the home page or log in again.

the entry in the log is as follows:

(10/04 12:07:06:593):{http-8843-2} [com.rim.bes.bas.web.common.BASBasePage] [DEBUG] [BBAS-200] {unknown} User is logged in... need to refresh security session.
(10/04 12:07:06:597):{http-8843-2} [com.rim.bes.bms.web.console.base.UserSessionProxy] [DEBUG] [BBMS-200] {unknown} Invoke: isStoreToSessionNeeded using com.rim.bes.bms.web.console.base.impl.UserSessionI mpl

i have tried from a variety of different clients (cleared history cache etc) but no joy

on my production server (non HA) it is working absolutely fine

on both the production bes 5 and the test bes 5.0 HA all the bes services and sql services are installed on 1 server and have changed the port to 8843 so it does not conflict with the other service using the same default port of 8443

anyone else seen this?

cheers

Last edited by elbutre : 10-04-2010 at 07:33 AM.
Offline  
Old 10-04-2010, 09:18 AM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2007
Model: 9800
PIN: N/A
Carrier: LUXGSM
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Having the same error.
Try this : it works for me.

Apparently there is an issue with the WebGenKey.bat and post Sept 3rd.

Steps to correct
1) Shut down all four BMS services
2) Change the date on the server to Sept 1st 2010
3) Rename the web.keystore file to web.keystore.old in C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Monitoring Service\bin
4) open command prompt and drill down into C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Monitoring Service\bin
5)run this command and replace *password* with your ssl password and *FQDN* with the fqdn of your BMS server
webGenKey.bat "C:\PROGRA~1\Java\JDK16~1.0_1" "C:\PROGRA~1\RESEAR~1\BLACKB~1\MONITO~1\" *Password* *FQDN*
5)Open regedit and go to HKEY_CURRENT_USER\Software\Research In Motion\BlackBerry Enterprise Server\Monitoring Service\ change the KeyStorePass to what password you set in step 5 in the command.
6) Start all BMS services.
7) log into the BMS service.
Offline  
Old 10-04-2010, 10:35 AM   #3 (permalink)
Thumbs Must Hurt
 
elbutre's Avatar
 
Join Date: Oct 2006
Location: London
Model: 9700
Carrier: vodafone
Posts: 75
Post Thanks: 2
Thanked 2 Times in 2 Posts
Default

hi

i noticed that post but did not think it was applicable to my situation

will run this and let you know how it goes

thanks

Last edited by elbutre : 10-04-2010 at 10:40 AM.
Offline  
Old 10-04-2010, 11:24 AM   #4 (permalink)
Thumbs Must Hurt
 
elbutre's Avatar
 
Join Date: Oct 2006
Location: London
Model: 9700
Carrier: vodafone
Posts: 75
Post Thanks: 2
Thanked 2 Times in 2 Posts
Default

perfect, it did the trick for me too, thanks very much
Offline  
Old 10-05-2010, 06:22 AM   #5 (permalink)
Thumbs Must Hurt
 
elbutre's Avatar
 
Join Date: Oct 2006
Location: London
Model: 9700
Carrier: vodafone
Posts: 75
Post Thanks: 2
Thanked 2 Times in 2 Posts
Default

i rebooted the bes server this morning and the monitoring page is no longer working (Same error as before). is this expected behaviour after a reboot and do you have to do those 8 steps each time after a reboot? please tell me that is not the case
Offline  
Old 10-05-2010, 12:42 PM   #6 (permalink)
Knows Where the Search Button Is
 
TeBear77's Avatar
 
Join Date: Aug 2010
Model: 9630
PIN: N/A
Carrier: Verizon
Posts: 27
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

in the fix I posted when I reboot I do not have to redo the fix.

can you verify that in the registry the KeyStorePass is correct?
Offline  
Old 10-06-2010, 11:13 AM   #7 (permalink)
Thumbs Must Hurt
 
elbutre's Avatar
 
Join Date: Oct 2006
Location: London
Model: 9700
Carrier: vodafone
Posts: 75
Post Thanks: 2
Thanked 2 Times in 2 Posts
Default

the keystorepass is correct, just checked it
Offline  
Old 10-13-2010, 05:12 AM   #8 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Aug 2006
Location: South Africa
Model: 8310i
Carrier: Vodafone
Posts: 202
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

same here - page cannot be displayed
Offline  
Old 10-13-2010, 05:19 AM   #9 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Aug 2006
Location: South Africa
Model: 8310i
Carrier: Vodafone
Posts: 202
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I notced that in the registry there is a database folder under Blackberry Enterprise Server, this folder has the BES database in there, should this be the monitoring service DB?
Offline  
Old 10-13-2010, 08:34 AM   #10 (permalink)
Thumbs Must Hurt
 
Join Date: Sep 2005
Location: Rotterdam
Model: 8820
Carrier: KPN
Posts: 90
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

the webkeygen workaround failed for me, but the second workaround did the trick.

uninstall install monitoring service; then re-install monitoring service and do NOT start the services when done. Change the system time to sept 1, then start the services, and change back the system time when services are fully started.

does that work for you, or is uninstalling monitoring service not an option?
Offline  
Old 10-21-2010, 01:59 PM   #11 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Aug 2006
Location: South Africa
Model: 8310i
Carrier: Vodafone
Posts: 202
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This works

"uninstall install monitoring service; then re-install monitoring service and do NOT start the services when done. Change the system time to sept 1, then start the services, and change back the system time when services are fully started"
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.