BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-23-2010, 05:23 PM   #1 (permalink)
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Post Thanks: 6
Thanked 9 Times in 9 Posts
Arrow Knowledge Sharing - Expect problems with BES 5.0 SP1 GroupWise

Please Login to Remove!

Just wanted to share these information from my research so as to prevent anyone from falling into unnecessary troubles. If you want to install or upgrade your BES GroupWise to 5.0SP1, double-check your environment to ensure that the requirements are met first. Otherwise you will be having long hours of support and troubleshooting frustrations.


References

KB24504-BlackBerry Enterprise Server running on Windows Server 2003 or 2008 may stop responding due to a BlackBerry Messaging Agent memory leak
KB24579-Environmental considerations when upgrading to or installing BlackBerry Enterprise Server 5.0 SP1 for Novell GroupWise
KB24114-Recommended version of Novell GroupWise components for BlackBerry Enterprise Server 5.0.1
KB20798-Supported upgrade paths to BlackBerry Enterprise Server 5.0 SP1 for Novell GroupWise


After reading above references, the most stable configurations will be:-
  • Novell GroupWise 8.0.1 HP1
  • Windows 2008 SP2
  • Microsoft SQL 2005 SP3
Also, when upgrading to BESG 5.0.1, the recommended method of deployment is a new BlackBerry Domain with a new 5.0.1 BlackBerry Configuration database. This will require activating users from pre-existing BlackBerry Enterprise Servers on the new BESG 5.0.1. So, die die you must install a new BESG 5.0.1 server.

As per KB20798, there are 2 ways:-

(1) Install a new BESG 5.0.1 with a brand new BESMgmt database. Then use the Enterprise Transporter to move the existing users over.

(2) Ensure all existing BESG servers are upgraded to at least 4.1.3 (seems like the best is to be on latest 4.1.7 schema). Install a new BESG 5.0.1 and points to the existing BESMgmt database that host the BESG 4.1 servers. Then use the BAS Web Admin Console and move the users over.


Some remarks to note:

(1) Do not install BESG 5.0.1 on Windows 2003 servers, you will running in memory leak problems listed in KB24504.

(2) Do not install BESG 5.0.1 and join to an existing BESG 4.0.x, it appears as per KB20798 that you will run into some undisclosed issues moving users from this configurations.

Good luck for those who wanna risks these troubles by going forward with the upgrade. For now, I'm gonna stick with the less troublesome BESG 4.1.6MR6...
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.