BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-03-2010, 09:17 AM   #1 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Exclamation 9700 + OS6.0.0.344 - NO BIS internet workaround

Please Login to Remove!

I dont know, if this is a problem I have in particular, or, because RIM or my Wireless providers service-books are wrong for this version, or, if this is just a BETA problem, but, I cannot use BIS for Surfing or any Network connection. BES, WiFi, Wap works.
Result: if out of WiFi coverage, you cannot use the Browser.

So, If someone has the same problem:
Go into the policy Manager
Duplicate the used policy,
In the Browser section, under "MDS Browser Domains"
enter a "*"
Save, and apply the policy to the user.

After this, all Internet will be handeld by the MDS browser over the BES server.
Offline  
Old 11-04-2010, 12:19 AM   #2 (permalink)
Knows Where the Search Button Is
 
aygriffith's Avatar
 
Join Date: Apr 2010
Location: SLC
Model: 9700
OS: 6.0.0.344
PIN: 21C7D67D
Carrier: T-Mobile
Posts: 19
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I didn't have to do this when i upgraded my 9700 device to the 6.0 leak. I'm able to browse on 2G/3G and Wifi. Both before and after BES activation.

Was this carrier specific? I'm on T-Mobile US and the device is on our BESx environment.
__________________
BESx 5.0.2
Exchange 2007

7510 > 7520 > 7100i > 8700c > 8800 > 8320 > 8310 > 9630 > 9700 > 9650
Offline  
Old 11-04-2010, 04:08 AM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

Yes, this seems to be carrier specific. If the carrier does not have the correct service books for some function for OS6, some things wont work. Maybe, no BIS mail or, no BIS Internet.
Offline  
Old 11-05-2010, 08:02 PM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

To clarify this:
This is a workaround which works only for Blackberry owners which run their own Blackberry Enterprise Server. If you have only BIS servicebooks, you cannot use it.

This workaround will force all browser traffic through the BES connection, restoring the previous MDS Browser functionality.
(in OS6, by default, the MDS browser is only used if you surf to a private network address or, to URLS in you company network)

Last edited by nobody7290 : 11-05-2010 at 08:03 PM.
Offline  
Old 11-10-2010, 03:00 PM   #5 (permalink)
New Member
 
Join Date: Oct 2007
Model: 9700
PIN: N/A
Carrier: TMO
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm on T-Mobile US and BES as well, but can not get browser (on leaked OS6 for 9700) get working over wifi - works fine over 2G/3G, but as soon as I'm with-in my wireless network range - no internet browsing from the device ("Unable to connect to the selected Mobile Data Service, please try again later"). At the same time UMA works fine, WAP browser works fine over wifi... (I do not have MDS service enabled on BES. In OS5.x in options for the browser I was able to select "default browser", can't find this option under OS6, am I missing something?)

Any thoughts?



Quote:
Originally Posted by aygriffith View Post
I didn't have to do this when i upgraded my 9700 device to the 6.0 leak. I'm able to browse on 2G/3G and Wifi. Both before and after BES activation.

Was this carrier specific? I'm on T-Mobile US and the device is on our BESx environment.
Offline  
Old 11-10-2010, 03:46 PM   #6 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

If you go in to the connection menu, click left, choose "troubleshoot", then Wifi Diagnostics. Is there anything missing like the default gateway or DNS server ?
also try the nslookup command to lookup a known host, or try to ping a host which answers a ping ( www.apple.com will answer a ping).
Offline  
Old 11-10-2010, 04:05 PM   #7 (permalink)
New Member
 
Join Date: Oct 2007
Model: 9700
PIN: N/A
Carrier: TMO
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by nobody7290 View Post
If you go in to the connection menu, click left, choose "troubleshoot", then Wifi Diagnostics. Is there anything missing like the default gateway or DNS server ?
also try the nslookup command to lookup a known host, or try to ping a host which answers a ping ( will answer a ping).
Wifi diagnostics or Service Status all indicate that data connection present, UMA is active. Ping gets response from apple.com. Nslookup resolves as expected as well.
I'm certain its up to browser config/service book (btw tried restoring service books that I backed up before upgrading - no difference) in OS5 if I went into options with-in the browser, I had a choice between Blackberry (MDS), Internet and Wap browsers as a default browser - after software upgrade it was always defaulting to MDS (Blackberry browser) and I experienced the same symptoms as now (except browser didn't work at all regardless on connectivity method), after changing it to Internet Browser all worked well... Problem is I do not see an option in OS6 to choose the default browser.

Additional observations: 3rd party applications that rely on data connections work on 2g/3g & wifi (driveSafly, Google maps/voice/search, blackberry AppWorld)
Offline  
Old 11-10-2010, 04:13 PM   #8 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

Maybe, your admin has disabled the Wifi Browser ?
Dont know, what happens then, after the upgrade to OS6, because OS6 will try first Wifi and, if this does not work/is forbidden, it might give up.

read here:
9800, OS 6, & BES Browser Policy Woes...

(the linked pdfs)

for a more detailed explanation what happens to the browser choice after upgrade to OS6
Offline  
Old 11-10-2010, 04:59 PM   #9 (permalink)
New Member
 
Join Date: Oct 2007
Model: 9700
PIN: N/A
Carrier: TMO
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by nobody7290 View Post
Maybe, your admin has disabled the Wifi Browser ?
Dont know, what happens then, after the upgrade to OS6, because OS6 will try first Wifi and, if this does not work/is forbidden, it might give up.

read here:


(the linked pdfs)

for a more detailed explanation what happens to the browser choice after upgrade to OS6
Thank you for pointing me towards that thread, very useful stuff. I added OS6 specific policy rules to BES, verified policy settings, all appears to be set correctly... but still no luck with browser over wifi. Will dig deeper tomorrow.
Offline  
Old 11-10-2010, 05:16 PM   #10 (permalink)
New Member
 
Join Date: Oct 2007
Model: 9700
PIN: N/A
Carrier: TMO
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Resolved:

I set the following item in IT Policy to "False" Disable Wi-Fi Direct Access to Blackberry Enterprise Server

Set to True to disable direct access to the BlackBerry Enterprise Server from Wi-Fi networks using a direct BlackBerry Router connection. Set to False to allow direct access to the BlackBerry Enterprise Server from Wi-Fi networks. The default value is carrier-dependent; some carriers might turn off Wi-Fi access to the BlackBerry Enterprise Server by default.
Note, in order to disable Wi-Fi access to the BlackBerry Enterprise Server using BlackBerry Infrastructure, use the "BlackBerry Infrastructure Wi-Fi Access Mode" IT policy or Wi-Fi configuration setting. By using these settings together, you can completely turn off Wi-Fi access to the BlackBerry Enterprise Server and/or BlackBerry Internet Service.


And set "Allow Browser" to "True" (it was not specified and for some reason default settings "true" does not apply to OS6 - it needs to be set to "true" and everything is working now.

Still doesn't makes any sense since first policy does not affect Internet connectivity, that policy item should impact how BB accesses BES and not public internet. And second policy item even more confusing - since browser should be enabled by default if not prohibited, and it worked when not on Wifi... Oh well, important thing is that I got a fully functional BB back
Offline  
Old 11-10-2010, 05:30 PM   #11 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default

Great that your internet is working again.
The amount of policies which you can tweak seems endless.
I just looked up the item from your post, and noticed, that there is an item where you can allow a user to forward a WiFi profile per email/pin to another Blackberry user.
---
edit:
Mhm, turned that on, but I see no option to send a WiFi profile.... anony tried that with success ?

Last edited by nobody7290 : 11-10-2010 at 06:41 PM.
Offline  
Old 11-12-2010, 01:47 PM   #12 (permalink)
Talking BlackBerry Encyclopedia
 
Thiego-uk's Avatar
 
Join Date: Sep 2007
Model: SGS2
OS: 4.0.3
PIN: N/A
Carrier: T-Mobile UK
Posts: 308
Post Thanks: 15
Thanked 10 Times in 10 Posts
Default Re: 9700 + OS6.0.0.344 - NO BIS internet workaround

Looking for resolution for my BIS internet prob. You guys have any idea? Very same case but im on BIS. everything is working good but the brownser when not on wifi.
Thanks
Offline  
Old 11-13-2010, 05:15 PM   #13 (permalink)
New Member
 
Join Date: Nov 2010
Model: 9700
OS: 6.0.0.344
PIN: N/A
Carrier: M-tel
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: 9700 + OS6.0.0.344 - NO BIS internet workaround

Quote:
Originally Posted by Thiego-uk View Post
Looking for resolution for my BIS internet prob. You guys have any idea? Very same case but im on BIS. everything is working good but the brownser when not on wifi.
Thanks
Delete the "Blackberry internet browsing service 2" entry in the Service Book. Worked for me perfectly! You may need to do that every time the device is rebooted though.

Last edited by cybertron213 : 11-13-2010 at 07:11 PM.
Offline  
Old 11-14-2010, 04:44 PM   #14 (permalink)
Talking BlackBerry Encyclopedia
 
Thiego-uk's Avatar
 
Join Date: Sep 2007
Model: SGS2
OS: 4.0.3
PIN: N/A
Carrier: T-Mobile UK
Posts: 308
Post Thanks: 15
Thanked 10 Times in 10 Posts
Default

Quote:
Originally Posted by cybertron213 View Post
Delete the "Blackberry internet browsing service 2" entry in the Service Book. Worked for me perfectly! You may need to do that every time the device is rebooted though.
Hurray!!! It worked great! Many thanks.

Posted via BlackBerryForums.com Mobile
Offline  
Old 11-16-2010, 04:23 AM   #15 (permalink)
Talking BlackBerry Encyclopedia
 
Thiego-uk's Avatar
 
Join Date: Sep 2007
Model: SGS2
OS: 4.0.3
PIN: N/A
Carrier: T-Mobile UK
Posts: 308
Post Thanks: 15
Thanked 10 Times in 10 Posts
Default Re: 9700 + OS6.0.0.344 - NO BIS internet workaround

Quote:
Originally Posted by cybertron213 View Post
Delete the "Blackberry internet browsing service 2" entry in the Service Book. Worked for me perfectly! You may need to do that every time the device is rebooted though.
Hummm.... Something wierd happen and I just want to share it. After I deleted the "Blackberry internet browsing service 2" It was working sweet but I thought I should do a hard reset just to see what would happen. After the reset the internet conection on the browser through BIS stopped working as expected so I went back to the service books and for my surprise there was no "Blackberry internet browsing service 2" but 2 "Blackberry internet browsing service". :O
Not sure what to do I decided to delete one and see what would happen, as I did the browser still wouldnt connect through BIS so I decided deleting the other one left and get new Service Books to replace both. After I got the new service books I decided trying conecting browser through BIS again and guess what... Worked just perfect. Now I check on my service books and I have both "Blackberry internet browsing service" and "Blackberry internet browsing service 2" and its all working good even after many hard resets all works fine.

I hope it helps those with same or similar situation.
Offline  
Old 11-16-2010, 06:02 AM   #16 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: 9700 + OS6.0.0.344 - NO BIS internet workaround

about the same happend to me. Also, the Search function of my browser no works properly (I now can search again with google/wikipedia et. al).

This possibly means, my Carrier and your Carrier have upgraded the Service books to something compatible with OS6.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.