BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   Unable to access Intranet (http://www.blackberryforums.com/bes-admin-corner/240549-unable-access-intranet.html)

c_s_t 11-25-2010 04:09 AM

Unable to access Intranet
 
Hi,

We have configured our BES proxy mappings to default to a webmarshall proxy (using .*://.*(:\d*)?(/.*)*(\?.*)? as the URL). this is working fine and all internet traffic is going out to the internet via the webmarshall proxy.

I cannot however get any internal web address to work.

I have created a proxy mapping to "hxxp://intranet.*" and "hxxp://intranet/*" with a proxy string of DIRECT, stopped and restarted the MDS service multiple times and done a full reset of the blackberry multiple times. Both these rules are above the catch all which uses the proxy.

Attempting to browse to "hxxp://intranet" results in a 404 error from a site on the internet, it isn't trying to resolve the address internally.

Anyone any ideas ?

We are using BES 4.1.6 on a Bold 9700 device.

(xx's used due to forum rules)

Thanks

Jadey 11-25-2010 05:21 AM

Re: Unable to access Intranet
 
Have you tried an exception in the syntax as per post:
http://www.blackberryforums.com/bes-...tml#post305631

?

c_s_t 11-25-2010 07:12 AM

Re: Unable to access Intranet
 
Hi,

Thanks for the reply - We've tried a number of different masks including :

.*://.*intranet*(:d*)?(/.*)*(?.*)?
.*://.*intranet(:d*)?(/.*)*(?.*)?
.*://.*\.intranet.mycompany\.
.*://.*\.intranet.mycompany\.com.*

The last two from the thread you linked - nothing works and everthing is directed to the proxy.

Jadey 11-25-2010 08:24 AM

Re: Unable to access Intranet
 
The intranet strings were added as DIRECT, right?

c_s_t 11-25-2010 08:40 AM

Re: Unable to access Intranet
 
Quote:

Originally Posted by Jadey (Post 1677510)
The intranet strings were added as DIRECT, right?

Yep.

I've no clue why this isn't working, it appears to be completly ignoring anything in the proxy mappings.

I can't find anything on the blackberry itself which would show if these settings had been picked up (?), nor can I see anything of any use in the logs ( I have both HTTP logging and Verbose HTTP logging enabled ).

Cheers.

c_s_t 11-25-2010 08:50 AM

Re: Unable to access Intranet
 
May or may not be relevant, but our IE proxy settings on our standard desktops are exactly the same as the BES proxy setting.

Any local webserver, including the intranet, is listed in the "Exeptions" box of the IE Proxy Settings.

mponcin 03-01-2011 08:40 AM

Re: Unable to access Intranet
 
Hi,

I'm having a problem like this, I try to access to an internal SAP app by browser, just that the error that BB Browser shows me is 'Time out' after it asked to me the active directory credentials (since we have enabled Auth HTTP). We configured MDSLogin.config too but this did not solve it.

Its so strange because we acceded without problems with previous version we had, 4.1, and when we upgrade to 5.0.2 never more it was possible.
I have opened a case with RIM but they are not very helpful.

Someone has haved an issue like this ? Any help will be happily accepted :D

freakinvibe 03-01-2011 10:21 AM

Re: Unable to access Intranet
 
@mponcin Have you tried the solution below?

KB23933-After a BlackBerry Enterprise Server update, BlackBerry smartphone users are unable to browse to web sites

mponcin 03-03-2011 08:25 AM

Re: Unable to access Intranet
 
I had not found that article. I'll check that and reply to you !
Thanks a lot ! :)

mponcin 03-10-2011 01:18 PM

Re: Unable to access Intranet
 
freakinvibe, I'll build you a monument of wisdom :P

Your unique answer resolved a problem that thousands of RIM people's answers just couldn't

My biggest thankfulness to you !

freakinvibe 03-14-2011 03:37 AM

Re: Unable to access Intranet
 
You are welcome.

Too bad that RIM support couldn't point you to that KB. They should have done that. Let them know, so they can improve.


All times are GMT -5. The time now is 05:12 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.