BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-13-2010, 07:34 AM   #1 (permalink)
New Member
 
Join Date: Dec 2010
Model: 9700
PIN: N/A
Carrier: Proximus
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Angry Required application cannot be deleted after migration to other server

Please Login to Remove!

Hi,

We have a Express server (5.0.1) running, on which we have 25 users configured.
On the Express server, I created a Software Policy that pushed an application as being required for all users. This worked very well.

Now we installed a Full Enterprise server (5.0.2), including 25 CALs, on which the Software Policy has that same application set as Optional.

The problem is, when we migrate users with the Transporter tool, the application gets pushed from the Full Enterprise server, but gets in conflict with the application from the Express server.
We can delete the version from the Full Enterprise server, but anything we try to get rid of the Required application of the Express server fails.

Is there a way, except by issuing a full wipe, to remove that application?

If I check in the Modules under Applications, there is a difference in the application name:
Express name : eofficeMobileDataAlerter42
Full name: eofficeMobileDataAlerter47

Any tips are welcome.

As a method to prevent this issue from migrating other users (we just did 6 now), I've set the application as Optional on the Express server. Hopefully we can manually delete the application on the other 19 devices we still have to migrate.

Thanks,
Toni
Offline  
Old 12-14-2010, 06:40 AM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2008
Location: Buenos aires, Argentina
Model: 8520
PIN: N/A
Carrier: Claro
Posts: 75
Post Thanks: 0
Thanked 4 Times in 4 Posts
Default Re: Required application cannot be deleted after migration to other server

you can not delete it from de devices? or from the express server?
__________________
Martin

Blackberry Instructor
Offline  
Old 12-14-2010, 09:00 AM   #3 (permalink)
Talking BlackBerry Encyclopedia
 
RadHaz75's Avatar
 
Join Date: Feb 2006
Location: Philadelphia
Model: 9650
OS: 6.0.0.524
PIN: BALL
Carrier: Verizon Wireless
Posts: 456
Post Thanks: 2
Thanked 4 Times in 4 Posts
Default Re: Required application cannot be deleted after migration to other server

i have a ticket open with RIM right now for a similar issue. we have an app deployed as required. we are trying to deploy an updated version of the app to those users however it is failing. after opening the ticket, RIM said there is a known BUG in 5.0.2 for exchange (and possibly older versions and other platforms) that will cause this issue. even setting the old app to optional and then pushing the new one as required results in a failure (and no manual delete option on the device for the supposedly optional app).

the workaround provided is to set the old app to disallowed which will force the BES to yank it off the device. once confirmed the app is removed, then push the new app. the bug is supposed to be fixed in 5.0.2 MR3 and 5.0.3.
__________________
Two months ago, I saw a provocative movie on cable TV. It was called The Net, with that girl from the bus.
Offline  
Old 12-14-2010, 09:20 AM   #4 (permalink)
New Member
 
Join Date: Dec 2010
Model: 9700
PIN: N/A
Carrier: Proximus
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default [Solved] Re: Required application cannot be deleted after migration to other server

Hi RadHaz75,

Thanks for your info, setting the (correct version of) the app as disallowed did indeed remove it from the devices!

My life got a bit easier

Last edited by ToniVR : 12-14-2010 at 09:45 AM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: Required application cannot be deleted after migration to other server
Thread Thread Starter Forum Replies Last Post
How to run BES with both Exchange 2003 and Exchange 2007 RUBEN@DK BES Admin Corner 10 10-28-2009 09:17 AM
Enabling Application Server SSO (Single Sign on)on the BES MobileMind BES Admin Corner 4 09-16-2009 04:12 PM
Knowledge Sharing - Verify Hardware + System Requirement prior BES Domino 5.0 upgrade noname BES Admin Corner 1 05-26-2009 06:22 AM
Moving BlackBerry Enterprise Server for Exchange to a New Server garycutri BES Admin Corner 0 09-20-2008 11:57 AM
BES 4.0 SP1 for Exchange now available! jibi BES Admin Corner 20 05-04-2005 10:00 PM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.