BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-16-2011, 03:54 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2008
Model: 9630
PIN: N/A
Carrier: Verizon Wireless
Posts: 27
Post Thanks: 4
Thanked 0 Times in 0 Posts
Question Cannot add single user to successful BESx install

Please Login to Remove!

I have a weird issue provisioning a single user. We've had the BESx installed and running for many months and have 50+ users provisioned and their devices activated. Everything on that end is working A-OK.

But, for one particular user, I cannot provision her account! I'm using the web based "BlackBerry Administration Service" and have provisioned most of the 50+ users myself, with nary a problem until now.

Procedure:
1. "User" -> "Create a User"
2. (I can fill in all or part of her display name, or all or part of her email address)
3. "Search"
4. Error: "The BlackBerry Administration Service cannot find the records you were looking for. Verify the search criteria you specified and try again."

It doesn't matter what portion of her display name I use, or substring of her email address, it never finds her AD object. For example, say her name was "Susan B. Anthony" and her email address was "susan.anthony(at)domain(dot)org". I could do a partial list for "susan" and pull up every Susan in the directory, but not her. Or, I could search for "susan.a" in the email address field and pull up the list of ever user with that string in their email address - but not her!

I've confirmed that she is not hidden from the GAL, that she has a valid and non-corrupted Exchange mailbox, etc. I can find nothing wrong about her account, yet BES cannot seem to find the object!

Does anyone know what I'm missing, here? Or, where I should start looking for a problem? For example, what log file could I even check to see what's being queried of AD and what's being returned?

We have:
Exchange 2007 SP1
BES Express version 5.0.1 MR 3 (Bundle 139)

Thanks!
__________________
~runester~
Exchange/BES Admin
BB Tour (9630) via VZW
Offline  
Old 02-16-2011, 04:06 PM   #2 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,568
Post Thanks: 256
Thanked 261 Times in 247 Posts
Default Re: Cannot add single user to successful BESx install

check
KB19451-"No records were found that match the specified search criteria" appears in the BlackBerry Administration Service console during an attempt to create a BlackBerry enabled user account
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
The Following User Says Thank You to knottyrope For This Useful Post:
runester (02-18-2011)
Old 02-18-2011, 05:12 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2008
Model: 9630
PIN: N/A
Carrier: Verizon Wireless
Posts: 27
Post Thanks: 4
Thanked 0 Times in 0 Posts
Default Re: Cannot add single user to successful BESx install

First, thanks for the reference! It took me a couple of days to get the password for besadmin ... but I just checked and the values are in place. I'm basing the following on the KB article you linked to above, as well as this additional information.


Code:
HKCU\Software\Microsoft\Windows NT\CurrentVersion\
Windows Messaging Subsystem\Profiles\BlackBerryServer_MailStoreProfile\
dca740c8c042101ab4b908002b2fe182
    001e6602    REG_SZ    MyDC1.MyDomain.org

HKCU\Software\Microsoft\Windows NT\CurrentVersion\
Windows Messaging Subsystem\Profiles\BlackBerryServer\
dca740c8c042101ab4b908002b2fe182
    001e6602    REG_SZ    MyDC2.MyDomain.org
I do see the errors mentioned in the KB article, in our logs. But, again, I'd like to point out that we have 50+ provisioned users, which the BB WebAdmin site had no problem finding in our AD. Why would it be totally unable to find just one user out of thousands but have no problems with any of the others?

Note: the two values are different. We have four (4) different DC's and I noticed that one DC's FQDN was in one key and another DC's FQDN was in the other registry key. Not sure if this matters or needs to be changed for some reason.
__________________
~runester~
Exchange/BES Admin
BB Tour (9630) via VZW

Last edited by runester : 02-18-2011 at 05:13 PM.
Offline  
Old 02-19-2011, 10:40 PM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2011
Location: South Carolina
Model: 9330
PIN: N/A
Carrier: Verizon
Posts: 41
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default Re: Cannot add single user to successful BESx install

Was the user previously deleted out of the BES before?
Offline  
Old 02-19-2011, 10:41 PM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2011
Location: South Carolina
Model: 9330
PIN: N/A
Carrier: Verizon
Posts: 41
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default Re: Cannot add single user to successful BESx install

Have you tried KB17400?
Offline  
Old 02-21-2011, 04:09 PM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2008
Model: 9630
PIN: N/A
Carrier: Verizon Wireless
Posts: 27
Post Thanks: 4
Thanked 0 Times in 0 Posts
Default Re: Cannot add single user to successful BESx install

YES, I've refreshed the company directory. But, to be sure, I did it again today as per the KB article you reference.

I am wondering, what log can I check to see if the refresh worked or encountered an error? Which file or event should I be checking?
__________________
~runester~
Exchange/BES Admin
BB Tour (9630) via VZW
Offline  
Old 02-22-2011, 02:03 AM   #7 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: Cannot add single user to successful BESx install

KB19451 is a solution to the problem that you can't do a user lookup due to the DC entry missing in the MAPI Profile. But that means, it can't look up any user.

What you are saying is that you can create any user, except one. So I don't think KB19451 is the issue. It must be a specific problem with that user object in AD or Exchange.

Very dumb question: Are you sure the user is not already on the BES or any left-overs are in the DB or Exchange? Because if the user is already in BES, you will get no search result for it (in the User Creation page).

Also, have you tried to put the full email address of the user in the "Email address" field and leave the "Messaging server display name" field blank?

As a last resort, you can also try to switch user lookup from MAPI to LDAP, but that might have other side effects and needs some registry changes.

Last edited by freakinvibe : 02-22-2011 at 02:06 AM.
Offline  
Old 02-23-2011, 09:20 AM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2008
Model: 9630
PIN: N/A
Carrier: Verizon Wireless
Posts: 27
Post Thanks: 4
Thanked 0 Times in 0 Posts
Default Re: Cannot add single user to successful BESx install

OK, I've re-confirmed that she is not currently provisioned on our BESx and I've sent a request to our Windows System guys to check her AD object properties out and see if there is anything funny going on.

When I tried to perform an "Add User From Company Directory" and entered her PrimarySMTPAddress into the "EMail Address:" field, it failed and the following event was in the BESx_MAST_01_20110223_0001.TXT log file:

Code:
[10000] (02/23 09:55:36.002):{0x3980} AddAddressLookupEntry failed for SMTP Address - FirstName.LastName@MyDomain.org
I also see hundreds of these events in the same log ...
Code:
[10000] (02/23 10:17:06.106):{0x14F8} MailStoreExchange::RefreshGALUsingMAPI - Error in HrFindExchangeGlobalAddressList, result=0x80004005.
[20000] (02/23 10:17:06.107):{0x14F8} [ODBCRecord::DeleteRecord] No rows found to delete.  SQL = "DELETE FROM MsAddresses WHERE MailStoreDomainId = ? AND SequenceNumber > ?".
[20000] (02/23 10:17:06.107):{0x14F8} [ODBCRecord::DeleteRecord] DATA = "MailStoreDomainId[1] SequenceNumber[98] ".
Finally, I've just confirmed that we have Four (4) Domain Controllers and each one is also a Global Catalog Server. I note this, become the FQDN of one DC is in [HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\BlackBerryServer_MailStoreProfi le\dca740c8c042101ab4b908002b2fe182\001e6602] and the other is in [HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\BlackBerryServer\dca740c8c04210 1ab4b908002b2fe182\001e6602] ... is there any issue with this?
__________________
~runester~
Exchange/BES Admin
BB Tour (9630) via VZW
Offline  
Old 02-23-2011, 09:42 AM   #9 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: Cannot add single user to successful BESx install

The "BlackBerryServer_MailStoreProfile" is the profile that is responsible for the lookup of users in the "Create Users" area. Why not copy the DC name that you have in the other Profile to "BlackBerryServer_MailStoreProfile"

We also have 4 DCs and we have the same listed in both profiles.
Offline  
The Following User Says Thank You to freakinvibe For This Useful Post:
runester (02-28-2011)
Old 02-23-2011, 12:01 PM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2011
Location: South Carolina
Model: 9330
PIN: N/A
Carrier: Verizon
Posts: 41
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default Re: Cannot add single user to successful BESx install

KB19451-"No records were found that match the specified search criteria" appears in the BlackBerry Administration Service console during an attempt to create a BlackBerry enabled user account 0 1150413239
Offline  
Old 02-23-2011, 12:02 PM   #11 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2011
Location: South Carolina
Model: 9330
PIN: N/A
Carrier: Verizon
Posts: 41
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default Re: Cannot add single user to successful BESx install

The lines of code still point to that article. :(
Offline  
Old 02-23-2011, 12:03 PM   #12 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2011
Location: South Carolina
Model: 9330
PIN: N/A
Carrier: Verizon
Posts: 41
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default Re: Cannot add single user to successful BESx install

KB25476-Unable to add users from company directory 0 1150413239
Offline  
The Following User Says Thank You to timmyBES For This Useful Post:
runester (02-28-2011)
Old 02-24-2011, 11:28 AM   #13 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2008
Model: 9630
PIN: N/A
Carrier: Verizon Wireless
Posts: 27
Post Thanks: 4
Thanked 0 Times in 0 Posts
Default Re: Cannot add single user to successful BESx install

Quote:
Originally Posted by timmyBES View Post
I've gotten permission to restart the "BlackBerry Mail Store Service" tomorrow morning, and I'll see if that makes any change. I'm going to manually update the registry keys so that they both have the same value, while the service is down - just in case that matters.

If none of this works, my only other idea is to disable and recreate the users mailbox in Exchange and hope that the new mailbox with it's new GUID will be visible to BESx in AD. I'm beginning to get some concerned inquiries from the user since it's been nearly three (3) weeks. :(

[Part of the frustration is that I've provisioned about 20 other users since I ran into this problem with her account!]
__________________
~runester~
Exchange/BES Admin
BB Tour (9630) via VZW
Offline  
Old 02-25-2011, 02:02 AM   #14 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: Cannot add single user to successful BESx install

If all that doesn't help, have you tried to use the "User Administration Tool" from the BES resource kit? With this, you can add a user via command line.
Offline  
Old 02-28-2011, 11:49 AM   #15 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2008
Model: 9630
PIN: N/A
Carrier: Verizon Wireless
Posts: 27
Post Thanks: 4
Thanked 0 Times in 0 Posts
Smile Re: Cannot add single user to successful BESx install

SOMETHING WORKED!!!

Unfortunately, I don't know what. The restart of "BlackBerry Mail Store" service didn't seem to make any difference. But, I took a long weekend and when I got back today, I tried adding that one problem user account, again, and this time ti was found! I put in a query to our Active Directory guy to see if he did anything to the user object in AD ... but I would be surprised since he's so busy. In any case, for whatever reason, everything is working A-Ok.

Thank you, one and all, for your ideas and assistance with this issue.
__________________
~runester~
Exchange/BES Admin
BB Tour (9630) via VZW
Offline  
Old 02-28-2011, 01:03 PM   #16 (permalink)
New Member
 
Join Date: Feb 2011
Model: 9650
PIN: N/A
Carrier: VZW
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Cannot add single user to successful BESx install

Sometimes there can be delays when you add a user through Peoplesoft as an example and wait for them to effectively hit AD. They might show up in AD but you still cannot add them even though you think you should. I manage a BES of 1300+ users and see this frequently.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: Cannot add single user to successful BESx install
Thread Thread Starter Forum Replies Last Post
1 Blackberry user constantly stops syncing until BES Services restarted... Siberian BES Admin Corner 2 11-05-2009 09:45 AM
Activation problems.. pierre.ammoun BES Admin Corner 0 08-07-2009 11:58 PM
BES users are unable to send attachments Simplicity Trevor BES Admin Corner 0 04-29-2009 06:26 PM
Delete user from BES, then add new user with the same phone userbo1 BES Admin Corner 4 09-03-2008 05:37 AM
Having trouble synchronizing contacts between Pearl and Outlook dfarrales General 8100 Series Discussion - Pearl 7 04-09-2007 01:03 AM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.