BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-24-2011, 04:26 PM   #1 (permalink)
fgb
Knows Where the Search Button Is
 
Join Date: Feb 2011
Model: none
PIN: N/A
Carrier: none
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem loging in with besadmin

Please Login to Remove!

Hello,

I have been trying to have BES 5.0.2.28 functioning since 2 days now and I’m still having trouble to connect to the BlackBerry Administration Service as “besadmin”. I fact, I have never been able to do it. The only way I can connect to the BB Administration Service is as “admin”.

I have a Microsoft Exchange Server 2007 running on Windows Server 2008 Standard.

I am trying to have the BES working on a virtual machine also running on Windows Server 2008 R2 Entreprise. This VM is on the same domain than the Microsoft Exchange Server.

I have been following the official guide provided with BES, as well as the message posted on the forum, which explains how to have BES running on an Exchange 2007 environment.

What I also don’t understand is that when I am connected to BES as “admin”, I am trying to add a user that I just added before on Exchange, and which appears in AD (I also followed the Send-As procedure), I got an error message saying “The BlackBerry Administration Service cannot find the records you were looking for. Verify the search criteria you specified and try again.”

Am I missing something here?

Please excuse my English which is not perfect, I am working on it.
Offline  
Old 02-25-2011, 01:41 AM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: Problem loging in with besadmin

What error message do you get, when you try to login with BESAdmin? Which role does BESAdmin have (Manage Users > BESAdmin > Roles)?

Also, check the BBAS-AS log for errors.
Offline  
Old 02-25-2011, 08:15 AM   #3 (permalink)
fgb
Knows Where the Search Button Is
 
Join Date: Feb 2011
Model: none
PIN: N/A
Carrier: none
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Problem loging in with besadmin

The error message I am getting when trying to log as besadmin is “The user name or password is not correct. Please correct the entry”.

besadmin has the role of administrator on the machine where I installed BES. I also tried to reset the password for every service, on the “Log On” tab.

besadmin doesn't have any local windows account on the server Microsoft Exchange is installed.

I did not find any error in the BBAS-AS log.
Offline  
Old 02-25-2011, 09:30 AM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: Problem loging in with besadmin

If you login to the adminstration service, do you see the BESAdmin user under "Manage Users".
Offline  
Old 02-25-2011, 10:35 AM   #5 (permalink)
fgb
Knows Where the Search Button Is
 
Join Date: Feb 2011
Model: none
PIN: N/A
Carrier: none
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Problem loging in with besadmin

I logged in to the Blackberry Administration Service, went under User > Manage User.

The only "Display name" I have is "System Administrator".
If I search for the besadmin, it does not find him.
Offline  
Old 02-25-2011, 10:44 AM   #6 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default Re: Problem loging in with besadmin

Any reason why you would use sql auth over AD auth?
Offline  
Old 02-25-2011, 10:52 AM   #7 (permalink)
fgb
Knows Where the Search Button Is
 
Join Date: Feb 2011
Model: none
PIN: N/A
Carrier: none
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Problem loging in with besadmin

What do you mean?

I just have been able to connect as besadmin.
This is what I did:

I connected as "admin" to the Blackberry Administration Service.
I added the user "besadmin" with Administrator rights.

Then I tried to login with "besadmin" using AD, and it works...

Now I am really not sure to understand how the all thing works...

I thought that during the installation the parameters I entered would permit me to log directly as besadmin.
Offline  
Old 02-25-2011, 10:56 AM   #8 (permalink)
fgb
Knows Where the Search Button Is
 
Join Date: Feb 2011
Model: none
PIN: N/A
Carrier: none
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Problem loging in with besadmin

Being logged under "besadmin" does not change the other problem I had, which is that I am trying to add a user that I just added before on Exchange, and which appears in AD (I also followed the Send-As procedure), I got an error message saying "The BlackBerry Administration Service cannot find the records you were looking for. Verify the search criteria you specified and try again."
Offline  
Old 02-25-2011, 11:13 AM   #9 (permalink)
fgb
Knows Where the Search Button Is
 
Join Date: Feb 2011
Model: none
PIN: N/A
Carrier: none
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Problem loging in with besadmin

I also tried to manually Refresh the available user list from company directory, but I get the error "The user list from the company directory cannot be refreshed because a mailstore server is not running."
Offline  
Old 02-25-2011, 11:24 AM   #10 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: Problem loging in with besadmin

Check in the Windows services for

"Blackberry Mail Store Service"

It should be started. Also check your event logs to find out why it stopped.
Offline  
Old 02-25-2011, 11:35 AM   #11 (permalink)
fgb
Knows Where the Search Button Is
 
Join Date: Feb 2011
Model: none
PIN: N/A
Carrier: none
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Problem loging in with besadmin

Yes the "Blackberry Mail Store Service" is stopped. I checked before making my testing if every service was started and it was the case.
Looking at the Event Viewer I found at that there are a lot if Error Event 1000.

Here are some of them:
- MailStoreExchange::GetPublicFoldersList - Error in HrOpenExchangePublicStore, result=0x80004005.
- DefaultHandler - exception caught thread Id=0x14F8
- MailStoreExchange::Initialize - Failed in MAPILogonEx, profile='BlackBerryServer_MailStoreProfile', result=0x80040111.
- Failed to start the BESMailstore RPC Server thread
Offline  
Old 02-25-2011, 11:51 AM   #12 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: Problem loging in with besadmin

Read this KB article:

KB19451-"No records were found that match the specified search criteria" appears in the BlackBerry Administration Service console during an attempt to create a BlackBerry enabled user account
Offline  
Old 02-25-2011, 12:35 PM   #13 (permalink)
fgb
Knows Where the Search Button Is
 
Join Date: Feb 2011
Model: none
PIN: N/A
Carrier: none
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Problem loging in with besadmin

I will try that.

At one point, it is mentionned:

Verify that the correct global catalog server is listed in the string value 001e6602 for the dca740c8c042101ab4b908002b2fe182 key.

I do not have the string value 001e6602, I will create it but what should be the associated value ?
Offline  
Old 02-25-2011, 12:59 PM   #14 (permalink)
fgb
Knows Where the Search Button Is
 
Join Date: Feb 2011
Model: none
PIN: N/A
Carrier: none
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Problem loging in with besadmin

When trying to modify the value, I realized that I do not have the BlackBerryServer_MailStoreProfile entry.

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\BlackBerryServer_MailStoreProfi le\dca740c8c042101ab4b908002b2fe182

I do have the Profiles folder with 3 others folders, BlackBerryServer, BlackBerryServer_Agent1 and MS Exchange Settings.

However I do have the dca740c8c042101ab4b908002b2fe182 in each of these folders. And the "001e6602" key is here, with the correct value in only one folder, which is BlackBerryServer_Agent1.

I will create everything to see if it makes any change.

Last edited by fgb : 02-25-2011 at 01:03 PM.
Offline  
Old 02-25-2011, 01:33 PM   #15 (permalink)
fgb
Knows Where the Search Button Is
 
Join Date: Feb 2011
Model: none
PIN: N/A
Carrier: none
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Problem loging in with besadmin

OK I am now able to add a user that I just created under AD. Thank you so much for your help.

Additional question: To make some testing with a Blackberry device, like trying to assign the device to the user and forward the emails received by the user to the blackberry, is it required to have a carrier?
Offline  
Old 02-25-2011, 01:36 PM   #16 (permalink)
fgb
Knows Where the Search Button Is
 
Join Date: Feb 2011
Model: none
PIN: N/A
Carrier: none
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Problem loging in with besadmin

Just noticed that the state of besadmin and of the new user I just added is "Initializing".
I have read somewhere that it will be a problem when assigning a blackberry device to this user.

I also used the IEMSTest.exe program to check the besadmin account and the other I just added, but when it comes to type the login, domain and password, I got the message "The logon credentials supplied were incorrect. Make sure your username and domain are correct, then type your password again."

Last edited by fgb : 02-25-2011 at 02:06 PM.
Offline  
Old 02-25-2011, 02:19 PM   #17 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default Re: Problem loging in with besadmin

I don't understand why would you go throgh several days worth of troublshooting and fixing something that should work right outu of the box, if you had read and followed all installation guides steps and pre-requisites. Wouldn't it be easier to rebuid the whole thing again now then later? Why fight it? Next this time make sure you read everything carefully. I'd never leave BES setup like this on the network. You have unique chance right now to do configure and install it right. The more users you add harder it gets to repair, restart, etc. later.
The fact that you don't know what initilizing means in BES world means, tells me that you really need to learn basic stuff man.
Offline  
Old 02-25-2011, 02:54 PM   #18 (permalink)
fgb
Knows Where the Search Button Is
 
Join Date: Feb 2011
Model: none
PIN: N/A
Carrier: none
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Problem loging in with besadmin

I have read and followed all the prerequisites and pre-installation tasks before starting. But for I don't know what reason it appears that I got some problem like the String value missing on the registry which is permitting to connect to the Mail Store Service. Before making a thread on the forum I tried to solve the problems by myself and to check if I correctly did the pre-installation tasks.

I agree that I need to learn about BES, no need to be brutal. I was looking for help... not to be put down...
Offline  
Old 02-25-2011, 03:00 PM   #19 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default Re: Problem loging in with besadmin

Sorry man if i was brutal, really it wasn't my intention. Have a good weekend.
Offline  
Old 02-28-2011, 01:16 AM   #20 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: Problem loging in with besadmin

Quote:
Just noticed that the state of besadmin and of the new user I just added is "Initializing".
This is normal. The next step is to assign a one-time activation password to the user and then do the Enterprise Activation on his Blackberry. Once the Enterprise Activation has finished, the status of the user will change from "Initializing" to "Running".

Of course the SIM card you have in your Blackberry must be provisioned with the Blackberry data service. Ask your carrier to set this up for you.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: Problem loging in with besadmin
Thread Thread Starter Forum Replies Last Post
BESAdmin permissions SmoothRunnings BES Admin Corner 8 01-29-2009 04:18 AM
Can't add BESAdmin to users' AD Security Tab gkarasik BES Admin Corner 14 11-02-2008 08:20 PM
BB Alerts problem crucifixion Aftermarket Software 0 01-15-2008 01:57 PM
BES problem or Exchange 2000 problem? Smits General BlackBerry Discussion 5 08-12-2006 11:21 AM
Will BESAdmin = Administrator be a problem? KeithWeldon BES Admin Corner 19 07-27-2006 12:51 AM





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.