BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-09-2011, 06:36 PM   #1 (permalink)
New Member
 
barkusmasta's Avatar
 
Join Date: May 2011
Location: Central California
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 6
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default Newer BES with Older Exchange

Please Login to Remove!

I'm in the process of trying to get our servers all upgraded from the 2000 world. Our current BES is 4.1 running on Windows 2000 Server Standard with Exchange 2000 Standard.

I'm wanting to get our BES upgraded to 5 first and was told by RIM that we can definitely have 2 BES servers running on the same Exchange server but different physical hardware in order to move our handhelds over one-by-one. I started to install BES 5 on a Server 2008 R2 box I put up but had some questions.

When I'm installing BES 5 do I use the latest and greatest MAPI & CDO 1.2.1? I'm just uncertain of which version I should have installed on my new BES server because it's going to be pulling from my Exchange 2000 server so should I install the version of MAPI for my current Exchange version or install the latest?

RIM also assured me that when we do eventually upgrade our Exchange to 2010 that everything will go smoothly as long as we also migrate the Exchange account that our BES uses.

Because this whole server project is already under a tight budget plus, essentially, I am the IT staff around here, I'm trying to do as much of this on my own as I can. So, getting support directly from RIM is pretty much out of the question. I'm just trying to save us from having to soak up more project hours on the upgrade with our BES. Thanks in advance.
Offline  
Old 05-10-2011, 08:08 AM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
cyclmpc's Avatar
 
Join Date: Nov 2008
Location: DC
Model: 9800
OS: 6.0.0.141
PIN: N/A
Carrier: ATT
Posts: 217
Post Thanks: 2
Thanked 2 Times in 2 Posts
Default Re: Newer BES with Older Exchange

Take a look at the matrix.
BlackBerry - BlackBerry Enterprise Server Compatibility

This should help.
__________________
I'm actually lost...
Offline  
Old 05-10-2011, 11:20 AM   #3 (permalink)
New Member
 
barkusmasta's Avatar
 
Join Date: May 2011
Location: Central California
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 6
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default Re: Newer BES with Older Exchange

Thank you for the response. I previously read through the compatibility matrix but was wondering more specifically about using MAPI & CDO 1.2.1 on Exchange 2000.

I know that technically RIM said everything should work fine running the old version of BES and the new version of BES at the same time but the last thing I want to do is hose something up in my attempts at saving our company money. Thanks again.
Offline  
Old 05-11-2011, 09:17 AM   #4 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,565
Post Thanks: 256
Thanked 260 Times in 246 Posts
Default Re: Newer BES with Older Exchange

Latest version of CDO dont like 2000 that much.

How many users are we talking about?
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Online  
Old 05-11-2011, 10:28 AM   #5 (permalink)
New Member
 
barkusmasta's Avatar
 
Join Date: May 2011
Location: Central California
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 6
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default Re: Newer BES with Older Exchange

52 users total.
Offline  
Old 05-11-2011, 10:54 AM   #6 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,565
Post Thanks: 256
Thanked 260 Times in 246 Posts
Default Re: Newer BES with Older Exchange

BES 5.0 does support 2000, limited but can get you through the move.

I am not sure about CDO support for 2000, you might need an older version for it as 2000 support has been dropped for the most part.

sene me a PM if you need the older version of CDO
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Online  
Old 05-11-2011, 12:11 PM   #7 (permalink)
New Member
 
barkusmasta's Avatar
 
Join Date: May 2011
Location: Central California
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 6
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default Re: Newer BES with Older Exchange

Should I go that route (CDO) or simply install the Exchange 2000 Administrator utility on the new server?

Things were so much more cut and dry when I installed BES 4.x onto our current Exchange 2000 server because, as you've mentioned, support for Exchange 2000 was still present so there was no question.
Offline  
Old 05-11-2011, 12:49 PM   #8 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,565
Post Thanks: 256
Thanked 260 Times in 246 Posts
Default Re: Newer BES with Older Exchange

ESM is not supported on 2008 or any 64 bit server IIRC, CDO is needed.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Online  
The Following User Says Thank You to knottyrope For This Useful Post:
barkusmasta (05-11-2011)
Old 05-11-2011, 01:08 PM   #9 (permalink)
New Member
 
barkusmasta's Avatar
 
Join Date: May 2011
Location: Central California
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 6
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default Re: Newer BES with Older Exchange

10-4. Thank you for the information.
Offline  
Old 05-11-2011, 02:44 PM   #10 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,565
Post Thanks: 256
Thanked 260 Times in 246 Posts
Default Re: Newer BES with Older Exchange

your welcome, glad to have helped out.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Online  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: Newer BES with Older Exchange
Thread Thread Starter Forum Replies Last Post
On BES 4.1.7 & Exchange 2007 - moving to Exchange 2010 ?! dude -d BES Admin Corner 7 11-08-2010 11:51 AM
Changing Exchange servers Supanatral BES Admin Corner 5 12-27-2007 11:24 AM
Using BES with multiple exchange orgs joshv BES Admin Corner 4 07-13-2007 07:42 AM
Getting Exchange off my BES box TBone2k BES Admin Corner 4 12-20-2006 07:48 AM
Exchange patch breaks BES easy-v BES Admin Corner 0 01-20-2006 12:55 PM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.