BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-13-2011, 11:31 AM   #1 (permalink)
New Member
 
Join Date: May 2011
Model: 5.0.3
PIN: N/A
Carrier: Both
Posts: 7
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default Upgrading 4.1.7 to 5.0.3...have a DB concern

Please Login to Remove!

Hello all,

I been digging through searches for this, but couldn't really find an exact answer. I've been doing my research on this upgrade, have it planned out, and I have all of the documentation and tools I'll need. We only have 50 devices, but they all belong to execs who have been in a bit of a firing frenzy lately.

I'll be doing a parallel upgrade. Our servers are virtual so I'll be upgrading a copy of our original server's VM. The DB is on the server in an MSDE instance. So when I copied the server, the DB is now also on the copy. I know the upgrade process will install SQL2005 Express.

My concern is that when I finish the upgrade, the new server will try to immediately contact/take control of routing all of the devices in the DB. This is a concern because I want to be able to migrate a few users at a time, using the transporter, before fully migrating off the 4.1.7.

Should I, before the upgrade, delete the users on the copy? To make sure there is no potential confusion later on.

Or am I over-thinking this, and I'll just have to use the Transporter to effectively change the SRP configuration for the devices/profiles?
Offline  
Old 05-13-2011, 11:53 AM   #2 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,557
Post Thanks: 256
Thanked 260 Times in 246 Posts
Default Re: Upgrading 4.1.7 to 5.0.3...have a DB concern

Going to full Full BES or BES Express?

If using transporter, you need to setup a new server and move users over to new server.

Running any apps on old BES? MDS IS is not longer supported.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 05-13-2011, 12:01 PM   #3 (permalink)
New Member
 
Join Date: May 2011
Model: 5.0.3
PIN: N/A
Carrier: Both
Posts: 7
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: Upgrading 4.1.7 to 5.0.3...have a DB concern

Yea, sorry, full BES to full BES.

It will be a separate server.

And no, not running any apps. Just have BES and MSDE on that server.
Offline  
Old 05-13-2011, 12:18 PM   #4 (permalink)
Wireless Sith Lord
 
DarthBBerry's Avatar
 
Join Date: Jan 2007
Location: Online
Model: iOS 6
Carrier: Verizon x2
Posts: 1,458
Post Thanks: 2
Thanked 27 Times in 22 Posts
Default Re: Upgrading 4.1.7 to 5.0.3...have a DB concern

Create a new DB on the new BES with the 5.0 installer. Then use the Transporter/Migration kit to move your folks over.
No downtime.
__________________
DarthBBerry
6-Time BlackBerry World Champion (2007-2012)
BlackBerry® Certified Support Specialist v5.0
BlackBerry® Certified System Administrator v5.0
Offline  
The Following User Says Thank You to DarthBBerry For This Useful Post:
worldsworstadmin (05-16-2011)
Old 05-13-2011, 01:05 PM   #5 (permalink)
New Member
 
Join Date: May 2011
Model: 5.0.3
PIN: N/A
Carrier: Both
Posts: 7
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: Upgrading 4.1.7 to 5.0.3...have a DB concern

I know that it will ask to install SQL 2005 Express, I had planned on that. So the install won't migrate the data in the old DB (MSDE) into the new one? If that's the case, I can live with that.
Offline  
Old 05-16-2011, 03:17 AM   #6 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: Upgrading 4.1.7 to 5.0.3...have a DB concern

Quote:
I'll be upgrading a copy of our original server's VM
I would not do that.

Start with a fresh server and a fresh DB. Then use transporter.
Offline  
The Following User Says Thank You to freakinvibe For This Useful Post:
worldsworstadmin (05-16-2011)
Old 05-16-2011, 11:38 AM   #7 (permalink)
New Member
 
Join Date: May 2011
Model: 5.0.3
PIN: N/A
Carrier: Both
Posts: 7
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: Upgrading 4.1.7 to 5.0.3...have a DB concern

Well, that's actually looking like the better option now.

We recently had a failure on our current BES. One of our DCs went down, and it just so happens that it was the one that BES was associated to. Our other DCs picked up the loads, but the BES never contacted the others. Turns out the Catalog Referrals was never configured correctly. With RIM's support, we also noticed all kinds of other potential issues. So it's either hot-fix the hell out of the servers or just start fresh.

Now that I've been added as the main support contact on our contract (all other contacts are no longer here), I've been given access to our support dashboard. And with it, access to download the full BES 5.0.3 installation file. I previously could only get the upgrader file.

So yea, fresh install now...fun times ahead.
Offline  
Old 05-16-2011, 12:58 PM   #8 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default Re: Upgrading 4.1.7 to 5.0.3...have a DB concern

If you gonna use the same srp keep in mind that just one server can be up and connected to a rim's infrastructure at the time. If planning to move a couple of users at the time as you initially stated, to see if new bes works fine and then to move the rest of them,you'd need to stop services on old server first. This is the truth unless you got temp key from rim to perform migration. If you use bulk move using transporter tool then you should be ok.
Offline  
Old 05-16-2011, 01:29 PM   #9 (permalink)
New Member
 
Join Date: May 2011
Model: 5.0.3
PIN: N/A
Carrier: Both
Posts: 7
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default Re: Upgrading 4.1.7 to 5.0.3...have a DB concern

Yes, I already have the migration kit. New SRP ID and auth key.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: Upgrading 4.1.7 to 5.0.3...have a DB concern
Thread Thread Starter Forum Replies Last Post
Upgrading to 4.1.7 with SQL 2008 Shawnd BES Admin Corner 1 01-18-2010 03:58 PM
Local Database Connection Error ogaal BES Admin Corner 10 11-25-2009 01:05 AM
Trying to do a cutover, db issues sniffs BES Admin Corner 10 02-18-2009 01:46 PM
BES connect to SQL2005 DB problem bearman23 BES Admin Corner 0 09-07-2008 12:10 PM
BES upgrade to 4.1.6 Horsebox BES Admin Corner 3 08-05-2008 06:27 PM





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.