BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-15-2011, 03:35 AM   #1 (permalink)
New Member
 
Join Date: May 2011
Model: 8900
PIN: N/A
Carrier: Vodacom
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES not communicating with Exchange 2007 on setup

Please Login to Remove!

Hi there,

I am installing BES on a SBS 2008 server. DC, DHCP, Exchange etc all running on the same box.
I have created a besadmin account that I am able to locally log onto the box with as I am using this account to set up the BES server. All goes well until I get to the section where I have to select the Exchange server and mailbox for the MAPI section. Tells me that the Exchange server cannot be contacted to verify details. I have looked through the log files and the error seems to imply that the system cannot verify the username and password which is however correct as I am logged onto the server using that account. I am also able to access OWA using this besadmin account. Even when trying to enter my personal (full admin) details I get this same error.

I have downloaded and installed the suggested MAPI version and restarted the install process. Still no luck.

5.0.2 bundle 14 is the BES build running on SBS 2008.

I have installed BES before a year back and didn't have this problem. Not sure if this is a new build with changes.

Would appreciate any assistance.

Thanks.
Offline  
Old 05-15-2011, 07:10 AM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: BES not communicating with Exchange 2007 on setup

If you go to a workstation, and login there as besadmin and setup an outlook profile for the user. Does that work, and can you send and receive emails?
Offline  
Old 05-15-2011, 10:35 AM   #3 (permalink)
New Member
 
Join Date: May 2011
Model: 8900
PIN: N/A
Carrier: Vodacom
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES not communicating with Exchange 2007 on setup

This is for BES Express by the way.
I was being bit of a noob and only now realized that I didn't have SP2 installed for Exchange 2007. Installed this and got a bit further in the installation. I am now stuck where I am supposed to enter the Active Directory details for the user besadmin but these are not accepted. This is at the second last step, before the services are started up within the install.

Get a ADSettings failed to validate user creds - user[besadmin] domain[xxxxxxx.local] pwd[XXXXXXXX] - code[2] error in the log file.

The account details are correct as I log onto the server using besadmin to setup everything. I have again tried my personal admin account, also without any luck.

I cannot remember having any issues with the previous versions of BES Express and the log files don't exactly give you information to resolve a problem. Has anyone come across this issue?
Offline  
Old 05-15-2011, 10:39 AM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: BES not communicating with Exchange 2007 on setup

Still it would be a good idea to try out what happens on a workstation if you there setup outlook with mapi for the besadmin user.
If that fails you will know, if the problem is with the account or, if not that the problem is related to the setup on the server.
Offline  
Old 05-15-2011, 10:43 AM   #5 (permalink)
New Member
 
Join Date: May 2011
Model: 8900
PIN: N/A
Carrier: Vodacom
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES not communicating with Exchange 2007 on setup

I get your thinking behind that, but don't think it would make a difference trying this as I have tried my 'main' admin account and this also comes up with that error. This 'main' admin account has access to emails via Outlook on a workstation.

I read up that at this point one should enter the account details used to setup the SBS 2008 server. This is my account. No luck.

Last edited by nulltech : 05-15-2011 at 10:44 AM.
Offline  
Old 05-15-2011, 10:50 AM   #6 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: BES not communicating with Exchange 2007 on setup

This test is only a few minutes of time, and, you will know that mapi for the besadmin should work.
Other things to check:
does dcdiag complete without errors ?

download
MFCMAPI - Download: March 2011 Release
and try to use this to check why mapi is not working ok.
Offline  
Old 05-15-2011, 04:36 PM   #7 (permalink)
New Member
 
Join Date: May 2011
Model: 8900
PIN: N/A
Carrier: Vodacom
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES not communicating with Exchange 2007 on setup

I definitely seems to be a LDAP issue on the SBS 2008 server as I get unable to bind to LDAP errors. This would be the reason to why accounts cannot authenticate. Trying to resolve this issue now, but a novice on the messaging side of things. Will post my findings once I work this out
Offline  
Old 05-15-2011, 06:49 PM   #8 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,366
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: BES not communicating with Exchange 2007 on setup

What is the status of the Windows Firewall ? Set to off for testing purposes.

here:
How to install BlackBerry Enterprise Server Express on a SBS 2008

is a walkthrough of BES installation on SBS 2008, maybe, check that again with your installation.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: BES not communicating with Exchange 2007 on setup
Thread Thread Starter Forum Replies Last Post
BES 5.0 stopped working after latest update (Exchange 2007 environment) jaelae BES Admin Corner 2 01-14-2010 10:19 AM
Exchange 2007, BES, Server 2008 and Server 2003 R2 wangel88 BES Admin Corner 9 04-07-2009 05:12 PM
BENCHMARK your BlackBerry speed! Add your results here! Mark Rejhon General BlackBerry Discussion 271 03-12-2007 10:51 PM
Exchange patch breaks BES easy-v BES Admin Corner 0 01-20-2006 01:55 PM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.