BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-20-2011, 09:05 AM   #1 (permalink)
New Member
 
Join Date: Sep 2009
Model: 9000
PIN: N/A
Carrier: Orange UK
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Error 413 but not on all handsets

Please Login to Remove!

Hello,

We are experancing a very strange issue with some of our handsets when users try to access an internal SAP website.

The website is a fairly basic site with a banner and some basic text.

I am able to access the site fine on a 8310, 9700, 9800 but not able to do it from a 9105 or a 9300

At first I though it was a config error but have been through the devices and checked that they were all set to the same;

Browser set to BlackBerry Browser
Support JavaScript - enabled
Allow JavaScript pop-ups - disabled
Terminate slow-running scripts - enabeld
show images - enabled
use background images - enabled
support embedded media - enabled
Browser identification - Internet Explorer

So I am wondering if it is someting to do with the devieces physical screen size and resoultion as the ones that work has a higher quality of screen?

Any ideas?

Cheers,

Graham
Offline  
Old 06-21-2011, 02:26 AM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: Error 413 but not on all handsets

The error is:

HTTP 413 Request Entity too Large

I would check in the Web Server logs if you can find more details on when this error happens. Also make sure that on the faulty devices you are on the latest OS (and with that, on the latest browser).
Offline  
Old 06-22-2011, 03:42 AM   #3 (permalink)
New Member
 
Join Date: Sep 2009
Model: 9000
PIN: N/A
Carrier: Orange UK
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Error 413 but not on all handsets

Hello freakinvibe,

Many thanks for your reply.

I have asked the SAP guys to have a look and see if ther are any logs on the SAP server. They have also asked if the BES might have any logs?

My first point of call was to flash the OS to the latest availabule through BBF but that didnt make any difference.

What do you mean by Latest Browser? is that a seperate installation to the OS upgarde?

Will see if there is any info back from the SAP guys.

Any other thoughs?
Offline  
Old 06-22-2011, 04:12 AM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: Error 413 but not on all handsets

Quote:
They have also asked if the BES might have any logs?
Sure, have a look at the MDAT logs in the log directory.
Quote:
is that a seperate installation to the OS upgarde?
No, that is included in the OS upgrade. There is no separate browser update.
Offline  
Old 07-06-2011, 05:19 PM   #5 (permalink)
New Member
 
Join Date: Aug 2010
Location: Los Angeles
Model: 9850
PIN: N/A
Carrier: Sprint
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Error 413 but not on all handsets

this sounds familiar

check your "Flow control" under the MDSCS instances general tab
Maximum data amount permitted per connection (KB)

the entity to large i think has to do with the size of the HTML file
(i could be wrong but last year i had to fix this on the server i took over and i think that was the message i was recieving on the BB's.
i believe the max setting is 1024kb
Offline  
Old 07-08-2011, 02:31 AM   #6 (permalink)
New Member
 
Join Date: Sep 2009
Model: 9000
PIN: N/A
Carrier: Orange UK
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Error 413 but not on all handsets

Hello freakinvibe and skeptik,

many thanks for the help you gave me.

The SAP team fixed the issue by re-engineering the website to be as basic as possibule and this has corrected the issue.

However i have also chagned the flowcontrol so might help in the future.

Cheers,
Offline  
Old 07-08-2011, 05:42 PM   #7 (permalink)
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Post Thanks: 6
Thanked 9 Times in 9 Posts
Default Re: Error 413 but not on all handsets

Hey grahambird80, rework on SAP side is a workaround. The fix to your issue is to increase the BES MDS-CS Maximum KB/Connection field value. Check out KB17318 below.

Link: KB17318-"HTTP error 413 request entity too large" appears when the BlackBerry Browser is used to browse to a web page
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: Error 413 but not on all handsets
Thread Thread Starter Forum Replies Last Post
Wireless Synch switched off on handsets jameskemp BES Admin Corner 2 07-16-2010 08:08 AM
Some handsets stopped working after moving mailboxes ncomper BES Admin Corner 4 05-06-2010 08:33 PM
UK BES - US Handsets maxster BES Admin Corner 8 06-01-2009 11:58 PM
using the Z9 with blackberry handsets dennis8320 Bluetooth Connection 0 04-12-2008 07:35 PM
HELP me please users can not delete on Handsets, ianamac BES Admin Corner 6 10-29-2007 11:31 AM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.