BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-23-2011, 05:50 AM   #1 (permalink)
New Member
 
Join Date: Oct 2005
Location: UK
Model: 8300
Carrier: O2
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES installation stuck at Start Services

Please Login to Remove!

Any help on this problem would be much appreciated. We are trying to upgrade to BES 5.0.3, however it looks like a previous service pack or even the original installation did not complete.

When I try and re-run the 5.0.1 setup it continues from the Blackberry CAL and SRP information section. All verification works ok, and I can continue through the steps until I get to the Start Services section. Clicking Start Services or Next here results in the installation hanging.

Last few lines of the install log read:-

[30000] (06/23 10:50:29.877):{0x710} <5>Jun 23 10:50:29 cmbcbes1 {0x220C} 0527: (#30000) [PIPTOOL]: FQDNFromMachineName found FQDN of [ removed ] for [ removed ]
[30000] (06/23 10:50:29.877):{0x710} <5>Jun 23 10:50:29 cmbcbes1 {0x220C} 0528: (#30000) [PIPTOOL]: StartService forms BMS URL of removed
[30000] (06/23 10:50:29.877):{0x710} <5>Jun 23 10:50:29 cmbcbes1 {0x220C} 0529: (#30000) [PIPTOOL]: StartService is finished forming URLs.
[30000] (06/23 10:50:45.439):{0x220C} RunWebGenKey: Attempting to generate the web.keystore file.
[30000] (06/23 10:50:45.439):{0x220C} RunWebGenKey: GenerateBMSUKeyStore commandline: ["C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\Monitoring Service\bin\webGenKey.bat" C:\PROGRA~2\Java\jdk1.6.0_15 C:\PROGRA~2\RESEAR~1\BLACKB~1\Monitoring Service\ besbms CMBCBES1.CMBC.INTERNAL]
[30000] (06/23 10:50:45.486):{0x710} <5>Jun 23 10:50:45 cmbcbes1 {0x220C} 0530: (#30000) [PIPTOOL]: Start Service executes common functions
[30000] (06/23 10:50:45.486):{0x710} <5>Jun 23 10:50:45 cmbcbes1 {0x220C} 0531: (#30000) UnzipWarFiles: Detected C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BAS\server\default\deploy\basClientWebAdmin Console.war is an existing folder. Skipping the uncompress.
[30000] (06/23 10:50:45.486):{0x710} <5>Jun 23 10:50:45 cmbcbes1 {0x220C} 0532: (#30000) UnzipWarFiles: Detected C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BAS\server\default\deploy\basclientwebdeskt op.war is an existing folder. Skipping the uncompress.

All Blackberry services are already started apart from the 4 Blackberry Monitoring services.

It's worth noting that the BES server has been, and still is, working ok for push email to our users. Unless I can find a workaround to this problem I'm considering a fresh rebuild and reinstall of BES, restoring the database. Downtime can be arranged for a short time for this work.

Hope somebody can offer some advice.
Offline  
Old 06-23-2011, 05:52 AM   #2 (permalink)
New Member
 
Join Date: Oct 2005
Location: UK
Model: 8300
Carrier: O2
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES installation stuck at Start Services

Please note, the FQDN and URL were intentionally removed from the log extract. This was just to try and allow the thread to post.
Offline  
Old 06-27-2011, 05:06 AM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: BES installation stuck at Start Services

You don't need to click "Start Services" at installation time. Let the installation complete and then start the services manually.

If you have trouble with the monitoring service, uninstall it from the boxes and use a separate box for it (with no other BES services on it).
Offline  
Old 06-27-2011, 09:10 AM   #4 (permalink)
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Post Thanks: 6
Thanked 9 Times in 9 Posts
Default Re: BES installation stuck at Start Services

Quote:
Originally Posted by freakinvibe View Post
You don't need to click "Start Services" at installation time. Let the installation complete and then start the services manually.

If you have trouble with the monitoring service, uninstall it from the boxes and use a separate box for it (with no other BES services on it).
This is a NO NO. The "Start Services" include calls to several procedures that may update the database. It is recommended to click that button to complete the installation.

You should not be installing Monitoring with the BES core components. You would want it to be another standalone computer to watch over your BES servers.
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Old 06-27-2011, 09:18 AM   #5 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: BES installation stuck at Start Services

Quote:
This is a NO NO. The "Start Services" include calls to several procedures that may update the database. It is recommended to click that button to complete the installation.
Do you have an official source for this? When we upgrade to a newer SP + MR, we never start the services after the SP, but do the SP + MR in one go. Never had a problem with this. When you do a reboot after the install, the services get started anyway.
Offline  
Old 06-27-2011, 09:27 AM   #6 (permalink)
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Post Thanks: 6
Thanked 9 Times in 9 Posts
Default Re: BES installation stuck at Start Services

No official documentation but from mere observation.

Search the below in the BTSC and you will know what I meant - BlackBerry Technical Solution Center

"Start Services" button
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Old 06-28-2011, 03:41 AM   #7 (permalink)
New Member
 
Join Date: Oct 2005
Location: UK
Model: 8300
Carrier: O2
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES installation stuck at Start Services

Thanks for the help. Whether I click "Start Services or "Next" the installation still hangs at this point.
I can't see a way to back out to the point where I can choose not to install Monitoring. When resuming the install it always starts at the same point and I can't go back to previous option screens.
I guess it's looking like a reinstall and restore.
Offline  
Old 06-28-2011, 05:39 AM   #8 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: BES installation stuck at Start Services

Have you tried a repair from Control Panel yet?
Offline  
Old 06-29-2011, 05:06 AM   #9 (permalink)
New Member
 
Join Date: Oct 2005
Location: UK
Model: 8300
Carrier: O2
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES installation stuck at Start Services

No repair option, just remove.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: BES installation stuck at Start Services
Thread Thread Starter Forum Replies Last Post
Moving BlackBerry Enterprise Server for Exchange to a New Server garycutri BES Admin Corner 0 09-20-2008 11:57 AM
Most bizarre BES problem I have ever had Jadey BES Admin Corner 24 08-14-2008 03:45 PM
The Saga of getting a BES data plan in the UK nm1213 General BlackBerry Discussion 3 09-03-2006 05:36 PM
BES 4.01 migration to new server, do these steps look okay? mcast12 BES Admin Corner 0 08-22-2006 11:22 AM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.