BlackBerry Forums Support Community

BlackBerry Forums Support Community (
-   BES Admin Corner (
-   -   BES 5.0.3 and Exchange 2010 - headaches (

DeanAzzu 09-06-2011 04:25 AM

BES 5.0.3 and Exchange 2010 - headaches
Hi everyone,

Really hoping someone can help with the problems I'm facing please. I'll give you a run down of my environment, then explain the problems:

Exchange - host name for this example EMAIL10
Windows Server 2008 R2 SP1 Enterprise
MS Exchange 2010 SP1 Roll-up 5.
BESAdmin account set up on Exchange 2010 and able to send/receive via outlook/web access.
Part of the view only admins
Receive as applied to this account via power shell
Send as applied to descendent user objects from domain level in AD
BES Policy throttling policy set up and assigned to this account. All relevant sesson limits set to null
BESAdmin EWS assigned to user with impersonation rights

Blackberry Server - hostname for this example BES5
OS is Windows Server 2008 R2 Standard SP1 running from Hyper-V virtual machine
BES 5.0.3
BESAdmin has local admin rights on this box, as well as log on locally and log on as a service
MAPI and CDO 1.2.1 6.5.8211.0 installed on BES server

SQL is on SQL Server 2005 SP3 in the same site as Exchange and BES
BESAdmin account has been created as a login on SQL server using windows authentication
Roles for this account are: dbcreator, sysadmin and public
User mapping is to the BESMgmt database


First off, when installing the BES, everything runs fine, up to the point of inputting the MAPI credentials. Now using the dummy hostnames I've written above, I enter the exchange server name of EMAIL10 and enter BESAdmin as the service account. I click check and the system hangs, before finally saying:

The setup application could not find a mailbox that is named BESAdmin

If I then click back on the installation and then click nest to get back to the MAPI details screen, the details are still there and hitting 'check' again resolves the email server and the admin account email address.

Also, on this screen, if I enter the name of one of our domain controllers and the BESAdmin account, it find the information instantly.

So I continue the install after it finds the information and the set up finishes.

I log in to the BAS using the BESAdmin AD credentials and all looks good.

I try to activate a user and this is where things get weird.

After three re-installs of the BES server, I get mixed results.

It could possible activate the user, pulling down all old email in the mailbox and then problems happen after X amount of hours
It could activate the user not pulling any information through (emails) and then problems start again later
Or on the last re-install of the BES, the user didn't activate as the messaging agent had shut down

OK - so on my first install, still with the initial MAPI check problem above, then checking for a second time, the install finished, I added an exchange 2010 user and they activated fine. Their email was pulled through and they could send and receive. Problems then started after two or three hours. Will explain problems shortly.

On the second re-install of BES, the user then activated, but no old email was pulled through.

On the thirs re-install of BES - the user didn't activate.

On all three instances, I see the same errors either instantly, or later down the line. These errors are:

Windows Event Viewer:
MailboxManager::SubsystemInitialize - Exception handledxxx65279; - Event ID 20139
BlackBerry Messaging Agent BES1 Agent 1 failed to start. Error code 0xxx65279; - Event ID 10277
Waiting for external UDP log messages on port 4085xxx65279; - Event ID 50049
'BES1' agent 1: will not restart - reached the maximum of 10 restarts per 24 hours, next restart on xxx65279;- Event ID 20406

BES Server Logs:
Starting Message System
[30055] (09/05 15:59:59.218):{0xACC} Using MAPI profile BlackBerryServer
[20139] (09/05 15:59:59.218):{0xACC} MailboxManager::SubsystemInitialize - Exception handled
[30000] (09/05 15:59:59.218):{0xACC} [ENV] MAPI32.DLL: C:\Windows\system32\MAPI32.dll, Version: 1.0.2536.0[30000] (09/05 15:59:59.234):{0xACC} [ENV] CDO.DLL: C:\Program Files (x86)\ExchangeMapi\cdo.dll, Version: 6.5.8211.0
[30000] (09/05 15:59:59.234):{0xACC} [ENV] Microsoft Management Console (MMC): C:\Windows\system32\mmc.exe, Version: 6.1.7600.16385
[30000] (09/05 15:59:59.234):{0xACC} [ENV] Failed to read 001e6602 reg value from the BlackBerry MAPI profile.[30000] (09/05 15:59:59.234):{0xACC} [ENV] BlackBerry Mailbox Agent 1 - BESX Version
[30000] (09/05 15:59:59.234):{0xACC} [ENV] BES Service Name: BlackBerry Mailbox Agent
[30000] (09/05 15:59:59.234):{0xACC} [ENV] BlackBerry Dispatcher: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BlackBerryDispatcher.exe, Version:
[30000] (09/05 15:59:59.234):{0xACC} [ENV] BlackBerry User Administration Service: NOT FOUND
[30000] (09/05 15:59:59.234):{0xACC} [ENV] BlackBerry MDS Connection Service: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\MDS\bin\bmds.exe, Version:
[30000] (09/05 15:59:59.234):{0xACC} [ENV] BlackBerry Database Consistency Service: NOT FOUND
[30000] (09/05 15:59:59.234):{0xACC} [ENV] BlackBerry Policy Service: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BlackBerryPolicyServer.exe, Version:
[30000] (09/05 15:59:59.234):{0xACC} [ENV] BlackBerry Synchronization Service: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\SyncServer\BlackBerrySyncServer.exe, Version:
[30000] (09/05 15:59:59.234):{0xACC} [ENV] BlackBerry Router: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BypassRouter\BlackberryRouter.exe, Version:
[30000] (09/05 15:59:59.234):{0xACC} [ENV] BlackBerry Controller: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BlackBerryController.exe, Version:
[30000] (09/05 15:59:59.234):{0xACC} [ENV] BlackBerry Alert: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BESAlert.exe, Version:
[30000] (09/05 15:59:59.234):{0xACC} [ENV] BlackBerry Attachment Service is installed remotely on
[35015] (09/05 15:59:59.234):{0xACC} [ENV] Total number of requests for connections: 20
[35014] (09/05 15:59:59.234):{0xACC} [ENV] Number of waits for connections since service was started: 0
[35019] (09/05 15:59:59.234):{0xACC} [ENV] [DB] Database Schema Version: 5.0.3 <5.0.2011.02.11>
[30000] (09/05 15:59:59.249):{0xACC} [ENV] [DB] Connection String = Server=we-sql;Database=BESMgmt;Network=dbmssocn;Trusted_Conn ection=Yes
[30000] (09/05 15:59:59.249):{0xACC} [ENV] [DB] DBMS Name = Microsoft SQL Server; DBMS Version = 09.00.4035; Provider Name = sqlncli.dll; Provider Friendly Name = Microsoft SQL Native Client; OLE DB Version = 02.80; Provider Version = 9.00.3042.00; Failover Partner =
[30480] (09/05 15:59:59.249):{0xACC} [CFG] BES failover mode is ACTIVE
[41120] (09/05 15:59:59.249):{0xACC} [CFG] Address Lookup is enabled
[41122] (09/05 15:59:59.249):{0xACC} [CFG] LDAP search is disabled, LDAP PIM search is disabled, LDAP ALP search is disabled
[41123] (09/05 15:59:59.249):{0xACC} [CFG] Using up to 10 external CDO Helpers in keep-alive mode
[41124] (09/05 15:59:59.249):{0xACC} [CFG] AddOwnerApptID is disabled
[41125] (09/05 15:59:59.249):{0xACC} [CFG] SetLocaleIDs is disabled
[30302] (09/05 15:59:59.249):{0xACC} [CFG] OTAFM hard-delete server support is disabled, rescans are 0x00
[40532] (09/05 15:59:59.249):{0xACC} [CFG] vCard conversion support has been enabled
[40892] (09/05 15:59:59.249):{0xACC} [CFG] GlobalRescan config: messaging:O, calendar:O, pim:O
[41126] (09/05 15:59:59.249):{0xACC} [CFG] EnableExceptionStackTrace is disabled
[40000] (09/05 15:59:59.249):{0xACC} [CFG] MAPI Encoding is 1
[10277] (09/05 15:59:59.249):{0xACC} BlackBerry Messaging Agent BES1 Agent 1 failed to start. Error code 0[50106] (09/05 15:59:59.249):{0xACC} Stopping BlackBerry Mailbox Agent 1 for Server BES1
[30000] (09/05 15:59:59.249):{0xC24} [DIAG] EVENT=Register_thread, THREADID=0xC24, THREADNAME="TimerThread"
[40000] (09/05 15:59:59.249):{0xC24} [DEBUG] EVENTMSG="TimerThread thread started"
[40507] (09/05 16:00:00.062):{0x1BF4} ExtUDPLogThread: Code on closing = 0
[30000] (09/05 16:00:00.062):{0x1BF4} [DIAG] EVENT=Unregister_thread, THREADID=0x1BF4, THREADNAME="ExtUDPLogThread"
[30065] (09/05 16:00:00.062):{0xACC} BlackBerry Mailbox Agent 1 for Server BES1 shutdown completexxx65279;

As you can see, I have the old 'Failed to read 001e6602 reg valuefrom the Blackberry MAPI profile' error messages. Looking on-line, the solution for others has been to input this kep in the Messaging Subsystem Profiles folder, pointing in to your GC.

I have tried this and rebooted the BES and it doesn't seem to work at all for me.

I have spent four days looking in to this and just cannot get it working properly.

Any help would be massively appreciated please.

Thanks in advance,

Sorry guys - just to add:

When I open the Blackberry Server Configuration tool, then try to edit the MAPI profile, it says:

There is no email program associated to perform the requested action. Please install an email program or, if one is already installed, create and association in the Default Programs control panel.

Clicking OK to this message then gives the MAPIInitialize (80004005) error.
Clicking OK to this message then gives the 'The MAPI subsystem cannot be correctly initialized and used. Please make sure the MAPI is installed and configured properly' error.

I have tried numerous times to delete the HKCU\Software\Microsoft\Windows NT\CurrentVersion\WinodwsMessagingSubsystem\ profiles folder and then edit the MAPI in BB Server COnfig and the same error applies. If I completely remove the MAPI and CDO 1.2.1 and delete the Profiles key from earlier, I can re-crate the MAPI profile, but then the same problems occur from above. It drops out again.

fadmin 09-06-2011 06:59 AM

Re: BES 5.0.3 and Exchange 2010 - headaches
See this first:

I'd also try disabling IPv6 from BES LAN adapter if not already (KB05094-BlackBerry Enterprise Server support for IPv6 ) :

DeanAzzu 09-06-2011 07:19 AM

Re: BES 5.0.3 and Exchange 2010 - headaches
Hi Fadmin,

Thanks for the response. The first post, regarding TDI stuff, I've tried to download the hotfix on the BES server itself, but it only gives out Vista patches and when I run it, its not compatible.

For IPv6 - I have disabled this on the NIC on the BES server already.

Many Thanks,

fadmin 09-06-2011 07:38 AM

Re: BES 5.0.3 and Exchange 2010 - headaches
And this is full BES 5.0.3 and not express,right? Any weird firewall or antivirus on the network? Static IP I assume?
Try this as well:

DeanAzzu 09-06-2011 08:35 AM

Re: BES 5.0.3 and Exchange 2010 - headaches
Hi Fadmin,

That's correct. Full BES and main network firewall is configured for 3101 bi-directional, as we have old BES 4.1 servers running against other exchange 2003 and 2007 boxes. Also, disabled the firewall on the server itself to see if that helped, but no change.

AV is controller via a server and as I say, we have old BES boxes running with same AV on.

It has a static IP and all subnet mask, gateway and DNS information is correct.

I've used the MAPI link you sent me before, but again, doesn't make a difference.

Also, I've just re-installed the whole thing again and activated my exchange 2010 test user, who has emails in outlook from yesterday. Activation completes fine and I can send/receive new mail, but the old mail isn't loaded on to the device. I have previously set the pre-population message count to 750 and 14 days.

By the way, when I say I can send an receive mail at the moment, I fully expect the mapi settings to drop out again at some stage, so although it initially works, give it a while and it will be useless again with the errors previously mentioned in opening post.

Many Thanks,

fadmin 09-06-2011 09:04 AM

Re: BES 5.0.3 and Exchange 2010 - headaches
Is Besadmin acct/mailbox the same as the one used in 4.1? If so, is besadmin mailbox residing on exchange 2010?

DeanAzzu 09-06-2011 10:15 AM

Re: BES 5.0.3 and Exchange 2010 - headaches
Hi mate,

No, a completely new account has been set up for BES5 and Exchange 2010, residing on Exchange 2010 server.

Many Thanks,

nobody7290 09-07-2011 03:54 AM

Re: BES 5.0.3 and Exchange 2010 - headaches
How did you setup the virtual server where the BES is running ?
Is this a clone/copy of an already existent machine, or did you nake a setup from scratch?
If you copied a VM, and then reused it for the BES, better install a new server.
Posted via Mobile

DeanAzzu 09-07-2011 05:04 AM

Re: BES 5.0.3 and Exchange 2010 - headaches
Hi Nobody7290,

The virtual machines was a completely new VM, new Server 2008 R2 OS and new BES install.

Since then, I have set up and installed a new physical server running server 2008 R2 and installed the BES.

Again, I see the setup MAPI profile not being able to find my BESAdmin account, although, entering the domain controller/global catalog server name finds this.

After the install, I start an activation of a new device/new user.

The activation hangs at contacting server and then the menu comes up saying, continue activation or cancel activation. Hitting continue activation then gets it going again.

Unfortunately, although I can then send/receive mail, no old email, when I say old, I mean emails from yesterday, are sunchronised to the device.

Also, I fully expect the MAPI service to drop out again.

This is running BES 5.0.3 with MR4.

Really beginning to frustrate me now this is - never had so many problems with BES before. If only BES 4.1 worked with Exchange 2010.

Talking on Exchange, would there be anything here that could cause this? I have the BESPolicy throttling policy assigned to the BESAdmin account and all values set to null, but is there a way to check this is being used, rather than the default throttling policy with certain values still set?

Can anyone think of anything else exchange wise that might cause this?

I'm going to re-install the BES5 software, this time, fully pointing to our exchange 2007 box and see what happens. That way, it should pretty much confirm it's exchange 2010.

Many Thanks,

nobody7290 09-07-2011 09:27 AM

Re: BES 5.0.3 and Exchange 2010 - headaches
that was only a guess, which i did because from the log file you posted, it seemed that the server did not find itself or services which are installed on it.
Even, if this is not the case, that this is because of a clone of a VM, have had a look in to the system or the security log ? Are ther any kerberos related errors in it ?
Posted via Mobile

JackiBlackberry 09-16-2011 07:45 AM

Re: BES 5.0.3 and Exchange 2010 - headaches
I just spoke to Rim yesterday and they gave me a registry key to change in Exchange 2010. We have 3 servers and are only experiencing issues on one... so how could it be exchange? Didn't edit the registry yet but if you are interested, i will let you know how it works out.

nobody7290 09-16-2011 08:05 AM

Re: BES 5.0.3 and Exchange 2010 - headaches
Yes, please explain what the Rim support told you.

This is always interesting.

freakinvibe 09-16-2011 10:42 AM

Re: BES 5.0.3 and Exchange 2010 - headaches
I guess all your AD DCs are Win2008 R2? If so, you might encounter problems with MAPI connections. Read:

KB17325-Issues with the BlackBerry Enterprise Server when using a Windows Server 2008 Global Catalog Server - NSPI Bind Limit exceeded

All times are GMT -5. The time now is 05:07 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.