BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   BES Express 5.0.2 -> 5.0.3 upgrade fails MAPI Error (http://www.blackberryforums.com/bes-admin-corner/253159-bes-express-5-0-2-5-0-3-upgrade-fails-mapi-error.html)

thomasr 09-07-2011 12:37 PM

BES Express 5.0.2 -> 5.0.3 upgrade fails MAPI Error
 
I just upgraded my perfectly working BESX 5.0.2(over a year) to 5.0.3 (Bundle 12) & the last part of the setup fails. It populates server name & mailbox automatically after pressing 'check name', then after 'next' I get: 'Setup could not initialize MS MAPI client...' as seen here exactly: KB25752

I then uninstalled MAPI/CDIO as prescribed here: KB15779-How to install or upgrade the Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1 However I could not fo the 'Recreate the MAPI Profile' because when I try to open BlackBerry Server Configuration it says it can't open it until setup finishes, which makes sense as it's stuck in the middle of setting it up BESX 5.0.3 upgrade.

Exhange Server 2007, Windows Server 2003 x64.

I thought it would be a good idea to upgrade since I have a 9930 coming tomorrow to replace my 9650. Now I wish I would have never touched the server. :oops:



Please help me Knottyrope. Thanks.

nobody7290 09-09-2011 04:03 AM

Re: BES Express 5.0.2 -> 5.0.3 upgrade fails MAPI Error
 
Have you tried to restart the installation now, after reinstalling mapi, using 5.0.3 or the 5.0.2 installer ?

Also, unless you accidentally delete the database of the BES, it should be safe to remove the BES software, then again install it from scratch, using the existent database.

maybe, before doing this, make a copy of the mssql database to a safe location.
Posted via BlackBerryForums.com Mobile

thomasr 09-13-2011 05:43 PM

Re: BES Express 5.0.2 -> 5.0.3 upgrade fails MAPI Error
 
I resolved it. BESAdmin was hidden from the GAL.

nobody7290 09-14-2011 06:22 AM

Re: BES Express 5.0.2 -> 5.0.3 upgrade fails MAPI Error
 
good to know !


All times are GMT -5. The time now is 08:00 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.