BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-12-2012, 06:08 PM   #1 (permalink)
New Member
 
Join Date: Feb 2012
Model: 9700
PIN: N/A
Carrier: AT&T
Posts: 14
Post Thanks: 4
Thanked 0 Times in 0 Posts
Default OpenMsgStore Failed - all of a sudden!

Please Login to Remove!

Hello everyone,

A few weeks back, I got a new BESEX server up and running, along-side our existing old BES server (which we are working on eliminating). Things have been going smoothly, we've been migrating users over using the transport tool and haven't had any problems (about 40 users done so far).

Now all of a sudden, we are unable to activate new users on the new server, and are getting errors in the event logs for the last batch of users that was transported: Event ID 20400 with OpenMsgStore (0x8004011d) failed followed by a 20154 User Not Started.

IEMSTest gives the same results. I found this thread:
<snipped first part of URL, since I can't post a link-- it is on these forums>250217-help-openmsgstore-failed-8004011d.html
Which was about the same issue, and the resolution was to recreate the MAPI profile being used.

I did that, and immediately after doing that an IEMSTest goes through just fine. Ten minutes later, I am getting the same errors, and IEMSTest on the same user that just passed now fails again with OpenMsgStore.

Any thoughts on where I should be looking into this? I am combing through logs, but an not yet an experienced BES Admin, so I am hoping someone can point me in the right direction!
Offline  
Old 03-12-2012, 06:09 PM   #2 (permalink)
New Member
 
Join Date: Feb 2012
Model: 9700
PIN: N/A
Carrier: AT&T
Posts: 14
Post Thanks: 4
Thanked 0 Times in 0 Posts
Default Re: OpenMsgStore Failed - all of a sudden!

Also, I am not receiving this error message for all users-- just the ones moved with the Transporter tool in the past day, or those that were activated directly on the new BESEX today.
Offline  
Old 03-13-2012, 03:58 AM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: OpenMsgStore Failed - all of a sudden!

What is your server OS version of the new Blackberry server? AD version? The number of concurrent MAPI calls is limited on newer OS versions (Windows 2008 +)
Offline  
The Following User Says Thank You to freakinvibe For This Useful Post:
SullyBES (03-14-2012)
Old 03-13-2012, 10:16 AM   #4 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,647
Post Thanks: 264
Thanked 271 Times in 257 Posts
Default Re: OpenMsgStore Failed - all of a sudden!

possible your DNS server hit its connection limits as well.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 03-13-2012, 12:02 PM   #5 (permalink)
New Member
 
Join Date: Feb 2012
Model: 9700
PIN: N/A
Carrier: AT&T
Posts: 14
Post Thanks: 4
Thanked 0 Times in 0 Posts
Default Re: OpenMsgStore Failed - all of a sudden!

New Bes Express server is on Windows 2008 R2. We are currently in the transition from Exchange 2010 SP 1 from Exchange 2003. The besadmin account is on the new exchange 2010 server, most of the users are still on exchange 2003. It definitely seems like it is a "too many connections" issue of some sort. I have verified the throttling policy is set correctly with all of the right attributes being unlimited. If I stop all of the BES Services and run IEMSTest, The mailbox opens successfully (don't receive the OpenMsgStore Failed)

Here are the IEMSTest results:

First, when BES Services are Running:
Code:
Test User: Opening message store using
        /o=Corp1/ou=First Administrative Group/cn=Recipients/cn=test.user
        /o=Corp1/ou=First Administrative Group/cn=Configuration/cn=Servers/cn=FN-EX1/cn=Microsoft Private MDB
Test User: OpenMsgStore failed (8004011d)
Test User: CDO Server Name: FN-EX1
Test User: CDO Mailbox DN: /o=Corp1/ou=First Administrative Group/cn=Recipients/cn=test.user
Test User: CDO logon successful
Test User: CDO COM exception: Code = 80040705, WCode = 0505, Code meaning = IDispatch error #1285
    Description = The attempt to log on to the Microsoft Exchange Server computer has failed. [Microsoft Exchange Server
 Information Store - [MAPI_E_FAILONEPROVIDER(8004011D)]].
Test User: CDO test failed
Test User: Active Directory permissions test completed successfully
Test User: Initializing EWS Proxy... successful
Test User: Configuring User... failed

And here when BES Services are not Running
Code:
Test User: Opening message store using
        /o=Corp1/ou=First Administrative Group/cn=Recipients/cn=test.user
        /o=Corp1/ou=First Administrative Group/cn=Configuration/cn=Servers/cn=FN-EX1/cn=Microsoft Private MDB
Test User: Mailbox opened successfully
Test User: Root Folder opened successfully
Test User: Folder created successfully
Test User: Test folder deleted successfully
Test User: MAPI test completed successfully
Test User: CDO Server Name: FN-EX1
Test User: CDO Mailbox DN: /o=Corp1/ou=First Administrative Group/cn=Recipients/cn=test.user
Test User: CDO logon successful
Test User: CDO COM exception: Code = 80040705, WCode = 0505, Code meaning = IDispatch error #1285
    Description = The attempt to log on to the Microsoft Exchange Server computer has failed. [Microsoft Exchange Server
 Information Store - [MAPI_E_FAILONEPROVIDER(8004011D)]].
Test User: CDO test failed
Test User: Active Directory permissions test completed successfully
Test User: Initializing EWS Proxy... successful
Test User: Configuring User... failed
Looking into that CDO COM exception now
Offline  
Old 03-13-2012, 01:00 PM   #6 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,647
Post Thanks: 264
Thanked 271 Times in 257 Posts
Default Re: OpenMsgStore Failed - all of a sudden!

What version is the CDO.DLL file on BES?

dont tell me 1.2.1, we need the verison in properties when you right click it
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 03-13-2012, 01:05 PM   #7 (permalink)
New Member
 
Join Date: Feb 2012
Model: 9700
PIN: N/A
Carrier: AT&T
Posts: 14
Post Thanks: 4
Thanked 0 Times in 0 Posts
Default Re: OpenMsgStore Failed - all of a sudden!

File Version 6.5.8244.0 for CDO.DLL

I found this in the MAGT log for all of the effected users:
MAPI call failed. Error 'The information store could not be opened.', LowLevelError 0, Component 'MAPI 1.0', Context 649

Searching on that leads me to more posts that seem to indicate it is still a throttling policy error. I recreated the throttling policy, assigned it to the bes user, and rebooted both my exchange 2010 MB and CAS servers, followed by a reboot of my BES Express server. Same result.
Offline  
Old 03-13-2012, 01:13 PM   #8 (permalink)
New Member
 
Join Date: Feb 2012
Model: 9700
PIN: N/A
Carrier: AT&T
Posts: 14
Post Thanks: 4
Thanked 0 Times in 0 Posts
Default Re: OpenMsgStore Failed - all of a sudden!

Okay I think we are getting somewhere now-- On the exchange 2003 machine, I found an event log error indicating the following:
Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Event ID: 9646
Date: 3/13/2012
Time: 10:44:25 AM
User: N/A
Computer: FN-EX1
Description:
Mapi session "/o=Corp1/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=BES Admin0ab" exceeded the maximum of 32 objects of type "session".


I'm not sure why that was never a problem before with our old BES server (does BES Express do something differently in terms of MAPI sessions, or perhaps it is related to the BES Admin account being moved to exchange 2010?). Anyways, there is a registry setting that I can set to increase the number of MAPI sessions on exchange 2003, but it requires restarting the IS, which I cannot do until tonight. I will test that out and report back.
Offline  
Old 03-13-2012, 01:22 PM   #9 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,647
Post Thanks: 264
Thanked 271 Times in 257 Posts
Default Re: OpenMsgStore Failed - all of a sudden!

using 2008 Global catalogs?
KB17325-Issues with the BlackBerry Enterprise Server when using a Windows Server 2008 Global Catalog Server - NSPI Bind Limit exceeded
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
The Following User Says Thank You to knottyrope For This Useful Post:
SullyBES (03-14-2012)
Old 03-14-2012, 12:37 PM   #10 (permalink)
New Member
 
Join Date: Feb 2012
Model: 9700
PIN: N/A
Carrier: AT&T
Posts: 14
Post Thanks: 4
Thanked 0 Times in 0 Posts
Default Re: OpenMsgStore Failed - all of a sudden!

Changing the registry setting for Max number of allowed sessions on the exchange 2003 machine, and then restarting the information store seems to have resolved my problem.

Thanks for that link Knotty-- that didn't seem to be the particular error I am having this time, but as I move more users over it may be something I have to look into as well.

Here is a link to the specific KB article from Microsoft, and registry edit, that fixed this for me:

Okay, I still can't post links. KB Article 842022
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: OpenMsgStore Failed - all of a sudden!
Thread Thread Starter Forum Replies Last Post
Help: OpenMsgStore failed (8004011d) BRSMITH BES Admin Corner 8 06-17-2011 02:24 AM
Error Accessing DB after 5.0.2 Upgrade loweredxtreme BES Admin Corner 5 01-10-2011 02:32 PM
[SYNC-DSession] Failed (error=5411) to decode UPDATE record knottyrope BES Admin Corner 6 01-07-2011 09:42 AM
IEMSTest asks for login info (OpenMsgStore() for this profile failed (8004011d)) kenss BES Admin Corner 6 03-17-2010 01:35 AM
How do I find carrier assigned network IP address? QueBall General BlackBerry Discussion 22 05-27-2008 12:10 PM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.