BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-25-2012, 12:50 PM   #1 (permalink)
New Member
 
Join Date: Apr 2012
Model: 9650
PIN: N/A
Carrier: Sprint
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Unable to install MR7 (or reinstall current MR)

Please Login to Remove!

Hey all - I'd really appreciate any input someone could give me into this problem (my RIM support contract lapsed and it doesn't appear as if 'the man' is willing to pay for it)

Background: Running BES 5.0 SP3 MR4 and trying to install MR7 on the server. This morning I had to move the database from one 2008 x64 SQL server to another and it went ok, except the part where you have to run Setup.exe to point BES at the new DB server (gets Error initializing system). KB23428 says to delete database reg key in HKLM\SOFTWARE\Wow6432Node\Research In Motion\BlackBerry Enterprise Server, and still got the same error. So, in the end, I just changed the name of the server in the registry, rebooted, BES is working with no issues right now.

The installer log for MR7 looks like this (I've censored the log with 'domain' 'domaincontroller' 'SiteName' etc, but you get the idea):

[30000] (04/25 09:55:22.662):{0xF14} Found AMD 64 bit processor.
[30000] (04/25 09:55:22.662):{0xF14} [SystemData]: Begin InitActiveDirectoryInfo.
[30000] (04/25 09:55:22.662):{0xF14} attempting GetDCInfoEx for server/domain [/]
[30000] (04/25 09:55:22.677):{0xF14} GetDCInfoEx successfully determined values [Name[server.domain.com] Addr[172.X.X.X] Domain[server.com] Forest[domain.com] Site[SiteName] SB[DC=domain,DC=com] PDC=1 GC=1 IsValid=1 NatRetCode=0 LDAPRetCode=0 ET=0 ] for server/domain [/]
[30000] (04/25 09:55:22.677):{0xF14} [SystemData]: Found a local DC at [172.X.X.X].
[30000] (04/25 09:55:22.677):{0xF14} [SystemData]: Querying GC's by forest/site [domain.com/SiteName] for local GC discovery
[10000] (04/25 09:55:22.693):{0xF14} PerformDNSQuery succeeded for query [_gc._tcp.SiteName._sites.domain.com/SRV]
[10000] (04/25 09:55:22.693):{0xF14} PerformDNSQuery found 4 SRV record(s) for query [domain.com/SRV]
[10000] (04/25 09:55:22.693):{0xF14} PerformDNSQuery found 8 total record(s) for query [domain.com/SRV]
[30000] (04/25 09:55:22.693):{0xF14} BindToAnADDomain succesfully bound the user [] on the ADsPath [LDAP://DomainController.domain.com/rootDSE] using [ADsGetObject]
[30000] (04/25 09:55:22.693):{0xF14} ValidateGC2 returning accepts domains - GC[domaincontroller.domain.com], GCdomain[domain.com], supplied dom []
[30000] (04/25 09:55:22.693):{0xF14} ValidateGC2 returning true - serv [domaincontroller.domain.com], supplied dom []
[30000] (04/25 09:55:22.693):{0xF14} [SystemData]: Found a local GC at [domaincontroller.domain.com].
[30000] (04/25 09:55:22.693):{0xF14} attempting GetDCInfoEx for server/domain [domaincontroller.domain.com/]
[30000] (04/25 09:55:22.724):{0xF14} GetDCInfoEx successfully determined values [Name[domaincontroller.domain.com] Addr[172.X.X.X] Domain[domain.com] Forest[domain.com] Site[SiteName] SB[DC=domain,DC=com] PDC=0 GC=1 IsValid=1 NatRetCode=0 LDAPRetCode=0 ET=0 ] for server/domain [domaincontroller.domain.com/]
[30000] (04/25 09:55:22.724):{0xF14} attempting GetDCInfoEx for server/domain [/DOMAIN]
[30000] (04/25 09:55:22.724):{0xF14} GetDCInfoEx successfully determined values [Name[pdc.domain.com] Addr[172.X.X.X] Domain[domain.com] Forest[domain.com] Site[SiteName] SB[DC=domain,DC=com] PDC=1 GC=1 IsValid=1 NatRetCode=0 LDAPRetCode=0 ET=0 ] for server/domain [/DOMAIN]
[30000] (04/25 09:55:22.724):{0xF14} [SystemData]: Found a user domain DC at [172.X.X.X].
[30000] (04/25 09:55:22.724):{0xF14} [SystemData]: Querying GC's by forest/domain/site [domain.com/domain.com/SiteName] for user GC discovery
[10000] (04/25 09:55:22.724):{0xF14} PerformDNSQuery succeeded for query [_gc._tcp.SiteName._sites.domain.com/SRV]
[10000] (04/25 09:55:22.724):{0xF14} PerformDNSQuery found 4 SRV record(s) for query [domain.com/SRV]
[10000] (04/25 09:55:22.724):{0xF14} PerformDNSQuery found 8 total record(s) for query [domain.com/SRV]
[30000] (04/25 09:55:22.740):{0xF14} BindToAnADDomain succesfully bound the user [] on the ADsPath [LDAP://domaincontroller2.domain.com/rootDSE] using [ADsGetObject]
[30000] (04/25 09:55:22.740):{0xF14} ValidateGC2 returning accepts domains - GC[domaincontroller2.domain.com], GCdomain[domain.com], supplied dom [domain.com]
[30000] (04/25 09:55:22.740):{0xF14} ValidateGC2 returning true - serv [domaincontroller2.domain.com], supplied dom [domain.com]
[30000] (04/25 09:55:22.740):{0xF14} [SystemData]: Found a total of [1] eligible servers during user GC discovery
[30000] (04/25 09:55:22.740):{0xF14} [SystemData]: Found a user domain GC at [domaincontroller2.domain.com].
[30000] (04/25 09:55:22.740):{0xF14} attempting GetDCInfoEx for server/domain [domaincontroller2.domain.com/]
[30000] (04/25 09:55:22.756):{0xF14} GetDCInfoEx successfully determined values [Name[domaincontroller2.domain.com] Addr[172.X.X.X] Domain[domain.com] Forest[domain.com] Site[SiteName] SB[DC=domain,DC=com] PDC=0 GC=1 IsValid=1 NatRetCode=0 LDAPRetCode=0 ET=0 ] for server/domain [domaincontroller2.domain.com/]
[30000] (04/25 09:55:22.756):{0xF14} [SystemData]: Finish InitActiveDirectoryInfo. GC validity is [1]
[10000] (04/25 09:55:22.756):{0xF14} [CSystemDataCon::ValidatePassword]: Failed to logon with given credentials.
[10000] (04/25 09:55:22.756):{0xF14} [CCryptoDataCon::InitCEDllPath]: CE not found

[30000] (04/25 09:55:23.240):{0xF14} Setting value to uninitialized data container [CBESDBComp].
[45060] (04/25 09:55:23.240):{0xF14}
[45060] (04/25 09:55:23.240):{0xF14}
[45060] (04/25 09:55:23.240):{0xF14}
[30000] (04/25 09:55:25.037):{0xF14} ADO ConnectionTimeout value = 30s
[30000] (04/25 09:55:25.037):{0xF14} ADO ConnectionTimeout for re-initalizing the pool = 45s
[25137] (04/25 09:55:25.052):{0xF14}
[25000] (04/25 09:55:25.052):{0xF14} IDS_25000 ConnectionItem::ConnectToDB: COM Error 0x80040E4D - IDispatch error #3149 - Source: Microsoft OLE DB Provider for SQL Server - Description Login failed for user 'BESsa'. - Command: ConnectionItem::ConnectToDB
[10000] (04/25 09:55:25.052):{0xF14} [CDBComp::ConnectToHost]: User authentication failed.
[30000] (04/25 09:55:25.052):{0xF14} Step GatherInfo failed
[10000] (04/25 09:55:25.052):{0xF14} [CDataStore::GatherProdInfo]: Failure in ProdDataCon


I originally was doing this with Windows Authentication, and after several failed attempts, I created a SQL account (BESsa) with Creator and Owner roles and used that, but same exact error.

Can't find anything really related to this - ideas would be much appreciated!!
Offline  
Old 04-25-2012, 01:04 PM   #2 (permalink)
New Member
 
Join Date: Apr 2012
Model: 9650
PIN: N/A
Carrier: Sprint
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Unable to install MR7 (or reinstall current MR)

Actually I realized when I used Windows Authentication, the error was slightly different

[40000] (04/25 09:19:27.650):{0x1108} {DbConfig::setConfigValues} No Encoded SQL Auth keys found
[40000] (04/25 09:19:27.650):{0x1108} {DbConfig::setConfigValues} No SQL Auth keys found
[30000] (04/25 09:19:28.853):{0x1108} ADO ConnectionTimeout value = 30s
[30000] (04/25 09:19:28.853):{0x1108} ADO ConnectionTimeout for re-initalizing the pool = 45s
[25137] (04/25 09:19:28.869):{0x1108}
[25000] (04/25 09:19:28.869):{0x1108} IDS_25000 ConnectionItem::ConnectToDB: COM Error 0x80004005 - Unspecified error - Source: Microsoft SQL Server Native Client 10.0 - Description Cannot open database "BESMgmt" requested by the login. The login failed. - Command: ConnectionItem::ConnectToDB
[10000] (04/25 09:19:28.869):{0x1108} [CDBComp::ConnectToHost]: Cannot connect to DB as it does not exist.
[30000] (04/25 09:19:28.869):{0x1108} Step GatherInfo failed
[10000] (04/25 09:19:28.869):{0x1108} [CDataStore::GatherProdInfo]: Failure in ProdDataCon
Offline  
Old 04-25-2012, 02:56 PM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,362
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: Unable to install MR7 (or reinstall current MR)

Also check the HKCU\Software\Research in Motion\Database\DatabaseServerMachineName

for the "besadmin" user.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: Unable to install MR7 (or reinstall current MR)
Thread Thread Starter Forum Replies Last Post
Unable to connect using the current security settings platodw General 8300 Series Discussion - Curve 1 06-04-2008 11:59 PM
Help Please With Error 1607 Unable To Install Installshield Scripting Runtim msportia Aftermarket Software 0 03-02-2006 02:41 AM
Unable to install any 3rd party software AsstInterests General BlackBerry Discussion 6 02-09-2006 07:03 PM
Unable to Install BES doders BES Admin Corner 12 11-17-2005 04:11 PM
Unable to install BlackBerry JDE all versions yousaf931 Developer Forum 0 03-08-2005 02:19 AM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.