BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-16-2012, 07:16 AM   #1 (permalink)
New Member
 
Join Date: Aug 2012
Model: 8310
PIN: N/A
Carrier: T-Mobile Poland
Posts: 9
Post Thanks: 5
Thanked 0 Times in 0 Posts
Default Blackberry Manager 4.1 doesn't allow for any settings

Please Login to Remove!

Hi,
I'm new to all the Blackberry stuff. My Company is running BES 4.1.5 (I know, it's old) and recently we had a security audit of the server. The Aditor pointed out that we have default Administrator name on the server (it is Windows Small Business Server 2003 - old) and so we switched changed the name. Now when I start Blackberry Manager i don't have any options to add users, right-clicking on users doesn't bring up the menu. The connectivity to database is working. In the BM I can see it reads the DB correctly as I can see the messages were delivered to devices.

My first step was to get back to Administrator username, but that didn't fix anything.

Did anyone here have similar problems, can You help me somehow?
Offline  
Old 08-16-2012, 09:45 AM   #2 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,701
Post Thanks: 270
Thanked 286 Times in 270 Posts
Default Re: Blackberry Manager 4.1 doesn't allow for any settings

what are your services for BES running as?

Did you change all the BES services log on as?

Did you recreate the MAPI profile?
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
The Following User Says Thank You to knottyrope For This Useful Post:
JaspErekpl (08-22-2012)
Old 08-17-2012, 03:05 AM   #3 (permalink)
New Member
 
Join Date: Aug 2012
Model: 8310
PIN: N/A
Carrier: T-Mobile Poland
Posts: 9
Post Thanks: 5
Thanked 0 Times in 0 Posts
Default Re: Blackberry Manager 4.1 doesn't allow for any settings

Quote:
Originally Posted by knottyrope View Post
what are your services for BES running as?
All the services for BES run as BESAdmin who is an administrator on the domain.

Quote:
Originally Posted by knottyrope View Post
Did you change all the BES services log on as?
Should I in my situation?

Quote:
Originally Posted by knottyrope View Post
Did you recreate the MAPI profile?
Yes, I did it as the first thing after I realised there's problem.
I Also restarted the services, restarted the server.

In logs I see only these 3 lines as problematic, but I couldn't get any information about the source and solution:
Code:
...
[40000] (08/17 09:43:49.511):{0x277C} [DIAG] EVENT=Syslog_disconnected, ERROR=10049, EVENTMSG="Connect failed to 0.0.0.0"
...
[30000] (08/17 09:43:52.355):{0x384} Access BBMgrAppResources using  rim_db_admin_security
[10000] (08/17 09:43:54.339):{0x384} Failed to load credential cache for accessing MDSS web services.
...
. See attached is the MNGR log (logging level is raised to 4, can it be higher?):

Code:
[30000] (08/17 09:43:49.433):{0x277C} Current Date: 2012/08/17
[30000] (08/17 09:43:49.433):{0x277C} [DIAG] EVENT=Thread_report, THREADID=0x277C, THREADNAME="DebugLogger"
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Current Process: C:\Program Files\Research In Motion\BlackBerry Enterprise Server\BBMgr\Server\bbmgrw32.exe
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Current Process logged on as: CONXXXX\[UNIQUE-ADMIN-USER], Start Time: Aug 17 2012 09:43:49, Uptime (seconds): 0
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Current Process id: 5420
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Computer Host Name: CONXXXX1, OS Version: 5.2, Build number 3790, ServicePack Major 2, ServicePack Minor 0
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Processor Identifier: x86 Family 15 Model 4 Stepping 1
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Processor Vendor Identifier: GenuineIntel
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Processor Name String: Intel(R) Xeon(TM) CPU 3.00GHz
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Number of Processors: 2
[30000] (08/17 09:43:49.433):{0x277C} [ENV] 84 percent of memory in use.
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Total size of physical memory: 4193360 KB
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Size of physical memory available: 633476 KB
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Size of the committed memory limit: 6117476 KB
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Size of available memory to commit: 3001492 KB
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Total size of the user mode portion of the virtual address space of the BES process: 2097024 KB
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Size of unreserved and uncommitted memory in the user mode portion of the virtual address space of the BES process: 2031976 KB
[30000] (08/17 09:43:49.433):{0x277C} [ENV] Total HD bytes: 31461695488, Total free bytes = 5356675072
[30000] (08/17 09:43:49.464):{0x277C} [ENV] System up time: 2 days 21 hrs 51 mins 31 secs
[30000] (08/17 09:43:49.464):{0x277C} [ENV] Local Time Zone: Central Europe Daylight Time (GMT+01:00)
[30000] (08/17 09:43:49.464):{0x277C} [ENV] TCP/IP provider (Winsock) File Version: 5.2.3790.0 (C:\WINDOWS\System32\wsock32.dll)
[30000] (08/17 09:43:49.480):{0x277C} [ENV] Local machine IP Address = 192.168.XXX.XXX
[30000] (08/17 09:43:49.480):{0x277C} [ENV] Local machine IP Address = 192.168.XXX.XXX
[30000] (08/17 09:43:49.480):{0x277C} [ENV] Winsock2 file: Network Location Awareness (NLA) Namespace, Version: 5.2.3790.4318 (C:\WINDOWS\System32\mswsock.dll)
[30000] (08/17 09:43:49.480):{0x277C} [ENV] Microsoft XML Parser 6.0: C:\WINDOWS\system32\msxml6.dll, Version: 6.20.2012.0
[30000] (08/17 09:43:49.480):{0x277C} [ENV] MDAC version: 2.82.3959.0
[30000] (08/17 09:43:49.480):{0x277C} [ENV] MSADO15.DLL: C:\Program Files\Common Files\System\ado\msado15.dll, Version: 2.82.5011.0
[30000] (08/17 09:43:49.495):{0x277C} [ENV] Running Process: System
[ ... REMOVED LONG LIST OF PROCESSES ...]
[30000] (08/17 09:43:49.511):{0x277C} [ENV] Running Process: bbmgrw32.exe
[40000] (08/17 09:43:49.511):{0x277C} [DIAG] EVENT=Syslog_disconnected, ERROR=10049, EVENTMSG="Connect failed to 0.0.0.0"
[30000] (08/17 09:43:49.526):{0x384} BlackBerry Manager Version 4.1.5.26 starting...
[40000] (08/17 09:43:49.589):{0x384} [ExchangeAdaptorDLL::GetProfileName] Using MAPI profile 'BlackBerryManager'.
[40000] (08/17 09:43:49.589):{0x384} Mailstore Type is 1 (Exchange).
[30000] (08/17 09:43:49.589):{0x384} Mailstore Connector initialized.
[40000] (08/17 09:43:51.589):{0x384} ConnectionPool: Created pool of 2 connections
[30000] (08/17 09:43:51.589):{0x384} [ENV] [DB] Connection String = Server=CONXXXX1;Database=BESMgmt;Trusted_Connection=Yes
[30000] (08/17 09:43:51.589):{0x384} [ENV] [DB] DBMS Name = Microsoft SQL Server;  DBMS Version = 08.00.0760;  Provider Name = sqloledb.dll;  Provider Friendly Name = Microsoft OLE DB Provider for SQL Server;  OLE DB Version = 02.70;  Provider Version = 08.10.3959
[35019] (08/17 09:43:51.589):{0x384} [ENV] [DB] Database Schema Version:  4.1.5 <4.1.2.2007.11.28>
[40000] (08/17 09:43:51.589):{0x384} [ODBCDatabase::SetMaxConnections] MaxConnection=2
[30000] (08/17 09:43:52.355):{0x384} Access BBMgrAppResources using  rim_db_admin_security
[10000] (08/17 09:43:54.339):{0x384} Failed to load credential cache for accessing MDSS web services.
[30000] (08/17 09:44:06.917):{0x221C} [DIAG] EVENT=Register_thread, THREADID=0x221C, THREADNAME="Unnamed"
[40000] (08/17 09:44:06.917):{0x221C} [rimdevicemanagementimpl::ThreadProc] Creating RIMDeviceMonitor
[40000] (08/17 09:44:11.448):{0x384} [devicemgmt::setDevice] GUID: PIN:0 PORT:1
[40000] (08/17 09:44:11.448):{0x384} [devicemgmt::refreshItem] GUID: PIN:0 PORT:1
[40000] (08/17 09:44:11.448):{0x384} [devicemgmt::refreshItem] Resetting item properties.
[40000] (08/17 09:44:11.448):{0x384} [devicemgmt::setDevice] GUID: PIN:0 PORT:3
[40000] (08/17 09:44:11.448):{0x384} [devicemgmt::refreshItem] GUID: PIN:0 PORT:3
[40000] (08/17 09:44:11.448):{0x384} [devicemgmt::refreshItem] Resetting item properties.
[40000] (08/17 09:44:11.511):{0x384} [rimdevicemanager::enablePort] Port:1 Enable: False Speed: 9600.
[40000] (08/17 09:44:11.511):{0x384} [rimdevicemanager::enablePort] Port:3 Enable: False Speed: 9600.
[30000] (08/17 09:44:11.558):{0x384} BlackBerry Manager has successfully started
[40000] (08/17 09:44:11.558):{0x384} LicenseManager: Starting.
[45056] (08/17 09:54:11.584):{0x170C} {ConnectionPool::GetConnection()}: new maximum connections in use count = 2
[40000] (08/17 09:57:08.489):{0x221C} [rimdevicemanagementimpl::ThreadProc] Destroying RIMDeviceMonitor
[30000] (08/17 09:57:08.489):{0x221C} [DIAG] EVENT=Unregister_thread, THREADID=0x221C, THREADNAME="Unnamed"
[40000] (08/17 09:57:10.801):{0x384} LicenseManager: Stopping.
[40000] (08/17 09:57:10.864):{0x384} [ExchangeAdaptorDLL::Uninitialize] Uninitializing MAPI connection.
[30000] (08/17 09:57:10.879):{0x384} BlackBerry Manager has shutdown
I'm new to all this stuff, I'm waiting for the proper training, is there hope for me?
Offline  
Old 08-17-2012, 03:30 AM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Aug 2008
Location: Basel
Model: 9780
PIN: N/A
Carrier: Swisscom
Posts: 1,579
Post Thanks: 5
Thanked 119 Times in 116 Posts
Default Re: Blackberry Manager 4.1 doesn't allow for any settings

With which account do you login to the BES to administer users? With "Administrator"? If so, you will not be able to administer after you rename the account.

Try to login with BESAdmin and check if BES Manager works for you.
Offline  
The Following User Says Thank You to freakinvibe For This Useful Post:
JaspErekpl (08-22-2012)
Old 08-20-2012, 08:13 AM   #5 (permalink)
New Member
 
Join Date: Aug 2012
Model: 8310
PIN: N/A
Carrier: T-Mobile Poland
Posts: 9
Post Thanks: 5
Thanked 0 Times in 0 Posts
Default Re: Blackberry Manager 4.1 doesn't allow for any settings

I Logged in as Administrator / New unique name admin:
NO LUCK :(

I also logged in as BESAdmin and still NO LUCK :(

I restarted the services / the server and I still get no luck.

I created a new BES service management account and switched to new database.

Still the same problem.

I also tried running everything as the built-in admin user (just for testing): still NO LUCK. :(

Any ideas?

Should I reinstall the BES?
Offline  
Old 08-20-2012, 09:28 AM   #6 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,701
Post Thanks: 270
Thanked 286 Times in 270 Posts
Default Re: Blackberry Manager 4.1 doesn't allow for any settings

Follow this
KB13909-How to change the password for the BlackBerry administration account

if not working after, you might need to make a new one
KB04293-How to Switch BlackBerry Enterprise Server Service Accounts For Microsoft Exchange
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
The Following User Says Thank You to knottyrope For This Useful Post:
JaspErekpl (08-22-2012)
Old 08-20-2012, 11:45 AM   #7 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2007
Model: Z10
OS: 10.1.0.19
Carrier: Fido
Posts: 1,068
Post Thanks: 6
Thanked 30 Times in 29 Posts
Default Re: Blackberry Manager 4.1 doesn't allow for any settings

^+1 in addition to that follow the pre-requisites for BESAdmin service account. Must not have admin privileges, just regular user with escalated priv.
Offline  
The Following User Says Thank You to fadmin For This Useful Post:
JaspErekpl (08-22-2012)
Old 08-20-2012, 01:12 PM   #8 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,701
Post Thanks: 270
Thanked 286 Times in 270 Posts
Default Re: Blackberry Manager 4.1 doesn't allow for any settings

i like this post
What is the BESAdmin service account and why does ... - BlackBerry Support Community Forums
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
The Following User Says Thank You to knottyrope For This Useful Post:
JaspErekpl (08-22-2012)
Old 08-22-2012, 07:35 AM   #9 (permalink)
New Member
 
Join Date: Aug 2012
Model: 8310
PIN: N/A
Carrier: T-Mobile Poland
Posts: 9
Post Thanks: 5
Thanked 0 Times in 0 Posts
Default Re: Blackberry Manager 4.1 doesn't allow for any settings

Hi again,

As I finally managed to solve the problem i wanted everybody to know what was the reason.

I assumed the problem was behind the Admin username change, but that was just a coincidence. At the same time I installed server updates with Internet Explorer security patches. Something went wrong with these and Internet Explorer stopped working.

Because Blackberry Manager uses some kind of IE component to connect to MDS service it disallowed the BES management.

I removed the updates and reinstalled them. After this step all works without problems.

Thank You for help in solving the issue. Have a nice day

I will take into consideration the reasoning behind the BESAdmin user privileges. I'm afraid to break anything as it was set up by someone else (who I suppose knew what he's doing). After I receive proper training I'll have to apply all the ideas I got during this problem.

Last edited by JaspErekpl : 08-22-2012 at 07:38 AM.
Offline  
Old 08-22-2012, 08:22 AM   #10 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,701
Post Thanks: 270
Thanked 286 Times in 270 Posts
Default Re: Blackberry Manager 4.1 doesn't allow for any settings

glad to see you are doing better and was able to learn something too
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: Blackberry Manager 4.1 doesn't allow for any settings
Thread Thread Starter Forum Replies Last Post
HOWTO: Use BlackBerry on Generic NON-BlackBerry Data Plan Mark Rejhon BlackBerry Network 92 03-08-2014 11:26 AM
Las Vegas CES Stuff ZombieBerry BlackBerry In the News 12 01-15-2012 12:59 PM
BES 5.0 Exchange/Domino final documentation posted illy BES Admin Corner 9 05-12-2009 11:16 AM
New to BES admin , need help with messages. bigwig BES Admin Corner 5 10-17-2007 10:59 AM
BES for Domino 4.0 SP4 - Coming Soon jibi BES Admin Corner 0 03-01-2006 10:29 AM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.