BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-19-2012, 10:51 AM   #1 (permalink)
Knows Where the Search Button Is
 
MasterofKarate's Avatar
 
Join Date: Mar 2011
Location: Redwood City, CA
Model: None
PIN: N/A
Carrier: Verizon
Posts: 44
Post Thanks: 4
Thanked 6 Times in 6 Posts
Default Enterprise Activation fails only on standby servers

Please Login to Remove!

Hi everyone,

We are having an issue in our BES environment where we cannot activate users when running on any of our standby servers. The ETP message is delivered, picked up from the Inbox, and is never modified by the user(s). All other functions seem to be working OK while on the standby and activations for all devices are successful when running on the primary.

Activation takes about 5 minutes to fail on the device with the error "The BlackBerry Enterprise Server has not responded to your activation request. An error may have occurred" with the options to view more details, continue activation, or cancel activation.

BES 5.0.3 MR8
Domino version 8.5.3

From our MAGT logs:

[40000] (11/19 09:20:21.854):{0x1BA8} {User Name Removed} *** OTAKEYGEN *** Failed to get password for the ACTIVATION request : ERR_GENERAL

[40000] (11/19 09:20:21.854):{0x1BA8} {User Name Removed} *** OTAKEYGEN *** sending ABORT_TRANSACTION, reason = NO_PASSWORD, description = "", transID = 53154148

[40393] (11/19 09:20:21.869):{0x1BA8} {User Name Removed} Message deleted from the mail file by sender request on server [Domino Mail Server Name Removed], NID=19906

[20262] (11/19 09:20:22.088):{0x1BE4} {User Name Removed} Unable to save PIM state data

[40000] (11/19 09:20:22.088):{0x1BA8} {User Name Removed} Email Settings: fetching modified documents


Any ideas/help would be greatly appreciated. Thanks!
Offline  
Old 11-25-2012, 07:18 AM   #2 (permalink)
dev
CrackBerry Addict
 
dev's Avatar
 
Join Date: Apr 2005
Location: Toronto
Model: 8800
Carrier: Rogers
Posts: 571
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default Re: Enterprise Activation fails only on standby servers

Check mail.box on the BES server for any SMTP routing error messages.
I would assume your domino mail servers & the BES server are all in the same NotesNamedNetwork so nrpc mail routing should be fine, however the etp message is in smtp format so it may be looking for an smtp route.
Check if the BES server is not entered (ip address entry) in the SMTP inbound control settings on the standby server under "Exclude these hosts from anti-relay checks"
Offline  
The Following User Says Thank You to dev For This Useful Post:
MasterofKarate (12-28-2012)
Old 12-28-2012, 11:16 AM   #3 (permalink)
Knows Where the Search Button Is
 
MasterofKarate's Avatar
 
Join Date: Mar 2011
Location: Redwood City, CA
Model: None
PIN: N/A
Carrier: Verizon
Posts: 44
Post Thanks: 4
Thanked 6 Times in 6 Posts
Default Re: Enterprise Activation fails only on standby servers

Sorry I didn't respond earlier, but I do appreciate your input. I was able to confirm those permissions but then determined the issue to be related to an entry for SQL auth credentials in the Registry of the primary servers. Even though our configuration showed that we were setup for Windows Auth to SQL, credentials were being passed for a non-windows account because a former team member had modified the registry when he originally installed our BES environment years ago.

Once I imported the data (including the credentials) from HKEY_USERS\.DEFAULT\SOFTWARE\Research in Motion\BlackBerry Enterprise Server\Database into the standby servers our activations started to work again.

Thanks!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: Enterprise Activation fails only on standby servers
Thread Thread Starter Forum Replies Last Post
Knowledge Sharing - Perform basic troubleshooting steps for Novell GroupWise noname BES Admin Corner 1 01-12-2010 07:33 AM
Disappearing Enterprise Activation... longHair General Legacy Device Discussion 10 07-21-2008 10:55 AM
Enterprise activation fails sanga.c BES Admin Corner 3 01-08-2007 02:04 PM
7100v & Enterprise Activation Aminocom General Legacy Device Discussion 3 11-23-2005 01:20 PM
BES Domino 4.0 SP2 rsun BES Admin Corner 12 08-25-2005 02:27 PM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.