BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   Problems installing BES 5.0.4 (http://www.blackberryforums.com/bes-admin-corner/264168-problems-installing-bes-5-0-4-a.html)

gbcwHolla 04-26-2013 05:48 AM

Problems installing BES 5.0.4
 
Hi Guys,

I’ve come across an issue while trying to install BES 5.0.4, I hope you guys can help.
After three days of looking up KB articles and double checking documentation, I’m about to pull the last gray hair out!

This is a fresh install on brand new servers, here’s our setup.

Blackberry Enterprise Server is hosted on a VM running Windows Server 2008 R2.
The BESMgmt database is on a separate Windows Server 2008 R2 VM running SQL Server 2008 R2 Standard Edition.

The BES Admin account is an AD account setup according to the following KB article: KB02276-Assigning service account permissions for a BlackBerry Enterprise Server for Microsoft Exchange

The install goes fine until the very last stage where you are prompted to start the services.
I click on start services, and a progress bar appears, then, after a couple of seconds a “Error writing to Database” dialog appears.
When I click Ok, the installer shuts down.

I’ve checked the installer logs and the following lines are standing out:

{0xEBC} 1664: (#30000) CBASUtilitiesCon::Decode - About to run batch file command: ["C:\Program Files (x86)\Java\jre1.6.0_31\bin\java.exe" -cp "C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BAS\lib\basServerSystem.jar" com.rim.bes.bas.system.Encoder decodeAES_HEX "XXXXXXXX" "XXXXXXXX"]
{0xEBC} 1665: (#10000) CBASUtilitiesCon::Execute - Exit code was [0]
{0xEBC} 1666: (#10000) CBASUtilitiesCon::Execute - Error with empty output file [C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\BAS\bin\basutility.tmp]
{0xEBC} 1667: (#10000) CBASUtilitiesCon::Decode - Failed to decode digest, return code [7]
{0xEBC} 1668: (#30000) CBASUtilitiesCon::QueryWebGenKeyPasswordRegistry failed to decode password, code [7], setting it to empty
{0xEBC} 1669: (#30000) CBASUtilitiesCon::QueryWebGenKeyPasswordRegistry result is [56]

And then further down the log is see this:

{0xB6C} 1979: (#20000) [ODBCRecord::DoCreateRecord] SQL error: [0x80040E2F Cannot insert duplicate key row in object 'dbo.BASTraits' with unique index 'UK_BASTraits_TriatIdPluginIdObjectIdsMetaDataSetI temId'. The duplicate key value is (1, 111, <NULL>, <NULL>, <NULL>, <NULL>).] Source: [Microsoft OLE DB Provider for SQL Server] SQL State: [23000] NativeError: [2601]
{0xB6C} 1980: (#20000) [ODBCRecord::DoCreateRecord] SQL error: [0x80040E2F The statement has been terminated.] Source: [Microsoft OLE DB Provider for SQL Server] SQL State: [01000] NativeError: [3621]
{0xB6C} 1981: (#20000) [ODBCRecord::DoCreateRecord] COM Error 0x80040E2F - IDispatch error #3119 - Source: "Microsoft OLE DB Provider for SQL Server" - Description "Cannot insert duplicate key row in object 'dbo.BASTraits' with unique index 'UK_BASTraits_TriatIdPluginIdObjectIdsMetaDataSetI temId'. The duplicate key value is (1, 111, <NULL>, <NULL>, <NULL>, <NULL>)."
{0xB6C} 1982: (#20000) [ODBCRecord::DoCreateRecord] SQL = "SET NOCOUNT ON; INSERT INTO BASTraits (Value, TraitId, PluginId) VALUES (?, ?, ?) ; SELECT SCOPE_IDENTITY(); SET NOCOUNT OFF".
{0xB6C} 1983: (#20000) [ODBCRecord::DoCreateRecord] DATA = "Value[MYDOMAIN.COM] TraitId[1] PluginId[111] ".
{0xB6C} 1984: (#10000) ADSettings could not write user domain [MYDOMAIN.COM] to the database
{0xB6C} 1985: (#10000) [PIPTOOL]: Start Service failed to update AD Settings, code [13]

I tried the fix suggested in KB26624 but to no avail. KB26624-"Error writing to database" is displayed after clicking on "Start Services" when installing the BlackBerry Enterprise Server
Also, the BESAdmin password contains no special characters.

Anybody out there got any ideas?

Cheers...

nobody7290 04-28-2013 09:27 AM

Re: Problems installing BES 5.0.4
 
This looks like two different problems. Something is wrong with the database and something is probably wrong with the java runtime.
Uninstall the blackberry server. Remove all instances of jre you have on the computer if possible.

If the Database is on a different server, make sure, the besadmin account has local administrator priviliedges there and, give him all rights to the sql server.
unstall the Server, remove the database, install again.
Or: creat the datbase with the script which comes with the BES installer locally on the SQL-Server.
Then try a new BES installation.

gbcwHolla 05-01-2013 08:18 AM

Re: Problems installing BES 5.0.4
 
Well, after many hours trying to figure out what the problem was, I just re-installed SQL Server. The install was exactly the same as before as were the permissions assigned and it worked. BES 5.0.4 successfully installed. Very weird.


All times are GMT -5. The time now is 05:07 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.