BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-01-2013, 10:54 AM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2006
Model: 8350i
Carrier: Nextel
Posts: 195
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES 4.1.4 on SBS 2003 and want BB 10!!!

Please Login to Remove!

I've posted before about this but I wanted to check again and see if anything has changed.

I'm running a very small environment, 1 SBS 2003 server, Exchange 2003, 4 total desktop users, 2 Blackerry's

I've been using BES 4.1.4 which is the trimmed down version I believe, but it has worked great for 6 years. Now I'm wanting to consider BB 10 phones for myself and the company president. Can't have any interruptions during this process.

Last time I checked you couldn't run BES 10.x on an old platform like SBS 2003 and upgrading that platform at this time will take quite a lot of work. Hardware and software. Not in the cards for right now.

I had started down the path of attaching a small Dell stand alone server running Windows Server 2008 R2 SP1, Foundation Edition and running BES 10.x on that and pointing back to my Exchange which is on the SBS 2003 box. The cost of the dell box with OS is 702 dollars which believe it or not, not bad for me considering the amount of time and effort it will take to upgrade and replace the old SBS 2003 box. That's going to be a big project.

So I'm wondering if this will actually work? I'm told you can join 2008 R2 into a SBS 2003 domain and that BES 10.x would actually work. So my questions are:

1. Will this actually work?
2. 2008 R2 Foundation? Is this OK?
3. What about CALS? I understand workstation cals, but what are BB cals?
Does it matter? All this cal stuff can make a guy crazy.
4. What version of BES?
5. What is the cost for just 2 users?
6. Where am I going wrong here?

Thanks. This is one situation where being a really small shop is a real pain in the butt. I appreciate your help.

Roveer.
Offline  
Old 08-01-2013, 02:32 PM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,362
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: BES 4.1.4 on SBS 2003 and want BB 10!!!

A1) Server 2008R2 is able to join a Domain managed by a SBS 2003, But a windows 2008R2 foundation server is unable to replace an SBS2003 server (no exchange server). Keep the SBS2003, but add a new server for the BES10.
A2) Dont know, I never tried the foundation server, but if I remember correct, it is a very limited version and, you will have problems joining the Windows domain. But I really dont know this exactly. The foundation server is not listed as a compatible OS for BES10.
A3) The BB10 server is free, but you need CALs (as with the BES4/5 enterprise version). CALs are about $99, but, if you currently activate a new BB10 on a BB10 server you get permanent CALs for free.
A4) Just install the most current Blackberry 10 Server version
A5) besides the cost of the server, and your time, 0
A6) You could just use Active Sync with the Blackberry 10 devices - no BES required (no synchronisation of outlook notes with Exchange 2003 however!)
Offline  
Old 08-02-2013, 08:14 AM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2006
Model: 8350i
Carrier: Nextel
Posts: 195
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES 4.1.4 on SBS 2003 and want BB 10!!!

Does anyone know if Server 2008 foundation will work to host BES10? Yes, Exchange will stay on SBS 2003 server. Foundation is only to run BES10.

When referring to CALS, are they Microsoft cals or BB Cals?

Can't use activsync, can only have outbound sync. Can't open inbound ports
Offline  
Old 08-02-2013, 08:22 AM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,362
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: BES 4.1.4 on SBS 2003 and want BB 10!!!

Blackberry Device CALs. Microsoft CALSs are AFAIK only needed if a client uses the Server for sharing, but, better read the fine print if you want to have a 100% legal installation.
Offline  
Old 08-02-2013, 08:53 AM   #5 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,724
Post Thanks: 272
Thanked 288 Times in 272 Posts
Default Re: BES 4.1.4 on SBS 2003 and want BB 10!!!

if not listed here then i would not try it in production

Blackberry Enterprise Server compatibility chart
BlackBerry - BlackBerry Enterprise Server Compatibility - US
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 08-02-2013, 08:57 AM   #6 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,724
Post Thanks: 272
Thanked 288 Times in 272 Posts
Default Re: BES 4.1.4 on SBS 2003 and want BB 10!!!

i don't think it will have enough power to RUN BES 10

Introduction to Windows Server 2008 Foundation
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 08-02-2013, 08:58 AM   #7 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,362
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: BES 4.1.4 on SBS 2003 and want BB 10!!!

There is no exchange 2003 mentioned in the current list - strange. I thought is was supposed to be compatible in the initial release ?
Offline  
Old 08-02-2013, 10:11 AM   #8 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,724
Post Thanks: 272
Thanked 288 Times in 272 Posts
Default Re: BES 4.1.4 on SBS 2003 and want BB 10!!!

I had BES 10 working with Exchange 2003 SP2 but now we on 2010
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 08-02-2013, 10:29 AM   #9 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,724
Post Thanks: 272
Thanked 288 Times in 272 Posts
Default Re: BES 4.1.4 on SBS 2003 and want BB 10!!!

2003 has limited support as shown here

http://docs.blackberry.com/en/admin/..._Matrix_en.pdf
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 08-02-2013, 12:14 PM   #10 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2006
Model: 8350i
Carrier: Nextel
Posts: 195
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES 4.1.4 on SBS 2003 and want BB 10!!!

Wow...

Based on all of what is being posted I think I may have to wait until I upgrade the server. the LS concerns me. Of course I guess I could build it, get my hands on a BB10 phone and try it out with BES4.1.4 still running on the SBS box.

Hrmm... Will have to give this some more thought.

Old software sucks...

Thanks for all the replies
Offline  
Old 08-02-2013, 02:37 PM   #11 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,724
Post Thanks: 272
Thanked 288 Times in 272 Posts
Default Re: BES 4.1.4 on SBS 2003 and want BB 10!!!

10 year old server software might be fine for most of your needs, but not all newer software is going to support 10 year old server OS and their 10 year old applications

A lot has changed in 10 years.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 08-02-2013, 03:12 PM   #12 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2006
Model: 8350i
Carrier: Nextel
Posts: 195
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES 4.1.4 on SBS 2003 and want BB 10!!!

Quote:
Originally Posted by knottyrope View Post
10 year old server software might be fine for most of your needs, but not all newer software is going to support 10 year old server OS and their 10 year old applications

A lot has changed in 10 years.
Yup, probably the biggest thing is that I'm 10 years older and just don't have it in me for this upgrade. It was fun years ago, but now... eehh

But I do really want BB10 so I have to find a way.
Offline  
Old 08-02-2013, 03:28 PM   #13 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,362
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: BES 4.1.4 on SBS 2003 and want BB 10!!!

If that server hardware has to be replaced sooner or later, just do it sooner, better then risk a hardware failure. Also, It might be possible that in about 5 Years the saved energy sums up to >$1500 with a new server.

I would get something with Server 2012. Stay with SBS 2003 as long as possible and virtualize it on the new server. Then, install a second Instance of Server 2012 or 2008R2 (which is included in the Server 2012 License),
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.