BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-04-2013, 03:36 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2011
Model: 9630
PIN: N/A
Carrier: verizon
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES Admin page not available

Please Login to Remove!

Hello all.

I had an emergency and had to change the BESAdmin password on my network. I thought I had made all of the appropriate changes but the BES Admin Web page is not working. Everything else is working fine except for that. I know I must have missed a place to update the password but I can't find it for the life of me. Any suggestions would be greatly appreciated. Thank you
Offline  
Old 12-05-2013, 02:49 AM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2013
Model: 9700
PIN: N/A
Carrier: AT&T-US
Posts: 121
Post Thanks: 0
Thanked 7 Times in 7 Posts
Default Re: BES Admin page not available

If using Microsoft SQL Server Authentication, there is a registry key on the BlackBerry Monitoring Service that must be updated to reflect the new password. While logged into the BlackBerry Administration Server as the BESadmin Service account, open the registry. Navigate to the following key:

HKEY_CURRENT_USER\Software\Research In Motion\BlackBerry Enterprise Server\Monitoring Service\Database

Ensure the following entries are correct:

Login = besadmin

Password = ********
Offline  
Old 12-05-2013, 03:02 AM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2013
Model: 9700
PIN: N/A
Carrier: AT&T-US
Posts: 121
Post Thanks: 0
Thanked 7 Times in 7 Posts
Default Re: BES Admin page not available

When you change the BESadmin password you need to perform the following steps :

1. Change the BESadmin password in AD
2. Logon to the BES using the new password
3. Change the password assigned to all the Blackberry Services
4. Go into Start > Programs > BlackBerry Enterprise Server > BlackBerry Server Configuration > Select the Administration Service - AD Settings tab > Enter the new password and press Apply
5. Stop and then start the BAS services
Offline  
Old 12-05-2013, 07:25 AM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2011
Model: 9630
PIN: N/A
Carrier: verizon
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES Admin page not available

Quote:
Originally Posted by Escorts View Post
If using Microsoft SQL Server Authentication, there is a registry key on the BlackBerry Monitoring Service that must be updated to reflect the new password. While logged into the BlackBerry Administration Server as the BESadmin Service account, open the registry. Navigate to the following key:

HKEY_CURRENT_USER\Software\Research In Motion\BlackBerry Enterprise Server\Monitoring Service\Database

Ensure the following entries are correct:

Login = besadmin

Password = ********

Hello Escorts.

That key does not exist. Should I create it? All I see is:

HKEY_CURRENT_USER\Software\Research In Motion\BlackBerry Enterprise Server\Database

In Database there is only Default, DatabaseName, and DatabaseServerMachineName

There is no "Monitoring Service" container. I checked the entire Research in Motion container and nowhere is there a Monitoring Service.

I did follow all of the steps in your second post when I made the change. That's why this is so confusing.

Please advise. Thank you
Offline  
Old 12-05-2013, 08:29 AM   #5 (permalink)
Spam Reporter
 
dc/dc's Avatar
 
Join Date: Oct 2005
Location: IAD
Model: 6230
Carrier: Voicestream
Posts: 14,530
Post Thanks: 220
Thanked 345 Times in 311 Posts
Default Re: BES Admin page not available

Quote:
Originally Posted by uberwilhelm View Post
Please advise. Thank you
My advice is to not listen to anything Escorts posts. It's usually wrong. I'm honestly surprised he didn't tell you to reload your OS.
__________________
I h8 txtspk.
Offline  
Old 12-05-2013, 09:46 AM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2011
Model: 9630
PIN: N/A
Carrier: verizon
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES Admin page not available

Quote:
Originally Posted by dc/dc View Post
My advice is to not listen to anything Escorts posts. It's usually wrong. I'm honestly surprised he didn't tell you to reload your OS.
Fair enough but so far he is the only who has offered anything.
Offline  
Old 12-05-2013, 10:07 AM   #7 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,691
Post Thanks: 270
Thanked 284 Times in 269 Posts
Default Re: BES Admin page not available

first question is, what version BES?

use this to change password
KB13909-How to change the password for the BlackBerry administration account
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 12-05-2013, 12:04 PM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2011
Model: 9630
PIN: N/A
Carrier: verizon
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES Admin page not available

Quote:
Originally Posted by knottyrope View Post
first question is, what version BES?

use this to change password
Oops. Sorry about that. 5.0.3 MR2 (Bundle 21) and I followed all of those steps. I think that is actually the page I used when I had to make the change.
Offline  
Old 12-05-2013, 06:47 PM   #9 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,362
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: BES Admin page not available

Have you tried to look at the logs ?
is the BAS service and the Native code container runnng ?
Did you try a restart of the server ?

I dont know, how many users depend on your server. If there are only a few, and a little downtime is acceptable in case something goes wrong, restart the server the BES is running on, login with the besadmin account,, and, apply the update to 5.0.4.

Alternative: on a different machine, install the BAS component under the BES admin account. Then try to find out, why on the original server the console is not working.
Offline  
Old 12-06-2013, 09:27 AM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2011
Model: 9630
PIN: N/A
Carrier: verizon
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES Admin page not available

Quote:
Originally Posted by nobody7290 View Post
Have you tried to look at the logs ?
is the BAS service and the Native code container runnng ?
Did you try a restart of the server ?

I dont know, how many users depend on your server. If there are only a few, and a little downtime is acceptable in case something goes wrong, restart the server the BES is running on, login with the besadmin account,, and, apply the update to 5.0.4.

Alternative: on a different machine, install the BAS component under the BES admin account. Then try to find out, why on the original server the console is not working.
Nothing in the logs about BAS, all services are running and I rebooted the server last night. I'm really stumped. Also, both BAS-AS.exe and BAS-NCC.exe are running in the task manager.

Last edited by uberwilhelm : 12-06-2013 at 09:39 AM.
Offline  
Old 12-06-2013, 10:28 AM   #11 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,691
Post Thanks: 270
Thanked 284 Times in 269 Posts
Default Re: BES Admin page not available

some times its not worth figuring out, just reinstall BAS and that fixes it in most cases
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Offline  
Old 12-27-2013, 09:32 AM   #12 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2011
Model: 9630
PIN: N/A
Carrier: verizon
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES Admin page not available

Quote:
Originally Posted by knottyrope View Post
some times its not worth figuring out, just reinstall BAS and that fixes it in most cases
Can you just reinstall BAS? I tried to do a reinstall and it looked like it was going to redo the whole thing.
Offline  
Old 12-28-2013, 10:25 AM   #13 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,362
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: BES Admin page not available

If you launch the installer, and the product is already installed, it will install just anyhting if I remember correct - but, that should be ok, unless you have installed patches after the installation. In this case apply any patches you had installed before.

Otherwise you would have to remove bas using the installer or Control-panel, add/remove programs. Then, you should have the option to only install a single component (BAS).

If the complete reinstall does not help, try to uninstall the BAS component. Then, reinstall.
Or, got to a different machine, launch the installer, select that you only want to install BAS. During the installation you will be asked to find the BES server/database installation.
It does not matter if you have multiple instances of BAS installed.

If you install BAS on a different machine, and the console works fine there, then at least you know, your BES server installation is ok, an you have a local problem on the machine where the console is not working.
Offline  
Old 12-30-2013, 12:54 PM   #14 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2011
Model: 9630
PIN: N/A
Carrier: verizon
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES Admin page not available

Quote:
Originally Posted by nobody7290 View Post
If you launch the installer, and the product is already installed, it will install just anyhting if I remember correct - but, that should be ok, unless you have installed patches after the installation. In this case apply any patches you had installed before.

Otherwise you would have to remove bas using the installer or Control-panel, add/remove programs. Then, you should have the option to only install a single component (BAS).

If the complete reinstall does not help, try to uninstall the BAS component. Then, reinstall.
Or, got to a different machine, launch the installer, select that you only want to install BAS. During the installation you will be asked to find the BES server/database installation.
It does not matter if you have multiple instances of BAS installed.

If you install BAS on a different machine, and the console works fine there, then at least you know, your BES server installation is ok, an you have a local problem on the machine where the console is not working.
Does that go for BESExpress as well? I am having a heck of a time here. I am trying to do a separate install on another server but it states it cannot connect to the database server even though all of the information is correct.
Offline  
Old 12-30-2013, 01:19 PM   #15 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,362
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: BES Admin page not available

If you are able to lauch the express installer an are able to choose to install only a component, that should work. However I never tried this myself with the Express version.

Are you sure, the database is accessible ?
If the database run on the standard sql port, try to telnet to the database server ( port 1366 ?), or, try to setup an odbc connection with the odbc manager to test if it really is setup to allow access from somewhere else.
Posted via BlackBerryForums.com Mobile
Offline  
Old 12-30-2013, 01:34 PM   #16 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2011
Model: 9630
PIN: N/A
Carrier: verizon
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES Admin page not available

Never mind. Apparently when this was originally installed they used a unique port. Once I figured it out it connected. And yes it did allow me to choose the BAS only install. It is going now. I will post what happens. Thanks for the help.

Last edited by uberwilhelm : 12-30-2013 at 01:36 PM.
Offline  
Old 12-30-2013, 02:26 PM   #17 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2011
Model: 9630
PIN: N/A
Carrier: verizon
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES Admin page not available

I swear I have had it with this thing. I got the BAS installed on the remote server and naturally the services won't start. I verified that the pwrd was correct. I check the windows loags and see this error:

The description for Event ID 4098 from source BAS-AS cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer. (Same for BAS-NCC)



How can it not be found? I just installed the thing. I start the Server Config (on the new server) and do a test to the database and it passes. I also restarted the new server. What the hell else is there?
Offline  
Old 12-31-2013, 10:34 AM   #18 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,362
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: BES Admin page not available

I have only a few guesses:
does something run on the computer which maybe uses the same port(s) bas is using ?
Uninstall BAS, telnet to the port bas used, if you get a connect then install BAS using a different port.

Uninstall BAS, remove all instances of java, remove the java directory from program files
Try to install again.

Do you have any Java VMs running (maybe from Raid controllers for example) ?
Uninstall those, remove BAS, again install BAS

Somone in the blackberry support forums wrote, that after logging in on the computer using the account the installation of BAS was done, he was able to lauch the console.

Remove all Security Software (firewall, antivirus etc.) disable the windows Firewall
Try again to install or launch BAS.

Maybe, install a new OS from scratch (dont use a copy of a VM or something preinstalled), dont install antivirus, firewall, updates or similar. Then try again to install BAS.
Offline  
Old 01-02-2014, 07:52 AM   #19 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2011
Model: 9630
PIN: N/A
Carrier: verizon
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: BES Admin page not available

Quote:
Originally Posted by nobody7290 View Post
I have only a few guesses:
does something run on the computer which maybe uses the same port(s) bas is using ?

Nope. Nothing else uses that port.

Uninstall BAS, telnet to the port bas used, if you get a connect then install BAS using a different port.

Uninstall BAS, remove all instances of java, remove the java directory from program files
Try to install again.

Java wan't even installed on this machine. I did a fresh install of Java 6 update 18.

Do you have any Java VMs running (maybe from Raid controllers for example) ?
Uninstall those, remove BAS, again install BAS

See above

Somone in the blackberry support forums wrote, that after logging in on the computer using the account the installation of BAS was done, he was able to lauch the console.

Tried that. I left the account logged in and still nothing.

Remove all Security Software (firewall, antivirus etc.) disable the windows Firewall
Try again to install or launch BAS.

I am not very comfortable doing that but I guess I can try it. I did create rules in the firewall to allow all of the ports needed for BAS.

Maybe, install a new OS from scratch (dont use a copy of a VM or something preinstalled), dont install antivirus, firewall, updates or similar. Then try again to install BAS.

I guess I can try that but this is has become a royal pain in the ass. I cannot wait to get rid of BES.
Thanks for the info. I answered your questions in red.
Offline  
Old 01-02-2014, 08:08 AM   #20 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2006
Model: 9700
Carrier: t-mobile Germany
Posts: 1,362
Post Thanks: 11
Thanked 69 Times in 66 Posts
Default Re: BES Admin page not available

mhm,
disabling antivirus or firewall for testing purposes is the first thing I do if somehting does not run as expected. You never know which ports and services are used by an unknown/new software.
If afterwards the problem is solved you can of course enable it again.

The last option (install from scratch) is something I also do not like very much. However it helps to stop waisting time if there are no other options which can help in a realistic timeframe.

If you want to uninstall BES, its up to you - go ahead.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: BES Admin page not available
Thread Thread Starter Forum Replies Last Post
BES 5 Transported Migrated Users not working...please help! DSHThomsons BES Admin Corner 41 02-25-2011 05:20 AM
Special BES Express plans (UK) classact Carrier Specific Issues 0 05-16-2010 09:32 PM
BES Admin impersonates BB user when connecting to application jeffryvu BES Admin Corner 3 05-03-2010 07:26 AM
can't run BES 5 User Admin Tool cmd programatically? Laeeq BES Admin Corner 7 11-03-2009 01:12 PM
BES 3.6 admin permissions nsmith_62 BES Admin Corner 2 12-08-2005 08:16 AM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.