BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-26-2006, 04:05 PM   #1 (permalink)
New Member
 
Join Date: Feb 2006
Model: 7100T
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Blackberry Server service terminating 5305

Please Login to Remove!

I just upgraded our 3.6 server with Exchange 2003 Sp2 to 3.6 with SP7, and now when we reboot the server we get:

Blackberry Server <servername> service terminated with service-specific error 5305 (0x14B9).

I can manually start the service, but if we reboot the server and no one is available who knows how to do this, we're stuck. I found a KB on RIM for this, but is all for stuff on BES 3.5 and lower, and mostly for Exchange 5.5.

Any help is appreciated!
Vince
Offline  
Old 02-26-2006, 04:34 PM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Apr 2005
Location: The Netherlands
Model: 8800
Carrier: Vodafone
Posts: 374
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Dit you install any Exchange 2003 SP2 components (like CDO and MAPI32) on the BES? The BES does not support Exchange 2003 SP2 components installed on the BES (yet).

Regards,
Bob
Offline  
Old 02-26-2006, 06:59 PM   #3 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: May 2005
Model: 7100
Carrier: T-Mobile
Posts: 299
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Likely the BES Service is starting up before the computer authenticates to the domain. Try to add a service that starts later as a dependency.
Offline  
Old 02-27-2006, 03:46 PM   #4 (permalink)
New Member
 
Join Date: Feb 2006
Model: 7100T
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here's the skinny. The BES is actually directly on the SBS 2003 install with Exchange 2003 SP2. The customer knows this isn't the preferred config, but RIM support at install time said it was fine for this 5 person network. When it is time to upgrade they'll separate the two.

So yes, Exchange 2003 SP2 is on there. I tried writing a quick script and putting it in the startup folder to start the BES service, but couldn't get it to work. I wondered if the BES service was trying to start before Exchange or if the domain hadn't authenticated yet. I don't know how to change when the service starts, i.e. with the dependency deal. Any ideas how to just get the service to start later in the boot process?

Thanks,
Vince
Offline  
Old 02-27-2006, 09:03 PM   #5 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: May 2005
Model: 7100
Carrier: T-Mobile
Posts: 299
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I don't know if you can change the Startup order without a Dependency. The Dependency can be added through the Properties of the Service.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.