BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-03-2006, 06:12 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Location: Bilbao, Spain
Posts: 21
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default upgrading BES 4.0 to 4.1 - MDS problem

Please Login to Remove!

I upgraded the BES 4.0 to 4.1 version and i had an error in the MDS Services installation...

the installer log says...
Custom Action: net.rim.wica.ag.base.installer.DatabaseLoadAction
Status: ERROR
Additional Notes: ERROR - class net.rim.wica.ag.base.installer.DatabaseLoadAction. install() Unexpected Fatal Error:

and the BES MDS Services is not installed.

The BES components are installed and they work fine. That is the cause i have not tried to reinstall all again.

Are the MDS Services important? Because the handhelds can navigate with the BES MDS Connection Service. What are they for and how could i resolve the problem and install them?

What is the cause of the error?

I tried to run setup in the "MDS Services" folder of the BES4.1 CDROM but it seems to be MDS Services 4.0.x version (and i cancelled)!!! is that correct?

Thanks!!
Ender
Offline  
Old 05-04-2006, 05:30 AM   #2 (permalink)
New Member
 
Join Date: May 2006
Model: 7100T
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same problem last night.

I looked over my installed Java versions and realised I had more installed versions that were required.

Ie, I had 1.5 update 4 (required for install) and earlier versions like 1.4 etc etc.


I removed all versions and reinstalled the version stated in the manual and retried the installation process. The MDS service installation then completed. Be warned though, the server will reboot automatically.

Hope this helps.

Devon
Offline  
Old 05-04-2006, 05:39 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Location: Bilbao, Spain
Posts: 21
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Thanks a lot

Thanks a lot, Devon....

Ixxx314;l try it and ixxx314;l tell you!!!
Offline  
Old 05-05-2006, 10:07 AM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Location: Bilbao, Spain
Posts: 21
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default error persist...

Uninstalling java and reinstalling only 1.5.0_4 version and the BES has not fixed the problem...

Are you sure the error was Custom Action: net.rim.wica.ag.base.installer.DatabaseLoadAction? ??

I have run $BESMDS_HOME\bin\tomcat-service.bat install to install the service, but when i try to start the tomcat log says....

[ERROR][2006-05-05 15:36:48,468][Catalina]Catalina.stop:
java.net.ConnectException: Connection refused: connect

and tomcat 5.5.9 stops again.

can be related to database connection?

Thanks for the help anyway!
Ender
Offline  
Old 05-08-2006, 05:23 AM   #5 (permalink)
New Member
 
Join Date: May 2006
Model: 7100T
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK, this may be waaaayyyy off the mark. But this is what my BB support company sent me.

Known Issues - Mobile Data System Services fails to install
Last Updated: 30 March 2006
Article Number: KB-04987




--------------------------------------------------------------------------------

Summary
This article applies to the following:

BlackBerry Enterprise Server™ 4.1
BlackBerry Mobile Data System™ (BlackBerry MDS™) Services
IBM® Lotus® Domino®
Microsoft® Exchange
Novell® GroupWise®
SDR84164


--------------------------------------------------------------------------------

Problem
When you install BlackBerry Enterprise Server 4.1, BlackBerry MDS Services fails to install.

The BlackBerry MDS Services installation log displays the following:

Custom Action: net.rim.wica.ag.base.installer.BESUpdateArchiveAct ion

Status: ERROR

Additional Notes: ERROR - class net.rim.wica.ag.base.installer.BESUpdateArchiveAct ion.install() Unexpected Fatal Error:

Workaround
Replace the web.xml file.

Download the web.zip file, then unzip the file to a temporary location (for example, your desktop).
To start the Apache Tomcat service, open a command prompt on the BlackBerry Enterprise Server, then type the following:
C:\Program Files\Research In Motion\BlackBerry MDS Services 4.1.0\bin>tomcat-service.bat install

This unpacks the mds.war file.

After the mds.war file is unpacked, make sure the web.xml file is accessible. In Microsoft Windows® Explorer, go to the following location to check the web.xml file:
C:\Program Files\Research In Motion\BlackBerry MDS Services 4.1.0\jakarta-tomcat-5.5.9\webapps\mds\WEB-INF

In the Administrative Tools of the Windows Control Panel, double-click Services.
Right-click the BlackBerry Mobile Data System Service, then click Stop.
Go to C:\Program Files\Research In Motion\BlackBerry MDS Services 4.1.0\jakarta-tomcat-5.5.9\webapps\mds\WEB-INF and replace the web.xml file with the file you unzipped in step 1.
In the Control Panel, double-click Services.
Right-click the BlackBerry Mobile Data System Service, then click Start.
Close the Services window.


--------------------------------------------------------------------------------

Additional Information
The BlackBerry MDS Services installation log is located in C:\Program Files\Research In Motion\BlackBerry MDS Services 4.1.0\installer\BlackBerry_MDS_Services_InstallLog .log.


--------------------------------------------------------------------------------

Keywords
BESUpdateArchiveAction.install, fatal, mds.war, MDS, MDSS, web.xml, 84164

Worth a go.....

Devon
Offline  
Old 05-08-2006, 06:13 AM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Location: Bilbao, Spain
Posts: 21
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default i tried it but it doesnt works...

One contact from our carrier sent me tha same workaround as you. I followed the steps but the tomcat doesnt start correctly

The workaround is for the problem in:
Custom Action: net.rim.wica.ag.base.installer.BESUpdateArchiveAct ion

and mine is in:
Custom Action: net.rim.wica.ag.base.installer.DatabaseLoadAction

Ixxx314;l try to start tomcat without the MDS application, to see if the problem is there or not...

Thanks a lot anyway!!
Ender
Offline  
Old 05-08-2006, 03:50 PM   #7 (permalink)
New Member
 
Join Date: May 2006
Model: 7100
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am having the same problem

Custom Action: net.rim.wica.ag.base.installer.DatabaseLoadAction

It did not install the MDS Server Services. I tried updating the Web.xml.. this is unrelated.... I do not want to have to uninstall this!!!
Offline  
Old 05-08-2006, 03:54 PM   #8 (permalink)
BlackBerry God
 
jibi's Avatar
 
Join Date: Oct 2004
Location: Jibi's Secret Place
Model: 8900
OS: 4.6.1.174
Carrier: AT&T
Posts: 11,310
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

Do you care about having development capabilities? If not, and you only want what was MDS in BES 4.0, then don't install MDS Services.
__________________
In the beginning the Universe was created. This has made a lot of people very angry and is widely regarded as a bad move.
Offline  
Old 05-08-2006, 03:58 PM   #9 (permalink)
New Member
 
Join Date: May 2006
Model: 7100
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes we do want Development Capabilites. That was our main reason of upgrading to Version 4.1. Any ideas?
Offline  
Old 05-08-2006, 04:01 PM   #10 (permalink)
New Member
 
Join Date: May 2006
Model: 7100
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default MDS Server Services

Have you heard of anyone else having this issue?
Offline  
Old 05-08-2006, 04:05 PM   #11 (permalink)
BlackBerry God
 
jibi's Avatar
 
Join Date: Oct 2004
Location: Jibi's Secret Place
Model: 8900
OS: 4.6.1.174
Carrier: AT&T
Posts: 11,310
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

yeah, i think that was the most common installation error. there are quite a few knowledge base articles on RIM's website that covers the issue. assuming you're within your 6 months, you should have free installation/upgrade support with RIM (assuming you don't have TSupport already), so give them a call - 877-255-2377
__________________
In the beginning the Universe was created. This has made a lot of people very angry and is widely regarded as a bad move.
Offline  
Old 05-08-2006, 04:14 PM   #12 (permalink)
New Member
 
Join Date: May 2006
Model: 7100
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am giving them a call right now. Thanks...
Offline  
Old 05-08-2006, 05:16 PM   #13 (permalink)
New Member
 
Join Date: May 2006
Model: 7100
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I contacted Blackberry and we no long have support with them. Do you know of any people experiencing this problem?
Offline  
Old 05-10-2006, 05:05 AM   #14 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Location: Bilbao, Spain
Posts: 21
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Im going to work with the tomcat 5.5.9, its configuration and the databases mdss and the other...
I hope to find the problem that makes tomcat not starting...
When i find something ixxx314;l tell everybody...
Offline  
Old 05-10-2006, 06:34 AM   #15 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Location: Bilbao, Spain
Posts: 21
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem FOUND!!

I have found a problem and now the Tomcat Starts!!!

My SQL Server was the MSDE provided with the bes, but in the configuration no TCP/IP Port was used... i have configured it to use TCP/IP port 1433 and now the Tomcat starts...

MDS Services are with problems yet, but im going to try a reinstallation and to see if the process goes fine...

To change the MSDE TCP/IP port i found....
SVRNETCN.exe and enable TCP/IP Protocol....
Offline  
Old 05-10-2006, 07:07 AM   #16 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Location: Bilbao, Spain
Posts: 21
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem Fixed!!

The problem was that... the TCP/IP connection to the SQL Server was not enabled...

After enabiling it at port 1433 i have done the next:

1) Uninstall "Blackberry MDS Services" (control panel --> install/uninstall programs) (DO NOT UNINSTALL BES Server)

2) Reinstall again the BES Server with MDS Services and components. The proccess has finished successfull.

Thanks all again!
Ender

Last edited by ender : 05-10-2006 at 07:12 AM.
Offline  
Old 05-10-2006, 01:19 PM   #17 (permalink)
New Member
 
Join Date: May 2006
Model: 7100
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

So I enabled both of the Ports and I am now able to connect to the Database.
I uninstalled Blackberry MDS SErvices and re-installed it again. This was successful with no Errors
When I go into the Blackberry Manager and try to go into the MDS Services it says that "A problem was encountered accessing the specified MDS Server Services or MDS Connection Service server"
I go into Services and it does not look as though a MDS Services Server is installed only the Connection Service Server is installed"
Offline  
Old 05-10-2006, 04:13 PM   #18 (permalink)
New Member
 
Join Date: May 2006
Model: 7100
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am recieving the following errors in the log file

BlackBerry Manager has successfully started
[20000] (05/10 14:11:08):{0x838} [ODBCRecord::DoSetValue] Update failed as no AddIdentifier was called. Alternatively, DoCreateRecord() can be called
[30000] (05/10 14:11:13):{0x838} Bad hResult 0x80131509, at mdsagview.cpp line 1091, from AG call CMDSAGView::testWsAccess - getServerStatus, source - System, error - The underlying connection was closed: Unable to connect to the remote server.
[30000] (05/10 14:11:32):{0x1D20} Bad hResult 0x80131509, at mdsagview.cpp line 356, from AG call CMDSAGView::PrepareData - getServerStatus, source - System, error - The underlying connection was closed: Unable to connect to the remote server.
Offline  
Old 05-15-2006, 10:12 AM   #19 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Location: Bilbao, Spain
Posts: 21
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

when u say you uninstalled the MDS Services and reinstalled it again what do u mean?

I wanted to say to uninstall MDS Services and install "BES Server 4.1" again, not only the MDS Services...

But i suppose you did it....

At the end of the MDS Services installation, a CMD window appears that is installing the windows service and deploying mds application in tomcat... if that window does not appear try the next:
1) open a cmd.exe
2) go to directory C:\program files\Research in motion\Blackberry MDS Services\jakarta-tomcat5.5.9\bin\
3) run "tomcat-service.bat install"

And check if the service is installed in the Administrative Tools-->Services
Offline  
Old 05-16-2006, 08:19 AM   #20 (permalink)
Knows Where the Search Button Is
 
misquote's Avatar
 
Join Date: Jan 2006
Location: Chazy, NY
Model: 9550
Carrier: Verizon
Posts: 37
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the fix ender!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.