BlackBerry Forums Support Community
              

Closed Thread
 
LinkBack Thread Tools
Old 05-11-2006, 01:50 PM   #1 (permalink)
Thumbs Must Hurt
 
Korbyn's Avatar
 
Join Date: May 2005
Location: Calgary, AB
Model: 9800
OS: 6.0.0.246
Carrier: Telus
Posts: 85
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BlackBerry MDS Services - Apache Tomcat Service

Please Login to Remove!

Stupid question, the BlackBerry MDS Services - Apache Tomcat Service, is it supposed to be running all the time or no?

Mine is set to Automatic, and it'll start up, and then shutdown without any errors or logging. Really odd to me.

Just wondering if it just starts up when it needs to?

And yes, I was able to successfully install MDS services once I had a SQL alias created to point to our cluster, which is also listening on a non-default port...

K.
Offline  
Old 05-11-2006, 03:02 PM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Jan 2006
Location: Amsterdam
Model: 8707v
Carrier: Vodafone
Posts: 33
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The service should be running all the time. If it starts and then stops again there must be a problem.

Could you check the Tomcat logs: C:\Program Files\Research In Motion\BlackBerry MDS Services 4.1.0\jakarta-tomcat-5.5.9\logs

And post the configuration of Tomcat (server.xml) in C:\Program Files\Research In Motion\BlackBerry MDS Services 4.1.0\jakarta-tomcat-5.5.9\conf
__________________
BlackBerry consultant @ dahvo
Offline  
Old 05-12-2006, 02:07 PM   #3 (permalink)
Thumbs Must Hurt
 
Korbyn's Avatar
 
Join Date: May 2005
Location: Calgary, AB
Model: 9800
OS: 6.0.0.246
Carrier: Telus
Posts: 85
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

That's for the idea of looking at the server.xml file. Because we use a non-default SQL port, I needed to go into that file and specify the correct port. Now it starts up and stays running.

Can't believe RIM missed out on supporting SQL Instances and non-default SQL ports... Got around the instance but creating an Alias using the SQL client, but I hadn't seen anything about this Tomcat service, although I'm not really sure what it's for yet, haven't gotten that far in my re-education on 4.1 (why the heck they didn't call it 5.0 I'll never know...)
Offline  
Old 06-08-2006, 09:49 AM   #4 (permalink)
Thumbs Must Hurt
 
jrbes's Avatar
 
Join Date: Jun 2005
Location: Here
Model: 8700
Carrier: Cingular
Posts: 161
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same problem - I edited the XML file to reflect just the SQL server name without the instance and changed the port from 1433 to our port, created an Alias and my LCS starting working, but my web browser would fail. I changed the XML back and now both work. RIM stated that 4.1.1 will fix this but will not be out for a while...
__________________
Policies get in the way of fun.
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.