BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-15-2006, 10:30 AM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2005
Location: Philadelphia
Model: 7290
Posts: 67
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation MAPI32.dll Question

Please Login to Remove!

Currently, our BES is running MSDE - windows server 2000

We have 9 exchange servers, all running 2003

Can i register a 2003 mapi32.dll on the BES running 2000 to match them up? Or will that cause issues, due to the .dll having hooks into the kernel?

We are currently on BES 4.0 SP3

Mapi32.dll :

Bes (win2000) - 6.5.7226.0

Exchange servers (win2003) - 6.5.7638.1

Thoughts?
__________________
Matt
Blackberry 8700c
Bes 4.1 / Exchange 2003 SP2

Last edited by exiled : 06-15-2006 at 10:50 AM.
Offline  
Old 06-15-2006, 11:56 AM   #2 (permalink)
CrackBerry Addict
 
ashworth's Avatar
 
Join Date: Jun 2006
Location: Ontario, Canada
Model: 9000
OS: 4.6
Carrier: Rogers
Posts: 625
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by exiled
Currently, our BES is running MSDE - windows server 2000

We have 9 exchange servers, all running 2003

Can i register a 2003 mapi32.dll on the BES running 2000 to match them up? Or will that cause issues, due to the .dll having hooks into the kernel?

We are currently on BES 4.0 SP3

Mapi32.dll :

Bes (win2000) - 6.5.7226.0

Exchange servers (win2003) - 6.5.7638.1

Thoughts?

You cannot just manually register the mapi32.dll file unlike the cdo.dll. The only way to properly register the mapi32.dll files it to install the Exchange System Manager tools on the BlackBerry Enterprise Server. Once that is done you want to make sure you apply SP2 for Exchange 2003. Then you may want to upgrade your BlackBerry Enterprise Server to 4.0 SP4 HF3. SP4 is the only service pack in 4.0 that supports Exchange 2003 sp2 (6.5.7638.x).
__________________
Cheers,
Ash


My BlackBerry GPS Golf Application | Mileage Calculator
Offline  
Old 06-15-2006, 12:45 PM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2005
Location: Philadelphia
Model: 7290
Posts: 67
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Actually i did know that, i'm sorry i didnt mean to leave that part out.

Actually this weekend we are updating to 4.1, so i'm not worried about the 4.0 SP4 part.

I guess i'll upgrade the BES to 4.1, then install ESM 2003 + SP2

Thanks again.


Quote:
Originally Posted by ashworth
You cannot just manually register the mapi32.dll file unlike the cdo.dll. The only way to properly register the mapi32.dll files it to install the Exchange System Manager tools on the BlackBerry Enterprise Server. Once that is done you want to make sure you apply SP2 for Exchange 2003. Then you may want to upgrade your BlackBerry Enterprise Server to 4.0 SP4 HF3. SP4 is the only service pack in 4.0 that supports Exchange 2003 sp2 (6.5.7638.x).
__________________
Matt
Blackberry 8700c
Bes 4.1 / Exchange 2003 SP2

Last edited by exiled : 06-15-2006 at 12:48 PM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.