BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   application of a service pack on a BES with a remote SQL database (http://www.blackberryforums.com/bes-admin-corner/38975-application-service-pack-bes-remote-sql-database.html)

booster 06-22-2006 11:49 AM

application of a service pack on a BES with a remote SQL database
 
Hi,

one of my clients has a BES v 4.0 for Exchange 5.5, with the configuration database installed on a remote SQL server.

The BES is using SQL authentication to access the SQL database.

Everything is going OK since I installed it one year ago.

The problem is : I could only apply the hotfix 1, but NO service pack at all ! Every time I try to apply a service pack, I have an error : DB upgrade fqiled", or something similar. As if the BES was unable to connect to the DB ...

Is it possible to apply a service pack on a BES that has a remote SQL database directly with the setup.exe that comes with the service pack ? Could it be an authentication problem ?
What are the necessary permissions to have on the DB to be able to apply this patch ?

Once, I read about a CreateDB.exe file to run ON the SQL server itself, with a pre-configured CreateDB.cfg file. Is it the only way to patch a remote SQL database, or can it be done with the setup.exe rn from the BES ?
If I use the CreateDB.exe and CreateDC.cfg on the SQL server, do I still need to run the service pack setup.exe on the BES ?

I plan to connect a BES v4.1 on this SQL database, to move users from the 4.0 BES to the 4.1 BES. Is there a minimum level of service pack I have to apply to the database to connect a BES v4.1 on it ?

I hope you understood everything !

I really need some help this time. I usually find my solution in this wonderful forum, but not this time !!!!!

Thanks in advance


connecter un BES 4.1 sur la DB SQL : quel niveau de SP minimum ?

elgauchogrub 06-22-2006 05:27 PM

CreateDB Utility
 
You're not alone with the DB upgrade issues, we've done 6-7 of them between service packs and full version upgrades, and not a single one has worked by running setup.exe.

As far as Creatdb.exe, I wish that still worked! I was told by T-Support that it's no longer an option once you're on 4.0. We pretty much used that as the default procedure since setup.exe was so unreliable.

You will need to upgrade your database to version 4.1 in order to run that version of BES. I've been testing the 4.0-4.1 migration the last couple days, and found that unlike previous versions, the setup.exe route actually worked the 2nd time I ran it. The only error I got was on one of the last parts of the database upgrade, and this was resolved by temporairly granting the SQL user account Setup Administrator permissions and running it again.

booster 06-26-2006 08:38 AM

Thanks for your reply !

I finally could convince the client to install a second BES (that was part of the migration project) with a temporary SRP ID, and I installed it in 4.0.4 hotfix 3 with a local MSDE database.

Once it was up and running, I simply moved the DB to a SQL server. So my client has now a patched BES running with a remote SQL database.

My client will move all users from the first BES to the second (unfortunately, 2 enterprise activations will be needed : one for the first move between BESs, one when I'll put the regular SRP ID on the second BES).

But the client is OK for that.

anyway, even if my problem is solved, could anyone tell me what could be the reason why I couldn't patch this database ?

Thanks


All times are GMT -5. The time now is 04:46 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.