BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-30-2006, 09:49 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Model: 8700
Carrier: Swisscom EDGE
Posts: 24
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default "Setup cannot locate Notes.ini" error when upgrading 4.0 to 4.1

Please Login to Remove!

Hi there !

I have the following pop-up message when I lauch the setup.exe of BES 4.1 on my BES 4.0 (service pack 1) in order to migrate it :

"Setup cannot locate Notes.ini in the Domino folder. Setup will now exit"

It does not modify any thing, there is a rollback when I press OK.

I checked all registry keys to check the paths to the Domino files, everything is OK.

I have Domino 7.0.1 running.

I found here in another topic saying that I should upgrade to SP3 at least before migrating to 4.1, otherwise I would get this notes.ini error message.
BUT when I apply this SP, I also get the notes.ini error message !!!!

I don't really know what to do, could you help me ??

Thanks in advance
Offline  
Old 07-04-2006, 02:38 PM   #2 (permalink)
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Post Thanks: 6
Thanked 9 Times in 9 Posts
Default

Modify your Domino's registry for the foldername from "7" to "6" and run the installer again... make sure to change back after installation...
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Old 07-25-2006, 07:00 AM   #3 (permalink)
New Member
 
Join Date: Jun 2005
Model: Bold
Carrier: Optus
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Booster,
I had exactly the same problem on my Domino server, we tested and tested
(In our lab on a test server)and found eventually it was in the actually notes.ini file. When we closely examined the file we found that from when upgrading the server from 5 to 6 and then hotfixes along the way that the ini file became very messy and had some double entries, one was about where the directory was to check for the id file. What we did (agin in the lab) is to strip out lines that we did not really need to get the server up, then started the server, tried the install. Each time we kept getting the same error message. Well we decided to get fair dinkum and strip out every line bar the first 3-4 lines. Started the server and it rebuilt the ini file back to basics so it could boot. Once the server was stable then we installed the Bes software without issue. The install was a dream, 10 minutes. When we had this side stable then we shut the server down, put back certain configs in the ini file that we wanted and bought the server back up. Server has been great ever since. We have always keep a copy of the old ini file ( never know when you may need to refer to it for history etc) and the new ini is on the serve now.

Hope this helps.
Offline  
Old 07-25-2006, 08:18 AM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Jul 2006
Model: 7290
Carrier: T-Mobile
Posts: 36
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Had a similar issue during an upgrade. Our solution was a little different.

Right Click My Computer-->Properties. Click Advanced Tab. Click Environment Variables Button.

Under System Variables find the Path variable. Highlight and click the Edit Button.

Make sure the path to the directory containing your Notes .ini is included in these paths. The entries are delimited by semicolons.
Offline  
Old 07-26-2006, 05:29 AM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Model: 8700
Carrier: Swisscom EDGE
Posts: 24
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Jinks,

I already checked this, of course, but the correct paths were already present !

In fact, we changed the registry key as noname adviced, and it worked ! Unbelievable .....

So it's fixed now, and it's working pretty well (the client hasn't shouted for days !)

Thanks all for your great help !

Cheers
Offline  
Old 07-26-2006, 08:18 AM   #6 (permalink)
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Post Thanks: 6
Thanked 9 Times in 9 Posts
Default

Hey booster, you're most welcome!
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.