BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   MDS connection Time out error (http://www.blackberryforums.com/bes-admin-corner/41118-mds-connection-time-out-error.html)

LHC77 07-17-2006 05:48 AM

MDS connection Time out error
 
I have just upgraded my BES from 4.0 to 4.1 and have also installed MDS. I can activate the MDS on the devices but when I try to run applications such as the simple convertor application supplied by RIM it allows me to enter the data and submit it but after a about a minute I get the following error in my log files.

{H T T P://xml.apache.org/axis/}hostname:bes (I had to put spaces in between http because I was not allowed to put URLs' yet)

java.net.ConnectException: Connection timed out: connect

I also get the following error on my handheld
An error has occurred, SOA connection failed; nested exception is:
java.net.connectException: Connection timed out: Connect.

I am fairly new to all this stuff and vodafone done the install so I am still learning myself but if anyone has any pointers then please let me know. I have checked the Java versions and .NET framework etc and they are all at the correct levels recommended levels.

noname 07-17-2006 05:58 AM

Are you having more than one version of Java Runtime Environment (JRE) running on the BES? Check under Add/Remove Programs under Control Panel... remove and make sure just latest version is installed... BES sometimes is "confused" if you have multiple copies of JRE...

LHC77 07-17-2006 07:44 AM

Thanks fort your reply.
I only have version 1.5.0_04 installed on the Server.

noname 07-17-2006 07:53 AM

Hmmm... "apache" appears in error log... is your BlackBerry MDS - Apache Tomcat service started? You may like to try reinstall the tomcat from the installer folder "third_party > apache"...

LHC77 07-17-2006 09:09 AM

Yeah it has definately started. I'll try a reinstall of apache. Do I need to uninstall it first or can I reinstall over the top?

LHC77 07-17-2006 11:13 AM

Ok I have found out what the problem is but I still don't know how to fix it. Basically I dropped the filters/access lists on the firewall for a few seconds, retried my connection to the convertor program on the MDS and it worked first time. Now I have put the filters back up and it has stopped again. Therefore there is a firewall configuration problem but I don't know where it lies. I have the standard 3101 port open on the server and mail is coming in and out no problem but still no joy with the BES applications.

Any new ideas out there?

LHC77 07-18-2006 09:59 AM

C'mon people, I can't believe for a minute that there is noone out there who knows what other ports (if any) have to be opened on my firewall for MDS work properly. My device activates ok but application responses get blocked by my firewall. I know it get blocked at the firewall because dropping the filters allows it to work. I also know it is the response because the log files show that data was received. My BES server is also behind a proxy server and am not sure if that is causing a problem.

noname 07-18-2006 10:36 PM

For Apache Tomcats, I understand that the ports used are 7080 (HTTP), 7443 (HTTPS) and shutdown port is 7005. MDS uses port 8080 to connect to applications.


All times are GMT -5. The time now is 09:08 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.