BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-03-2006, 04:44 PM   #1 (permalink)
New Member
 
Join Date: Aug 2006
Model: 7130e
Carrier: Sprint
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Calendar Sync only working one way (Outlook --> BB)

Please Login to Remove!

I have a single blackberry environment running BES Express 4.1.0.38. Unfortunately it is not sending appointments created or editted on the blackberry (7130e) wirelessly back to Exchange/Outlook 2003.

I have tried to disable and reenable the wireless synch but that has so far turned up nothing. Any thoughts on what the problem could be?

Everything else seems to work fine.

Thanks in advance!
Offline  
Old 08-03-2006, 05:14 PM   #2 (permalink)
CrackBerry Addict
 
|||||||'s Avatar
 
Join Date: Jun 2006
Model: 7100
Carrier: Rogers
Posts: 615
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Permissions

Is the besadmin user a member of the domain admins?
Offline  
Old 08-15-2006, 02:47 PM   #3 (permalink)
New Member
 
Join Date: Aug 2006
Model: 7130e
Carrier: Sprint
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I can't remember which user I chose during setup to be the BESAdmin. Where can I check that out?

Assuming I did something stupid like set the BESAdmin to be the super admin for the network, shouldn't that account have permissions to everyone's mailbox? One thing at a time though, first I have to find where to setup the account.
Offline  
Old 08-15-2006, 03:12 PM   #4 (permalink)
CrackBerry Addict
 
|||||||'s Avatar
 
Join Date: Jun 2006
Model: 7100
Carrier: Rogers
Posts: 615
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by AlecMm
I can't remember which user I chose during setup to be the BESAdmin. Where can I check that out?

Assuming I did something stupid like set the BESAdmin to be the super admin for the network, shouldn't that account have permissions to everyone's mailbox? One thing at a time though, first I have to find where to setup the account.
The admin user is the user that starts the BlackBerry services, the one you installed BES logged in as.
Offline  
Old 08-15-2006, 03:21 PM   #5 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2006
Model: 8100
Carrier: Voda
Posts: 187
Post Thanks: 0
Thanked 2 Times in 1 Post
Default

Have you copied and registered the cdo.dll in to Windows>System32 on the BES?
Offline  
Old 08-15-2006, 04:12 PM   #6 (permalink)
New Member
 
Join Date: Aug 2006
Model: 7130e
Carrier: Sprint
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, just checked the services all labelled Blackberry and they're all running as the admin for the server, so have full rights to everything.

Where do I get the correct version of CDO.dll? I haven't done that yet.


Also, I just followed the instructions to make sure that a BESAdmin specific login had delegation rights on the Exchange server according to a RIM knowledgebase article linked from this site. Still no joy.

In "Role Administration" in BES all of my rim_db_admin_xxxx accounts have "0" for "Number of Administrators". Is that right? If I click "List administrators" I see the admin account and my BESAdmin specific account I just made, but I can only click the checkbox for each account for one bes_db_admin_xxx. Thoughts?
Offline  
Old 08-15-2006, 04:18 PM   #7 (permalink)
New Member
 
Join Date: Aug 2006
Model: 7130e
Carrier: Sprint
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

BES and Exchange are running on the same physical server btw. Guess I should point that out.
Offline  
Old 08-15-2006, 04:28 PM   #8 (permalink)
CrackBerry Addict
 
|||||||'s Avatar
 
Join Date: Jun 2006
Model: 7100
Carrier: Rogers
Posts: 615
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by AlecMm
Yes, just checked the services all labelled Blackberry and they're all running as the admin for the server, so have full rights to everything.
And that's the problem

Livelink - Redirection
Offline  
Old 08-15-2006, 04:35 PM   #9 (permalink)
New Member
 
Join Date: Aug 2006
Model: 7130e
Carrier: Sprint
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Not sure I follow... How should it be configured?
Offline  
Old 08-15-2006, 04:36 PM   #10 (permalink)
CrackBerry Addict
 
|||||||'s Avatar
 
Join Date: Jun 2006
Model: 7100
Carrier: Rogers
Posts: 615
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by AlecMm
Not sure I follow... How should it be configured?
Domain admins are inherently denied the send as permission which breaks the calendar therefore if you follow the resolution to cause 1 you will be much better.
Offline  
Old 08-15-2006, 04:51 PM   #11 (permalink)
New Member
 
Join Date: Aug 2006
Model: 7130e
Carrier: Sprint
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Oooooh, gotcha.

I just went through and changed each Blackberry service to run as my BESAdmin account which is a member of the administrators and users groups. Plus I did the whole shibang to make sure Send As and the other 2 permissions were set correctly for that user.

If that's all it was all along I'm going to cry.
Offline  
Old 08-15-2006, 05:18 PM   #12 (permalink)
CrackBerry Addict
 
|||||||'s Avatar
 
Join Date: Jun 2006
Model: 7100
Carrier: Rogers
Posts: 615
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Don't cry, You are one of 700 bazillion who have done the same thing.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.