BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-15-2006, 06:58 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2006
Location: Manchester, UK
Model: 7100g
Carrier: BT
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Calendar Sync Issue

Please Login to Remove!

Hi everyone, I hope someone will be able to shed some light on this problem.

(I have searched the forum and cant find an answer).

I'm running BES 4.0.4 with 20 users. Currently eveything is working fine apart from 1 user whose Blackberry Calendar entries dont sync back to his desktop.

After searching the forum I have ;

deleted and resent his service books.
ensured permissions are correct (every other user works)
Checked his wireless sync option is turned on

I then checked the MAGT log file and found a number or errors relating to the problem.

The short version of the message is :

CDOCalendar::UpdateAppointment - Receiving slow sync item from device CDOCalendar::UpdateAppointment - Exception handled.
CDOCalendar::UpdateAppointment - Error in call Allocate MAPI memory for the root appointment source key and entry id.

Does anyone have any ideas?

Thanks in advance. Mark.
Offline  
Old 08-15-2006, 07:34 AM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Jun 2006
Model: 8700t
Carrier: T-Mobile
Posts: 50
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have seen issues with corrupt service books who even I manually deleted them, they were still not gone.. Try this:

-1- Create a backup
-2- Remove the service books from the backup file (Backup&restore - Advanced)
-3- Wipe the device
-4- Restore the backup to the device and do an Enterprise Activation.
Offline  
Old 08-15-2006, 07:55 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2006
Location: Manchester, UK
Model: 7100g
Carrier: BT
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Cheers Flying Dutchman.

Will give that a shot.
Offline  
Old 08-16-2006, 03:59 AM   #4 (permalink)
Thumbs Must Hurt
 
Join Date: Jun 2006
Location: Dubai
Model: 8700c
PIN: 203A948C
Carrier: Etisalat
Posts: 62
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Also make sure the user is not part of any Security Group; as in Domain Admins, Exchange Admins etc
Offline  
Old 08-21-2006, 07:45 AM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2006
Location: Manchester, UK
Model: 7100g
Carrier: BT
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok I have tried the suggestions above but alas the device is still failing to synchronise calendar items back to the desktop.

Spoke to my supplier and they have suggested updating my cdo.dll and mapi files.

Before I do this does anyone have any other suggestions?

(I dont really want to mess deep down in the server while it's working perfectly for everything else but this one user)


Cheers,

Mark.
Offline  
Old 08-21-2006, 07:46 AM   #6 (permalink)
BlackBerry Extraordinaire
 
BBAdmin's Avatar
 
Join Date: Feb 2005
Location: Port 3101.org
Model: .
Carrier: .
Posts: 2,491
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

If CDO was the root cause it would affect the whole user base. Try creating a new MAPI profile for the user though.
__________________

Offline  
Old 08-21-2006, 08:05 AM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2006
Location: Manchester, UK
Model: 7100g
Carrier: BT
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Do you mean just on the users desktop (ie remove and recreate email profile) or are you suggesting I remove the user from the exchange server?

Just clarifying.

Thanks,

Mark.
Offline  
Old 08-21-2006, 08:06 AM   #8 (permalink)
BlackBerry Extraordinaire
 
BBAdmin's Avatar
 
Join Date: Feb 2005
Location: Port 3101.org
Model: .
Carrier: .
Posts: 2,491
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry, should have been more specific, the email profile.
__________________

Offline  
Old 08-21-2006, 08:07 AM   #9 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2006
Location: Manchester, UK
Model: 7100g
Carrier: BT
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK. Will give that a try. Cheers again.

Mark.
Offline  
Old 09-06-2006, 04:29 AM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2006
Location: Manchester, UK
Model: 7100g
Carrier: BT
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just a follow up for those who helpfully posted in my hour of need.

After trying everything that was suggested and checking every setting and .dll I still had the problem of a single users calendar not syncing correctly.

I was in the process of documenting the log files for sending to RIM and Hey Presto all is fine!!!

So all I can think of is that my Blackberry server has become self aware and can repair itself. If only my users were the same!

Anyway, thanks to all who posted.

Mark.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.