BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-15-2006, 10:12 AM   #1 (permalink)
New Member
 
Join Date: Jun 2005
Model: 8800
Carrier: Cingular
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Upgraded to 4.1 SP1 with Strange SQL Errors

Please Login to Remove!

My test environment is Domino 6.5.4 with 2 clustered BES servers - one at version 4.1 HF1 and one still at 4.0.3 HF3. We have 2 SQL servers (primary and failover) with a named instance.

Well, we took the plunge and upgraded to 4.1 SP1 with Sametime but without MDSS. RIM documents that SP1 would fix our named instance issue. The upgrade process itself went smoothly although many of the dialog boxes are different from the 4.1 HF1 upgrade. All other BB functionality appears to work just fine.

However, after the install, the Enterprise Messenger on the device stopped working and the MDS Connection Service stopped working even though both appear started in Services.

The errors that appear in the BBIM and MDAT logs are exactly the same and are as follows;

<BBIM_CN="Our BB Server Name" >:<DEBUG>:<LAYER = SCM, EVENT = General Error connecting to the database.: [Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access denied.>

<MDS-CS_CN="Our BB Server Name">:<DEBUG>:<LAYER = SCM, EVENT = General Error connecting to the database.: [Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access denied.>

Anyone know how to troubleshoot this issue? What should I be checking?

Our SQL account is part of a group that has Server Administrator and Database Creator permissions and nothing has changed with this account since upgrading to 4.1 HF1.

Has anyone else upgraded to SP1 yet?
Offline  
Old 08-15-2006, 01:58 PM   #2 (permalink)
CrackBerry Addict
 
|||||||'s Avatar
 
Join Date: Jun 2006
Model: 7100
Carrier: Rogers
Posts: 615
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Livelink - Redirection
Offline  
Old 08-15-2006, 02:10 PM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2006
Model: 8100
Carrier: Voda
Posts: 187
Post Thanks: 0
Thanked 2 Times in 1 Post
Default

Edited out as previous poster got there first
Offline  
Old 08-15-2006, 02:10 PM   #4 (permalink)
New Member
 
Join Date: Jun 2005
Model: 8800
Carrier: Cingular
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Thanks, But I am aware of that KB Article

We have those files on the BB since 4.1. They remained after upgrading to SP1 but we got those errors anyway.

Can anyone else help?
Offline  
Old 08-15-2006, 02:13 PM   #5 (permalink)
CrackBerry Addict
 
|||||||'s Avatar
 
Join Date: Jun 2006
Model: 7100
Carrier: Rogers
Posts: 615
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by dalxandr
We have those files on the BB since 4.1. They remained after upgrading to SP1 but we got those errors anyway.

Can anyone else help?
Reading is fun!:

Quote:
Originally Posted by THE TKC
Resolution

Install BlackBerry Enterprise Server software version 4.1 Service Pack 1.

Note: If you have used Workaround 2, remove the entries you made in the rimpublic.property files.

Restart the BlackBerry Collaboration Service and the BlackBerry MDS Services.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.