BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-24-2006, 10:37 AM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2006
Location: Canada
Model: 7250
Carrier: Telus
Posts: 131
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 4.0.5 patching issues :(

Please Login to Remove!

We are running BES 4.0.5 for Exchange on Windows 2000 Server, BES is on it's own server.

I upgraded the box from 4.0.0 to 4.0.5 some time again, probably in June when the 5a patch first came out. Anyhow I noticed there are hotfixes that came out for BES in the past few months so I downloaded them (in this case a few times) and unziped them.

When they run on their own I get the following error message:

The upgrade patch cannot be installed by the windows installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch.

I have the correct upgrade patches and I know that since I am the only IT guy here that our BES has 4.0.5a installed, so I am not sure why this isn't working.

Oh in the past I found that BES was looking for the old Service Pack temp folder on the hard drive; why RIM wouldn't make the service complete beats me; so I compressed it and saved it, but even when I replace it in its old place I get the same error message from these patches. (big sigh)

Thanks
Andrew
Offline  
Old 08-24-2006, 08:06 PM   #2 (permalink)
CrackBerry Addict
 
ashworth's Avatar
 
Join Date: Jun 2006
Location: Ontario, Canada
Model: 9000
OS: 4.6
Carrier: Rogers
Posts: 625
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Do you have Service pack 5a extracted to a folder location?

Or maybe you installed Service Pack 5, not Service Pack 5a. What you could try to do is backup your database, install Service Pack 5a then try to apply the Hot fix.
__________________
Cheers,
Ash


My BlackBerry GPS Golf Application | Mileage Calculator
Offline  
Old 08-24-2006, 08:10 PM   #3 (permalink)
iPhone Convert
 
juwaack68's Avatar
 
Join Date: Oct 2005
Location: Tulip City - MI
Model: iP5
OS: 6.0.2
PIN: to beans
Carrier: I'm not
Posts: 13,875
Post Thanks: 3
Thanked 72 Times in 55 Posts
Default

Yes, what Ash said. In order to install a Hotfix you have to extract all of the files of the latest SP to a temporary location. Then during the Hotfix install you'll have to browse to that temporary location.
__________________
No longer a BES Admin, but it was fun while it lasted!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.